Losing connection while on a boat makes boat disappear


NailBat
  • Pending

If you lose connection to the server while out to sea, upon rejoining the server you will be teleported back to the start gate. The boat will remain on the map, but if you return to the area where the boat should be, it will be missing.

Happened twice in a row.


Steps to Reproduce

Be on a boat out at sea.

Lose connection to the server.

Rejoin the server.

client_log.txt



User Feedback


....

was the boat moving while disconnecting? If so, then it simply continued moving, and therefore is no longer on the same position.
The game only saves your position on the map, not that you are on a boat. So when rejoining and on that position is no boat any longer, you would fall into water and therefore start instead at the portal.

If the boat was not moving and unable to do so (anchor) then this is a bug. otherwise not.

  • Like 1

Share this comment


Link to comment
Share on other sites
....

The first time it was moving, but if it had continued to move I'd expect to find a wreckage as it was near rocks. The second time however it was not moving, I was anchored near an island.

If the boat still exists, but simply floated away, shouldn't it appear on my map?

Share this comment


Link to comment
Share on other sites
....
1 hour ago, NailBat said:

The first time it was moving, but if it had continued to move I'd expect to find a wreckage as it was near rocks. The second time however it was not moving, I was anchored near an island.

If the boat still exists, but simply floated away, shouldn't it appear on my map?

As far as I know the map is only updated if it is in your visible range. So everything you can not see, won't update on the map (unless another player is there, or you placed special items that are able to update)

if you still have the savegame and are looking for the boat, try to open the console and type c_gonext("prefab"). Replace prefab with a thing on your boat, for example mast or anchor. This will teleport you to the next found thing (repeat the command if multiples are found). This way you can at least find out if the boat still exists.

But anyway, if this also happend while boat was not able to move, this should not happen and might be a bug.

Edited by Serpens

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now