Godmode/SuperGodMode bugged - game runs out of memory


imsomony
  • Fixed

Hi Klei,

I have a non-caves local server (with mods and adjustments to world settings) where I'm always in SuperGodMode so I can experiment. It's been working absolutely fine up until the past few days, zero issues. The last time I played was either Friday, July 7th, or Saturday, July 8th.

I started the world back up on Friday July 14th, after hotfix 223464: http://forums.kleientertainment.com/topic/80582-game-update-223464/ Thinking it was a mod causing issues, I updated them all and cleaned them. I verified the integrity of my game cache, restarted Steam, and restarted my computer. The old world still crashed, and after much experimentation and flipping mods on/off, I figured out it was c_godmode() or c_supergodmode causing it.

 

Error.JPG


Steps to Reproduce
I made a brand new world. No mods, no caves, and no adjustments to world settings - the only thing I did was use console to run c_supergodmode() and/or c_godmode(). I also experimented with Survival/Endless/Wilderness, and mixes of Public/Friends-Only/Local. Each world crashes after roughly 40 minutes. I've attached my brand new world's client_log and DXDiag, and the error received. I don't have any recent MDMP files, they're all dated 2014. If there's something else you need, just lemme know. If it helps, I used Task Manager to watch my memory performance. With DST running, I would gradually eat through roughly 3 GB and then crash.
  • Like 1


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

@ScottHansen

I can replicate the crashing at around the minute 50 mark or snapshot 8. You don't need godmode or anything of the like.

What's required is to have either "Command Line Arguments: -threaded_physics -threaded_render" or "use_threaded_renderer = true" in client.ini.

So you guys should go revert some of the commits made by @bizziboi. Or announce the render args are deprecated or something.

Without threaded render the game doesn't crash... at least for now. And it doesn't look like it will crash anytime soon (after many hours).

 

  • Like 1
  • Haha 1

Share this comment


Link to comment
Share on other sites

Nice catch @DarkXero, you're awesome! I set that up so long ago I completely forgot about it! I removed " -threaded_physics -threaded_render" from my launch options, and now there's no more crashes or running out of memory.

Share this comment


Link to comment
Share on other sites

Hi @DarkXero

Good catch indeed! I'll have to investigate, as it surprises me.

We'll remove threaded physics, it has a known stability issue. I wasn't aware it was being used. 

I will however investigate threaded renderer. It's expected to use more memory (it's always a trade-off) but not *that* much.

Kaj

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now