Fullscreen resolution wont change/work


csontvazharcos
  • Pending

I can't play the game on fullscreen as it puts itself to the top left corner and does not go fullscreen.

 

ddb06fd67a4e1e04260a1a2504a9edb1.jpg


Steps to Reproduce
Run the game on Win10, 4k desktop. set the game to fullscreen and 1920x1080 resolution


User Feedback


Hi,

Please make sure your video card drivers are up to date and that you do not have any applications running that may capture your screen. Also make sure you do not have any pending windows update.

You could also try manually changing the settings file to match your desktop's resolution
- close DST
- open \Documents\Klei\DoNotStarveTogether\client.ini
- under the [GRAPHICS] label add:
fullscreen_width = x
fullscreen_height = x

replace x with your desktop's resolution width and height respectfully

If these do not help, then please attach your log file (located at \Documents\Klei\DoNotStarveTogether\client_log.txt)

  • Thanks 1

Share this comment


Link to comment
Share on other sites
10 minutes ago, ScottHansen said:

Hi,

Please make sure your video card drivers are up to date and that you do not have any applications running that may capture your screen. Also make sure you do not have any pending windows update.

You could also try manually changing the settings file to match your desktop's resolution
- close DST
- open \Documents\Klei\DoNotStarveTogether\client.ini
- under the [GRAPHICS] label add:
fullscreen_width = x
fullscreen_height = x

replace x with your desktop's resolution width and height respectfully

If these do not help, then please attach your log file (located at \Documents\Klei\DoNotStarveTogether\client_log.txt)

I'm still getting the same issue. If I set the resolution to 4k it works fine however I don't want to run the game on 4k as it has too much of a performance hit on my PC. For others games setting the resolution down to 1080p works perfectly fine. For DST I get this wierd issue. I attached my client log hopefully you can help me as I can't play the game like this.

client_log.txt

Share this comment


Link to comment
Share on other sites
On 20/06/2018 at 9:01 PM, ScottHansen said:

Hi,

Your log file indicates that your video card driver is from October 2017.

Updated it still not working, can't change the resolution on full screen

dfad6d62c7505e78956e98467778f34f.jpg

Share this comment


Link to comment
Share on other sites

So, I just tested this out on my 4k monitor at home and ran into the same issue.

According to the internet, this is apparently a windows thing where it does not like full screen applications running in non-native screen resolutions.

Please change the game's resolution to match your desktop's resolution. If your mouse cannot reach the left arrow in the settings menu (which is a problem I had) then disable full screen mode, press Apply, accept the changes. Now toggle back to full screen mode (do no press apply yet) and change the resolution to match your desktop. Now press Apply.

Should you look on the internet for workarounds, I do not recommend any "solution" that requires you to download other programs.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
52 minutes ago, ScottHansen said:

So, I just tested this out on my 4k monitor at home and ran into the same issue.

According to the internet, this is apparently a windows thing where it does not like full screen applications running in non-native screen resolutions.

Please change the game's resolution to match your desktop's resolution. If your mouse cannot reach the left arrow in the settings menu (which is a problem I had) then disable full screen mode, press Apply, accept the changes. Now toggle back to full screen mode (do no press apply yet) and change the resolution to match your desktop. Now press Apply.

Should you look on the internet for workarounds, I do not recommend any "solution" that requires you to download other programs.

Alright, however I play all my games this way and I never run into this issue, I tried looking for a solution but failed to find any. 

Share this comment


Link to comment
Share on other sites

I am having the same issue, however, my computers native resolution is 1920x1080. At any resolution, the game is placed in the top left corner of my screen. I am running the game on a laptop, Dell Inspiron 15 7000, and even at 1920x1080, it is placed improperly. If I set the game to windowed and fullscreen is the settings.ini showed the windowed resolution to be 2400x1217 which is not my computers fullscreen resolution. Nothing I have seen online seems to help.image.thumb.png.82acb54d7ffbd28f3d4ef117edb52656.png

Share this comment


Link to comment
Share on other sites

I FIXED IT!!!! So here's one possible solution that seemed to work for me:

1. Open the Don't Starve Together install directory (I've got it under "Steam\steamapps\common\Don't Starve Together\")

2. Open folder \bin\ from there

3. Right click on dontstarve_steam.exe and choose "Properties"

4. Go to "Compatibility"-tab

5. Push the "Change high DPI settings"-button

6. Tap the checkbox for both "Use this setting to fix scaling problems" and "Override high DPI scaling behavior". I've got the following options chosen from the drop-down menu:
5dfb816ed0fc2_Screenshot2019-12-19at15_52_48.thumb.png.b2fdbe8c4555331cf07aa4d10ef3914e.png

You may notice that the Windows 7 compatibility mode is on, but I checked and that doesn't matter for this specific bug.

  • Like 1
  • Thanks 2

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now