Fps drops / Fps not 60(120) / crashes


teampatrikCZ1
  • Pending

Hi, I have a problem with my game. My game should run smoothly on 60fps but it doesn't, I sometimes have massive fps drops and my fps is below 60, it only stays at 50-55. I have a gaming laptop with these specs :

 

CPU :        Intel Core i7 7700HQ @ 2.80GHz

                                RAM :       16,0GB Single-Channel Unknown @ 1198MHz (17-17-17-39)

                    Motherboard :       Micro-Star International Co. Ltd. MS-1799 (U3E1)  

                          Graphics :        Generic PnP Monitor (1920x1080@120Hz)
                                                   ntel HD Graphics 630 (MSI)

                                                   4095MB NVIDIA GeForce GTX 1050 Ti (MSI)

                                                   ForceWare version: 397.64
                                                   SLI Disabled    

This problem does also occurs in vanilla, shipwrecked, hamlet and RoG.

Please help. This problem is very annoying and makes the game not enjoyable. I do no use mods. I have tried everything that's on the internet about this problem and I have yet to find the solution. I also varyfied the game cache like 25 times.

This is my fourth attempt at making the devs/admins/mods look at my problem. It has been more than a half of a year since my first post.

log.txt


Steps to Reproduce
Playing the game on a high-end computer.


User Feedback


.... ....
2 hours ago, jantonio said:

@teampatrikCZ1 wrong bug thread if you want help in the single player game, this is for "together".

Yeah this problem does occur in DST, can you read ? Did I say that this bug doesn't occur in DST ?? Why would I post it here if the problem doesn't also occur in DST ?????

Share this comment


Link to comment
Share on other sites
....

@teampatrikCZ1 These steps may or may nor resolve your issue (your laptop seems to be similar to mine, but you seem to have more RAM than me). In the event they don't, you can also contact Windows and Nvidia support to try and resolve the issues (like how I did for two weeks trying to resolve this). I'm assuming your OS is Windows as well. Reddit thread for another user where one of my steps resolved it for them.

Option 1: If its a laptop, click on the battery icon and drag the power mode slider to best performance like this. Do this for when the laptop is both plugged and not plugged in, since the slider, in my case, was different. Keep in mind that every time Windows does an update, you may need to check this battery setting since it changes sometimes for some reason.

Option 2: Right click on your desktop and choose NVIDIA Control Panel. Go to Manage 3D settings -> Program Settings -> Don't Starve(dontstarve_steam.exe). (The execution file will affect both DST and DS. If it doesn't show up, launch DS/T.)

Choose the following settings:

Select the preferred graphics processor: High performance NVIDIA processor

Power management mode: Prefer maximum performance

Threaded optimization: ON

Triple buffering: Off

Vertical Sync: Off

Option 3: Update your display adapters and Firmware in device manager. Go to device manager -> Display adapters. Right click each on and update them.

Option 4: A specific Windows update could be the cause. Windows pushed on update recently, and I was faced with FPS issues AGAIN, and it was not present in the previous build -_-. Rollback the Window's Update BUT FIRST create a restore point for your laptop, manually back up your important files, and have a list of applications you need on hand. 

Once you've got your backup, go to: Settings -> Update and Recovery -> Recovery -> Go Back to an Earlier Build.

It'll ask why you're going back. Select "My apps or devices don't work on this build". It will ask for more info in a box, tell them that you were facing FPS issues. This will take a while. 

If that solved the issue, you need to prevent that update from occurring again, cause Windows will force that bad update to you otherwise. Windows provides software that does that.

Option 5: Reinstall your NVIDIA drivers. Use these two tutorials, both by the same person. Tut1 and tut2.

Option 6: THIS IS A LAST RESORT STEP and is not part of my original reddit comment. Factory reset your laptop and see if you're facing FPS issues even then. If even this fails, I'm out of suggestions.

I guess at that point, update your laptop to the latest state, contact Windows Support and Nvidia Support (cause they'll say update to their latest software), and hope they can fix it.

TLDR:

Spoiler
  • Check if battery is in battery saver, if laptop.
  • Adjust NIVIDIA Control Panel settings.
  • Update display & firmware drivers in device managers.
  • Rollback your versions of Windows if that when you noticed the issue occurring. You can prevent a specific Windows update using the "Show or hide updates" troubleshooter package Windows provides.
  • Reinstall your NVIDIA Drivers. Follow tutorials provided.
  • Factory reset if you can, but it's a last resort step.

 

Edited by lakhnish
tldr; last step

Share this comment


Link to comment
Share on other sites
....
3 hours ago, lakhnish said:

@teampatrikCZ1 These steps may or may nor resolve your issue (your laptop seems to be similar to mine, but you seem to have more RAM than me). In the event they don't, you can also contact Windows and Nvidia support to try and resolve the issues (like how I did for two weeks trying to resolve this). I'm assuming your OS is Windows as well. Reddit thread for another user where one of my steps resolved it for them.

Option 1: If its a laptop, click on the battery icon and drag the power mode slider to best performance like this. Do this for when the laptop is both plugged and not plugged in, since the slider, in my case, was different. Keep in mind that every time Windows does an update, you may need to check this battery setting since it changes sometimes for some reason.

Option 2: Right click on your desktop and choose NVIDIA Control Panel. Go to Manage 3D settings -> Program Settings -> Don't Starve(dontstarve_steam.exe). (The execution file will affect both DST and DS. If it doesn't show up, launch DS/T.)

Choose the following settings:


Select the preferred graphics processor: High performance NVIDIA processor

Power management mode: Prefer maximum performance

Threaded optimization: ON

Triple buffering: Off

Vertical Sync: Off

Option 3: Update your display adapters and Firmware in device manager. Go to device manager -> Display adapters. Right click each on and update them.

Option 4: A specific Windows update could be the cause. Windows pushed on update recently, and I was faced with FPS issues AGAIN, and it was not present in the previous build -_-. Rollback the Window's Update BUT FIRST create a restore point for your laptop, manually back up your important files, and have a list of applications you need on hand. 

Once you've got your backup, go to: Settings -> Update and Recovery -> Recovery -> Go Back to an Earlier Build.

It'll ask why you're going back. Select "My apps or devices don't work on this build". It will ask for more info in a box, tell them that you were facing FPS issues. This will take a while. 

If that solved the issue, you need to prevent that update from occurring again, cause Windows will force that bad update to you otherwise. Windows provides software that does that.

Option 5: Reinstall your NVIDIA drivers. Use these two tutorials, both by the same person. Tut1 and tut2.

Option 6: THIS IS A LAST RESORT STEP and is not part of my original reddit comment. Factory reset your laptop and see if you're facing FPS issues even then. If even this fails, I'm out of suggestions.

I guess at that point, update your laptop to the latest state, contact Windows Support and Nvidia Support (cause they'll say update to their latest software), and hope they can fix it.

TLDR:

  Reveal hidden contents
  • Check if battery is in battery saver, if laptop.
  • Adjust NIVIDIA Control Panel settings.
  • Update display & firmware drivers in device managers.
  • Rollback your versions of Windows if that when you noticed the issue occurring. You can prevent a specific Windows update using the "Show or hide updates" troubleshooter package Windows provides.
  • Reinstall your NVIDIA Drivers. Follow tutorials provided.
  • Factory reset if you can, but it's a last resort step.

 

I will definitely try it and tell you the results, thank you.

Share this comment


Link to comment
Share on other sites
....
On 3/22/2019 at 3:13 PM, lakhnish said:

@teampatrikCZ1 These steps may or may nor resolve your issue (your laptop seems to be similar to mine, but you seem to have more RAM than me). In the event they don't, you can also contact Windows and Nvidia support to try and resolve the issues (like how I did for two weeks trying to resolve this). I'm assuming your OS is Windows as well. Reddit thread for another user where one of my steps resolved it for them.

Option 1: If its a laptop, click on the battery icon and drag the power mode slider to best performance like this. Do this for when the laptop is both plugged and not plugged in, since the slider, in my case, was different. Keep in mind that every time Windows does an update, you may need to check this battery setting since it changes sometimes for some reason.

Option 2: Right click on your desktop and choose NVIDIA Control Panel. Go to Manage 3D settings -> Program Settings -> Don't Starve(dontstarve_steam.exe). (The execution file will affect both DST and DS. If it doesn't show up, launch DS/T.)

Choose the following settings:


Select the preferred graphics processor: High performance NVIDIA processor

Power management mode: Prefer maximum performance

Threaded optimization: ON

Triple buffering: Off

Vertical Sync: Off

Option 3: Update your display adapters and Firmware in device manager. Go to device manager -> Display adapters. Right click each on and update them.

Option 4: A specific Windows update could be the cause. Windows pushed on update recently, and I was faced with FPS issues AGAIN, and it was not present in the previous build -_-. Rollback the Window's Update BUT FIRST create a restore point for your laptop, manually back up your important files, and have a list of applications you need on hand. 

Once you've got your backup, go to: Settings -> Update and Recovery -> Recovery -> Go Back to an Earlier Build.

It'll ask why you're going back. Select "My apps or devices don't work on this build". It will ask for more info in a box, tell them that you were facing FPS issues. This will take a while. 

If that solved the issue, you need to prevent that update from occurring again, cause Windows will force that bad update to you otherwise. Windows provides software that does that.

Option 5: Reinstall your NVIDIA drivers. Use these two tutorials, both by the same person. Tut1 and tut2.

Option 6: THIS IS A LAST RESORT STEP and is not part of my original reddit comment. Factory reset your laptop and see if you're facing FPS issues even then. If even this fails, I'm out of suggestions.

I guess at that point, update your laptop to the latest state, contact Windows Support and Nvidia Support (cause they'll say update to their latest software), and hope they can fix it.

TLDR:

  Reveal hidden contents
  • Check if battery is in battery saver, if laptop.
  • Adjust NIVIDIA Control Panel settings.
  • Update display & firmware drivers in device managers.
  • Rollback your versions of Windows if that when you noticed the issue occurring. You can prevent a specific Windows update using the "Show or hide updates" troubleshooter package Windows provides.
  • Reinstall your NVIDIA Drivers. Follow tutorials provided.
  • Factory reset if you can, but it's a last resort step.

 

It did nothing, nothing worked. It was just a huge waste of time but thx anyway I guess.

Share this comment


Link to comment
Share on other sites
.... ....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now