EResult 9 when trying to update mod?

  • Closed

I made a post about this on the modding forum here but I thought it might be necessary to post it here since it's also a technical issue.

Over the weekend I had an issue updating my mod because I kept receiving an "EResult 9" error from the uploader. The mod itself worked fine and I didn't think there was any corruption, so I thought it had to be on Steam's end. I tried today and I did manage to update my already existing DST mod, but now I'm trying to upload it to DS as well and am now getting the same exact error...

What exactly does this error entail? Is there anything I have to do differently or double check before uploading? As I stated in that post, I had a similar problem uploading a mod earlier in the year because I kept getting "EResult 25" as an error and @PeterA came to the rescue and helped solve the issue (I guess it had something to do on your guys' end?)

I've attached a copy of my mod and the ModUploader log if you want/need to take a look at them. I'm more than happy to comply if you need me to do/check anything for you, I'd just like to be able to update/upload my mods :\


Steps to Reproduce
Upload a mod to the workshop

User Feedback

Ok, after ripping my hair out trying to solve the issue I think I finally figured out what the problem was. Apparently it will not let you upload a mod from the same directory to two different workshop submissions. I had to make a separate directory (even though it's still literally the same mod lol) to upload to DS and it went through...

If I could make a suggestion, it'd be to perhaps change the error I was getting to reflect such an issue :\ had I'd not experimented trying anything I could, I wouldn't have solved this issue. Even according to the log, it really never pointed towards that being an issue. Either that or even laying out the proper guidelines and prerequisites for uploading a mod, like also needing to change the version number with each update or you'll also get an error...Took a little time to figure that one out too lol

It's okay, you guys are still my favorite indie company ;) but yeah you can close this, I think I've managed to figure out my issue

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now