Sign in to follow this  

Dedicated server failed to start


LaughingdogVA
  • Pending

I hadn't played the game in a few months, so I initially thought this was just related to mods, and removed them.  Now I see from other threads this is a recurring problem.

I can create a game *with* mods if I do not enable caves.  But I cannot create a game with caves enabled, mods or not.  If I try, I get the error in the title.  It also does not create any game at all in the "Host a Game" list that would be selectable.  So I'm not sure if it even makes a cluster folder.  But based on time stamps, the attached Cave and Master server logs may be the correct ones.  I have also attached the client_log from "C:\Users\Brian\Documents\Klei\DoNotStarveTogether".  

I saw responses related to "read access" issues.  I have no issues actually doing anything in any of my folders.  However, all folders on my computer, when properties are selected, show the "Read-only" box checked.  Unchecking it and clicking OK appears to change it.  But when selecting "Properties" again, it's checked again when that menu is opened in Windows File Explorer.  I've tried to use this site's advice on how to resolve that, and none of these work, some because my screens don't even have the same options available.

client_log.txt Cave server_log.txt Master server_log.txt


Steps to Reproduce

Open game.  

Select Host a game

Create world

Sign in to follow this  


User Feedback


Hi

Your issue seems to be different than the other people having a similar error message.

CURL ERROR: (login.kleientertainment.com) Could not resolve host: login.kleientertainment.com

If the problem remains, please try to go to login.kleientertainment.com in a web browser and let me know the error message you see. Thanks
 

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites

I can't access the site at all, on any browser, on any computer in my home.  I recently replaced an old Verizon Actiontek router with their newer G3100 router.  Could that be the cause?  Is there anything I should look at in the router settings to try to fix this?

image.png.10a235c545ea5801f9f5b5d1ad247df2.png

Share this comment


Link to comment
Share on other sites

If you are still having problems logging in, could you try pinging the login server and then post the output?

open a command prompt in windows and type:
ping login.kleientertainment.com

And if the ping times out, please run:
tracert login.kleientertainment.com

  • Like 1

Share this comment


Link to comment
Share on other sites

The ping worked.  Info is below.  As for accessing login.kleientertainment.com on a browser, I've verified that I can't access that from any computers in my house, nor can I access it on phones on Verizon or T-mobile services (i.e. wifi turned off on the phone).  

 

Microsoft Windows [Version 10.0.19041.1052]
(c) Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>ping login.kleientertainment.com

Pinging login.kleientertainment.com [13.248.132.235] with 32 bytes of data:
Reply from 13.248.132.235: bytes=32 time=21ms TTL=122
Reply from 13.248.132.235: bytes=32 time=29ms TTL=122
Reply from 13.248.132.235: bytes=32 time=45ms TTL=122
Reply from 13.248.132.235: bytes=32 time=26ms TTL=122

Ping statistics for 13.248.132.235:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 21ms, Maximum = 45ms, Average = 30ms

Share this comment


Link to comment
Share on other sites

The master and caves servers logs both contain "Could not resolve host: login.kleientertainment.com", but the client log does not have this issue. My guess would be the new router, or a windows firewall, or some other security software you have installed is blocking the dedicated servers from talking to the outside world. Please make sure the exe's are not being blocked.

The client runs the \Steam\steamapps\common\Don't Starve Together\bin\dontstarve_steam.exe
The servers run the \Steam\steamapps\common\Don't Starve Together\bin\dontstarve_dedicated_server_nullrenderer.exe

 

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now