Sign in to follow this  

Dedicated server failed to start


chillplayer
  • Pending

My wife and I started a server together and we have a 1946 days world with caves.  Everything was still fine last night after the new patch updated.  However, after I spent 1350 spool to get the Tam o Shanter skin today, it shows "Dedicated server failed to start" message when I tried to load the game.  I can still create a new world with the same settings with no problem, I just can't load into my old world for some reason.  I am using 4 mods (eternal glowcaps n mushlight, lasting endtable decoration, geometric placement, and epic healthbar) but I don't think they caused the problem.  I rolled back 5 days, uninstalled all the mods and try again, no luck...I even sold the new Tam o Shanter skin I just bought and see if that's gonna help and still no luck.  I tried to deactivate my antivirus and verified integrity of game files in steam and it still doesn't help. I tried to transfer the save files to my wife's computer and open it on her end, the same message shows.  Can someone please help me look into it and see what happens coz we spent 1000 hour game time to build this world...Thanks.  Attached is the cluster one server log.

server_log.txt


Steps to Reproduce

Here's the client log. Just in case

client_log.txt

Sign in to follow this  


User Feedback


1 hour ago, Tykvesh said:

@chillplayer Could you upload the whole save file?

Hello Tykvesh,  the zipped cluster_1 exceeded the max total size i can upload here.  Are you looking for a specific file from the cluster_1 folder?  I will upload the client_save in zip just in case you want it.  Thanks alot!!

By the way, I have sent in the whole dontstarvetogether game file folder (35MB) via the submit request option on this site.

client_save.zip

Edited by chillplayer

Share this comment


Link to comment
Share on other sites
11 minutes ago, chillplayer said:

Hello Tykvesh,  the zipped cluster_1 exceeded the max total size i can upload here.  Are you looking for a specific file from the cluster_1 folder?

I'm looking for this file, something in it prevents your world from resuming:

Klei\DoNotStarveTogether\103709574\Cluster_1\Master\save\session\4ED11F7829D3FB93\0000002171

Edited by Tykvesh
Corrected the file path

Share this comment


Link to comment
Share on other sites
9 minutes ago, Tykvesh said:

I'm looking for this file, something in it prevents your world from resuming:

Klei\DoNotStarveTogether\103709574\Cluster_1\Master\save\session\4ED11F7829D3FB93\0000002171

There is no file in the session folder.

1 minute ago, chillplayer said:

There is no file in the session folder.

well I found the file you are looking for from the backup file I created earlier today.  Its not in the Klei folder for some reason.

0000002171

Share this comment


Link to comment
Share on other sites
2 minutes ago, Tykvesh said:

@chillplayer, huh... Maybe I misread something in the server logs. Can you go to Klei\DoNotStarveTogether, and initiate a search for a file named "0000002171"?

image.png.15fd107a8a83fcfec67cbd8d2df0ff23.png

the 4ED zip is from my backup folder and the master zip is from Klei\DoNotStarveTogether

4ED11F7829D3FB93.zip Master.zip

I just did a search in the Klei/DoNotStarveTogether folder and I can find the 000002171 file in these 4 files 

client_log_2020-12-16-17-41-02.txt server_log_2020-12-16-17-37-08.txt server_log_2020-12-16-16-21-57.txt client_log_2020-12-16-15-59-30.txt

Share this comment


Link to comment
Share on other sites

@chillplayer Good news! I've looked into the save file and found the issue. I can repair it so you can play in your world again! Follow these instructions:

  1. Go to your Host Game menu
  2. Find the save that fails to load
  3. Click the folder icon on it, it should say something like "Open Cluster_1"
  4. Upload that folder here!

Don't Starve Together Screenshot 2020.12.17 - 15.02.26.57.png

Share this comment


Link to comment
Share on other sites
17 minutes ago, Tykvesh said:

@chillplayer Good news! I've looked into the save file and found the issue. I can repair it so you can play in your world again! Follow these instructions:

  1. Go to your Host Game menu
  2. Find the save that fails to load
  3. Click the folder icon on it, it should say something like "Open Cluster_1"
  4. Upload that folder here!

Don't Starve Together Screenshot 2020.12.17 - 15.02.26.57.png

which folder? the 4ED one?

Share this comment


Link to comment
Share on other sites
11 minutes ago, Tykvesh said:

@chillplayer The folder that will be opened when you press the "Open Cluster_X" button, it contains everything that belongs to that broken world.

hm..after I pressed the 'Open cluster_1" button, I saw a Cave folder, a Master folder and a cluster configuration setting file, which file should I upload? or do i have to upload every file in that cluster 1 folder?

15 minutes ago, chillplayer said:

hm..after I pressed the 'Open cluster_1" button, I saw a Cave folder, a Master folder and a cluster configuration setting file, which file should I upload? or do i have to upload every file in that cluster 1 folder?

I am not sure how to upload the folder in game...lol

Share this comment


Link to comment
Share on other sites

@chillplayer Here's what you need to do after pressing the "Open Cluster_1" button:

  1. Go back one folder (Alt + Arrow up)
  2. Select the "Cluster_1" folder
  3. Open its menu
  4. Select "Send to" -> "Compressed (zipped folder)"
  5. Upload the zipped folder here

image.png.8b28309f3945410572ee76cbcd43853c.png

 

Share this comment


Link to comment
Share on other sites
1 hour ago, Tykvesh said:

@chillplayer This version of the save should work properly, though I had to reset your caves: Cluster_88.zip

Unzip it in among the other folders named Cluster_1, Cluster_2, etc. After that, another "Chillplayer" world should appear in your Host Game menu.

Awesome!  I just tried to load in the the saved game and it works now!!! Thank you so much. Btw, is there any way to restore the new o shanta skin that I unraveled when I was in panic mode after I found out I cant load into the game after I bought that skin?

3 minutes ago, chillplayer said:

Awesome!  I just tried to load in the the saved game and it works now!!! Thank you so much. Btw, is there any way to restore the new o shanta skin that I unraveled when I was in panic mode after I found out I cant load into the game after I bought that skin?

Also, do you know what's the reason that causing my world broken? I want to avoid that from happening in the future.  Thanks again Tykvesh.

Share this comment


Link to comment
Share on other sites

@chillplayer Glad to help! You can submit a request to restore the unraveled item:

  • Choose the "Account help" category .
  • In the description add your user id KU_98gUIYUs
  • View your past transactions here, find the item that was unraveled
  • Add the name of that item and the date it was unraveled to the description
Spoiler

image.thumb.png.0a6008c26339ba11d8d23fe91420e4c6.png

Quote

Also, do you know what's the reason that causing my world broken? I want to avoid that from happening in the future. 

I don't know if your issue was caused by a mod, but I've added a suggestion for the developers, if it gets adressed this won't be an issue in the future!

Edited by Tykvesh

Share this comment


Link to comment
Share on other sites
22 minutes ago, Tykvesh said:

@chillplayer Glad to help! You can submit a request to restore the unraveled item:

  • Choose the "Account help" category .
  • In the description add your user id KU_98gUIYUs
  • View your past transactions here, find the item that was unraveled
  • Add the name of that item and the date it was unraveled to the description
  Reveal hidden contents

image.thumb.png.0a6008c26339ba11d8d23fe91420e4c6.png

I don't know if your issue was caused by a mod, but I've added a suggestion for the developers, if it gets adressed this won't be an issue in the future!

Ok, anyway, thanks again Tykvesh!!

  • Big Ups 1

Share this comment


Link to comment
Share on other sites
39 minutes ago, zarklord_klei said:

Did you have any weird interactions with a boat and a wobster den the last time you played that save before it got corrupted?

yes theres a boat that has drifted near a wobster den and stucked there.  Visually it's blinking around a wobster den in my world and I still see it in the restored save. Do you think that caused the problem? I am planning to get rid of it when I play later anyway.

Share this comment


Link to comment
Share on other sites
1 hour ago, chillplayer said:

yes theres a boat that has drifted near a wobster den and stucked there.  Visually it's blinking around a wobster den in my world and I still see it in the restored save. Do you think that caused the problem? I am planning to get rid of it when I play later anyway.

Yes, you should remove both the boat and the wobster den via commands or manually breaking them, they are what caused the corruption.

Share this comment


Link to comment
Share on other sites
1 hour ago, zarklord_klei said:

Yes, you should remove both the boat and the wobster den via commands or manually breaking them, they are what caused the corruption.

yea I just pick axed the wobster den that get the boat stucked and now the boat stop blinking. Everything looks normal now.  Thanks for the help guys!

How do you get rid of the boat with command if this happens again? like what command do I use?

Share this comment


Link to comment
Share on other sites
9 hours ago, chillplayer said:

How do you get rid of the boat with command if this happens again? like what command do I use?

You open the console with tilde (~) and send this in the box:

c_find("boat"):Remove()

On the left from the box it should say "Remote", press Ctrl if it says "Local"

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now