Can't update mods


DarknightJ
  • Pending


My mods can't update when I click on the the update key. I tried to reinstall the game and also resubscribe my mods but they appear to show as "workshop - [ID Number]" . The mods don't update at all for some reason and my friend's mods work completely fine.

mods.JPG


Steps to Reproduce
I was trying to host a server for me and my friend


User Feedback


The cause of the issue appears to be that the permissions for the C:\Program Files (x86)\Steam\SteamApps\common\Don't Starve Together\mods directory gets messed up somehow and the game is no longer able to fully modify it. (We think it may have been due to a recent change in Windows 10 via a recent update)

Step 1: go to your SteamApps\common\Don't Starve Together directory, open Properties, and on the Security tab click on Advanced.

Step 2: You may need to disable the permissions inheritance on the mods directory. Do this by clicking on “Disable Inheritance”. The button might say "Change permissions", if so, click on that and enter the username and password for your admin account.

Step 3: When prompted click on “Remove all inherited permissions from this object”.

Step 4: On the Advanced Security Settings window click on Add.

Step 5: Then on the Permission Entry window, click on "Select a principal"

Step 6: In the bottom text area, type "Everyone", and then click "Check Names" and then OK.

Step 7: Now that the Principal is set to "Everyone", make sure that "Applies to:"  is set to "This folder, subfolders and files", and that "Basic permissions:" has "Full control" checked, then click OK.

Step 8: You should now see the new permission entry for "Everyone" that has "Full control" listed under Access. Make sure you check "Replace all child object permission entries with inheritable permission entries from this object", then click OK.
 

  • GL Happy 1

Share this comment


Link to comment
Share on other sites
7 hours ago, JanH said:

The cause of the issue appears to be that the permissions for the C:\Program Files (x86)\Steam\SteamApps\common\Don't Starve Together\mods directory gets messed up somehow and the game is no longer able to fully modify it. (We think it may have been due to a recent change in Windows 10 via a recent update)

Step 1: go to your SteamApps\common\Don't Starve Together directory, open Properties, and on the Security tab click on Advanced.

Step 2: You may need to disable the permissions inheritance on the mods directory. Do this by clicking on “Disable Inheritance”. The button might say "Change permissions", if so, click on that and enter the username and password for your admin account.

Step 3: When prompted click on “Remove all inherited permissions from this object”.

Step 4: On the Advanced Security Settings window click on Add.

Step 5: Then on the Permission Entry window, click on "Select a principal"

Step 6: In the bottom text area, type "Everyone", and then click "Check Names" and then OK.

Step 7: Now that the Principal is set to "Everyone", make sure that "Applies to:"  is set to "This folder, subfolders and files", and that "Basic permissions:" has "Full control" checked, then click OK.

Step 8: You should now see the new permission entry for "Everyone" that has "Full control" listed under Access. Make sure you check "Replace all child object permission entries with inheritable permission entries from this object", then click OK.
 

Hi Jan, I did the steps you told me to and tried updating my mods after that but when I opened steam to play DST the mods still won't update, is there a step I am missing?

Share this comment


Link to comment
Share on other sites

Hello , I did the step correctly , I did miss nothing , when at the end I click on OK and it start doing all the files , it opens a window saying that on this file, I do not have the access so I can't change it. 

Share this comment


Link to comment
Share on other sites

My friend, who is also using Windows 10, is having this same problem. She tried following the steps JanH suggested and it seems to have fixed one mod, but not any of the others.

Share this comment


Link to comment
Share on other sites

The only way that I have found to fix this problem on windows 10 is to restart your computer and run safe mode while in safe mode delete any mod that says you don't have permission to change turn off safe mode and then just re-download them. though constantly restarting your computer just to fix any mod that needs t update probably isn't the best option.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now