Sign in to follow this  

c_rollback


cezarica
  • Pending

Had a unfortunate accident in day 581 and wanted to roll back 1 day, so did c_rollback(1) but didn't actually work cos day is still 581 and feels like the result was more like using 0 and not 1, meaning roll back to begging of the day 581 and not back to 580. c_rollback(2) works just fine getting us back to day 579.


Steps to Reproduce
Look at world time and days and do c_rollback(1) and notice that instead of rolling back one day it doesn't do anything.
Sign in to follow this  


User Feedback


Closed the server with c_shutdown() and started it again from bash (on linux) cos something clearly happened as Bearger didn't spawn at all for 2 seasons in a row and was able to roll back 1 day after another from 615 to 610 cos had a griefer and now refuses to roll any more days before 610... I tried c_rollback() with any number and doesn't roll anything.

All I get is morning of day 610.. so annoying...

Edited by cezarica

Share this comment


Link to comment
Share on other sites

Ah. as I was browsing the tickets I opened and remembered about this and can be safely closed as issues where solved.

The Bearger issue was caused by a guy who was lazy to get out of the base and used a telelocator staff on him, and since he didn't play for a few days we didn't knew that and .. well.. we found him hibernating somewhere far away later on. :)

As for rolling back, I'm an idiot. I left the max_snapshots to default of 6, yeah, can't roll any more days if there isn't any saved and just used the 6 that where saved. The c_rollback() is working just fine now so the issue must have solved itself.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now