Armor Not Auto-Equipping Fast Enough, Killing Players When They Should Have Survived


lakhnish
  • Fixed

If you wear a piece of armor that proceeds to break, you can still die despite having enough HP and a piece of backup armor that should have prevented your death.

I'm assuming the following is happening:

Wear a piece of armor with low durability. Have an extra armor piece of armor of the same type in your inventory.

Get hit -> the armor breaks -> get hit again very quickly (maybe same frame?) -> new armor then auto equips but it's too late and you're dead.

Examples:

 


Steps to Reproduce

Wear a piece of armor with low durability. Have an extra armor piece of armor of the same type in your inventory.

Get hit -> the armor breaks -> get hit again very quickly (maybe same frame?) -> new armor then auto equips but it's too late and you're dead.

 



User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
On 11/24/2021 at 3:39 PM, zarklord_klei said:

Changed Status to Fixed

Is this fix part of the game now? I didn't see it listed in any patch note since this message.

Edited by lakhnish

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now