Farm_plants.lua Error


volkankeles
  • Pending

I don't know this is bug or mod conflict. But my own game host always crashes in 1-2 min.

 

------------

[00:05:51]: Can't find prefab farm_plant_cucumber    
[00:05:51]: [string "scripts/prefabs/farm_plants.lua"]:155: attempt to index local 'plant' (a nil value)
LUA ERROR stack traceback:
scripts/prefabs/farm_plants.lua:155 in (upvalue) ReplaceWithRandomPlant (Lua) <153-168>
   inst = 100229 - farm_plant_randomseed (valid:true)
   plant = nil
scripts/prefabs/farm_plants.lua:432 in (field) fn (Lua) <431-433>
   inst = 100229 - farm_plant_randomseed (valid:true)
   stage = 2
scripts/components/growable.lua:157 in (method) SetStage (Lua) <149-159>
   self =
      targettime = 158.03333333507
      magicgrowable = true
      task = PERIODIC 100229: 158.000000
      stages = table: 09BFA040
      inst = 100229 - farm_plant_randomseed (valid:true)
      growoffscreen = true
      loopstages = true
      loopstages_start = 2
      stage = 2
      domagicgrowthfn = function - scripts/prefabs/farm_plants.lua:577
   stage = 2
scripts/components/growable.lua:84 in (method) DoGrowth (Lua) <71-98>
   self =
      targettime = 158.03333333507
      magicgrowable = true
      task = PERIODIC 100229: 158.000000
      stages = table: 09BFA040
      inst = 100229 - farm_plant_randomseed (valid:true)
      growoffscreen = true
      loopstages = true
      loopstages_start = 2
      stage = 2
      domagicgrowthfn = function - scripts/prefabs/farm_plants.lua:577
   stage = 2
scripts/components/growable.lua:20 in (field) fn (Lua) <19-21>
   inst = 100229 - farm_plant_randomseed (valid:true)
   self =
      targettime = 158.03333333507
      magicgrowable = true
      task = PERIODIC 100229: 158.000000
      stages = table: 09BFA040
      inst = 100229 - farm_plant_randomseed (valid:true)
      growoffscreen = true
      loopstages = true
      loopstages_start = 2
      stage = 2
      domagicgrowthfn = function - scripts/prefabs/farm_plants.lua:577
scripts/scheduler.lua:177 in (method) OnTick (Lua) <155-207>
   self =
      running = table: 09183468
      waitingfortick = table: 091834B8
      tasks = table: 091832D8
      waking = table: 0DF773A8
      attime = table: 09183418
      hibernating = table: 09183120
   tick = 4740
   k = PERIODIC 100229: 158.000000
   v = true
   already_dead = false
scripts/scheduler.lua:371 in (global) RunScheduler (Lua) <369-377>
   tick = 4740
scripts/update.lua:185 in () ? (Lua) <164-243>
   dt = 0.033333335071802
   tick = 4740
   i = 4740

[00:05:51]: [string "scripts/prefabs/farm_plants.lua"]:155: attempt to index local 'plant' (a nil value)
LUA ERROR stack traceback:
    scripts/prefabs/farm_plants.lua:155 in (upvalue) ReplaceWithRandomPlant (Lua) <153-168>
    scripts/prefabs/farm_plants.lua:432 in (field) fn (Lua) <431-433>
    scripts/components/growable.lua:157 in (method) SetStage (Lua) <149-159>
    scripts/components/growable.lua:84 in (method) DoGrowth (Lua) <71-98>
    scripts/components/growable.lua:20 in (field) fn (Lua) <19-21>
    scripts/scheduler.lua:177 in (method) OnTick (Lua) <155-207>
    scripts/scheduler.lua:371 in (global) RunScheduler (Lua) <369-377>
    scripts/update.lua:185 in () ? (Lua) <164-243>
    
[00:05:51]: Warning: Widget:SetFocusFromChild is happening on a widget outside of the screen/widget hierachy. This will cause focus moves to fail. Is     ScriptErrorWidget    not a screen?    
[00:05:51]: stack traceback:
    scripts/widgets/widget.lua:605 in (method) SetFocusFromChild (Lua) <602-627>
    scripts/widgets/widget.lua:624 in (method) SetFocusFromChild (Lua) <602-627>
    scripts/widgets/widget.lua:624 in (method) SetFocusFromChild (Lua) <602-627>
    scripts/widgets/widget.lua:656 in (method) SetFocus (Lua) <629-665>
    scripts/widgets/menu.lua:83 in (method) SetFocus (Lua) <74-85>
    scripts/widgets/scripterrorwidget.lua:109 in (method) OnUpdate (Lua) <102-119>
    scripts/update.lua:95 in () ? (Lua) <33-134>    

server_log.txt client_log.txt


Steps to Reproduce

Nothing special. I tried a lot of version like waiting, walking, building etc. It doesn't matter.



User Feedback


Did you ever get this resolved?

I'm encountering a very very similar error but with the start text

[00:09:21]: Can't find prefab farm_plant_cabbage
[00:09:21]: [string "scripts/prefabs/farm_plants.lua"]:155: attempt to index local 'plant' (a nil value)

Other than that the log looks identical except for times, seeds and other numbers.

I have a few mods on the server, but nothing that handles crops.

 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now