Recommended Posts

FliXis    0

Hello!

No music in the main menu.
In the game itself there is no part of sound effects and musical accompaniment. For example, there is almost no music and sound, as the katana cuts the grass
No such problems were observed before the update on Hamlet.
Linux Mint 18.3.

Share this post


Link to post
Share on other sites
serramatutu    0

Same happening to me.

Ubuntu 18.04 LTS. I tried validating game files through steam and that seems not to be the problem. I've also disabled all mods and restarted the game.

Share this post


Link to post
Share on other sites
ivan_dde    1

Same here. Some sounds are masked so that you can barely hear them. Audio cues for bat/hound attacks, boss audio cues. Some mobs still have sound like the batilisks. I'm running on steam and linux mint 18.3

Share this post


Link to post
Share on other sites
smdrz    0
Quote

FMOD Error: Can't find named sound dontstarve_DLC003/amb/temperate/rainforest
[00:01:25]: FMOD Error: Can't play event dontstarve_DLC003/creatures/enemy/grabbing_vine/attack: Unsupported file or audio format. 

these two linux gets repeated almost on all assets in hamlet dlc

seems linux version of hamlet is missing sound files?

Share this post


Link to post
Share on other sites
BittaJam    1
20 hours ago, smdrz said:

seems linux version of hamlet is missing sound files?

I've managed to extract sound files from the *.fsb files, there are tons of them, so I wasn't able to go through each and every name (at least, yet), but either some files are really missing, or, what looks more promising, there's just an error in the path somewhere. The problem is, there has been no reaction from Klei to that bug, neither here, nor on Steam, so I am not sure if they have paid any attention to it just yet. I hope for the best, and I'm going to keep digging. 

  • Like 1

Share this post


Link to post
Share on other sites
Unqou    3

I confirm also the bug (Ubuntu 14.04 LTS - Steam). I have ALL Don't Starve DLCs (including the soundtrack album dlc) and I confirm this bug is specific on Hamlet. If you open a game with - for example - reign of giants, all sounds works fine.

However main menu will remain silent since the main menu uses the configuration from the last DLC (so Hamlet - the one with sounds problem). It would also be cool if it could be possible to choose a different menu appearance (DS standard, DS ROG, DS SW or DS Ham) and let user to enable the one he/she likes more (obliouvsly... if purchased and installed).

EDIT: Added a log file. I obtained this log file this way:

1) deleted original log.txt

2) started a new session of don't starve (ALL DLCs installed)

3) started a new Hamlet game and survived one day, after collecting grass, some other very basic items (not wooden) and exploring caverns. Intentional die with a suicidal attack on temple against bat with torch.

4) closed the game and updated the resulting log.txt

log.txt

Edited by Unqou
added a log file

Share this post


Link to post
Share on other sites
FliXis    0

I hope this bug will be fixed on December 6th. All the patches bypassed him by ...

Share this post


Link to post
Share on other sites
decripter37    2

Bumping. I opened another discussion on Steam that was ignored.
Even after 6th December, Hamlet still has no sound, it's Debian 9 for me, the files in the folder seems suspiciuos:

.steam/steam/steamapps/common/dont_starve/data/DLC0003/sound/DLC003_music_stream.lst

C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\DSH_SecretSound_V4_short_edit03.wav, quality=0, fsound_loop_off
C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\dsh_Jungle_Theme_V2.wav, quality=0, fsound_loop_normal
C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\dsh_adventureagain_v3.wav, quality=0, fsound_loop_normal
C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\dsh_city_enter_1.wav, quality=0, fsound_loop_normal
C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\dsh_deeprainforest_enter_2.wav, quality=0, fsound_loop_normal
C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\dsh_fight_music_v1.wav, quality=0, fsound_loop_normal
C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\dsh_hamlettheme_v1.wav, quality=0, fsound_loop_normal
C:\Users\Sound Dev PC\Desktop\DoNotStarve\contentsrc\sound_DLC3\music\dsh_ruins_demo02_V1.wav, quality=0, fsound_loop_normal

It seems pretty windows-centric to me, my guess is that "Sound Dev" is a sound developer at Klei and that was a hack to play sounds on the testing pc, then, the Linux version was left behind and it remained with the problem.

  • Thanks 1

Share this post


Link to post
Share on other sites
bizziboi    431

It's actually really strange, I'll have to investigate. The path names are a red herring, that's just where the sounds were when the sound designer was editing stuff, it has no bearing on the final output. The game complains about the sounds being in an unsupported format, but they are no different from what the game has shipped with for all those years as far as I know, so it's puzzling.

As far as I am aware the sound system hasn't changed between Hamlet and before - does (did?) sound work if you play regular Don't Starve?

If you have DST, does sound work there?

As said - I'll have to investigate.

  • Like 1

Share this post


Link to post
Share on other sites
decripter37    2

DS, RoG and SW works good with all the sounds, DST too.
In Hamlet all the non-Hamlet related sounds work.
I'm happy that someone at Klei finally noticed the bug.

Share this post


Link to post
Share on other sites
BrunoFS    0

I do own DST and the sound works ok.

The same applies to vanilla, RG and SW.

The problem on occurs on Hamlet.

Is there any sys info or log I could send to help the investigation?

Share this post


Link to post
Share on other sites
bizziboi    431
21 hours ago, BrunoFS said:

Is there any sys info or log I could send to help the investigation?

Can't tell yet, but will reach out if need be. If it only happens for Hamlet it's probably something non-hardware related. I hope to take a look next week - I am off for two days.

So to make sure I get this right

- Even with the current build a regular world the sound is okay?

- With the current build a regular world that is Hamlet compatible is okay?

- In a Hamlet world, base sound work okay, but new sounds don't play?

Peculiar. Oh, hmmmm, I may have an idea. Let me know.

Thanks

  • Thanks 1

Share this post


Link to post
Share on other sites
decripter37    2
3 hours ago, bizziboi said:

- Even with the current build a regular world the sound is okay?

- With the current build a regular world that is Hamlet compatible is okay?

- In a Hamlet world, base sound work okay, but new sounds don't play?

  1. Yes
  2. Yeah
  3. Yup

I can talk for me at least, everything works, but Hamlet sounds.

  • Thanks 1

Share this post


Link to post
Share on other sites
Andreas45    2
On 12/14/2018 at 4:05 AM, bizziboi said:

- Even with the current build a regular world the sound is okay?

- With the current build a regular world that is Hamlet compatible is okay?

- In a Hamlet world, base sound work okay, but new sounds don't play?

I'm also experiencing this bug and can also confirm yes to all of these.  A few more details:

- SW sounds included in Hamlet also do not seem to work (e.g. hacking, water, etc)

- A new SW game, even with Hamlet compatibility enabled, seems to have all sound working correctly.

- A new ROG game WITHOUT hamlet compatibility has all sounds work correctly

- A new ROG game WITH hamlet compatibility has all sounds work, except for the world generation screen (I tested this a few times to be sure).

log_load_existing_hamlet_game.txt

log_rog_new_game_with_hamlet_compat.txt

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
bizziboi    431

Can confirm it didn't work on my Ubuntu setup either, and it seems I got it working there, so hopefully in the next update it'll work for you guys as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now