Jump to content

[Bug] Audio setting stays at 0


Legs11

Recommended Posts

Hello all!

I am having an issue with my audio settings while playing Don't Starve, and I have noticed this has happened previously with others.

Whenever I try to turn my audio settings up they revert to 0 upon saving the changes

The log information does show this error.

FMOD Error: Error initializing output device. 

 

so I ended up setting my speakers to 16bit playback at 48k Hz, as was told by a few people who had solved their issues. But this did not work

I have also tried these to no avail:

-Realtek driver update (It kept coming back with it being updated already)

-Running game as admin

-Reinstalling game

-Checking the game file integrity (to which one file was bad but was reinstalled)

-Restarting the laptop

-Deleting settings.ini

I also thought it may have been my Razer Kraken Pro V2 headphones that could be causing the problem but when they are unplugged the issue still occurs.

I don't know how long it has been going on for but I do know it was an issue before I downloaded the early access of Hamlet.

I just want to hear the new sounds of Hamlet :(

Thanks for any help!!

 

DxDiag.txt

log.txt

Link to comment
Share on other sites

First off, please ensure that your Windows User Profile has the proper administrative permissions to make changes or save files to your hard drive. 

Also do, you happen to have Nahimic 3D Sound software installed/enabled on your computer? If so, try temporarily disabling this to see if that resolves the audio issue.

If you've tried both steps above and the issue persists, 

1) Go into your Windows Audio Settings;
2) select "Change other sound settings"; 
3) Click on PLAYBACK tab and right-click your default audio playback setting and choose "Properties"
4) Click on the "Advanced" tab and on "Default Format", scroll down the list and set the value to the highest Hz value up to 192000 Hz. (Higher bits is better quality)
5) Click on the "Apply" button to complete the change.

From there, launch the game once more and you should find that the audio is back in order.

Link to comment
Share on other sites

On 11/14/2018 at 4:49 AM, JanH said:

First off, please ensure that your Windows User Profile has the proper administrative permissions to make changes or save files to your hard drive. 

Also do, you happen to have Nahimic 3D Sound software installed/enabled on your computer? If so, try temporarily disabling this to see if that resolves the audio issue.

If you've tried both steps above and the issue persists, 

1) Go into your Windows Audio Settings;
2) select "Change other sound settings"; 
3) Click on PLAYBACK tab and right-click your default audio playback setting and choose "Properties"
4) Click on the "Advanced" tab and on "Default Format", scroll down the list and set the value to the highest Hz value up to 192000 Hz. (Higher bits is better quality)
5) Click on the "Apply" button to complete the change.

From there, launch the game once more and you should find that the audio is back in order.

Thanks for the reply JanH!
 

I am the only account on my laptop and I am admin. Plus I dont have that 3D sound software on my laptop

In regards to your other solution; I did as you said however it is only showing up two options: 16 bit, 48000 Hz and 24bit, 48000 Hz
Ive uninstalled the realtek sound driver (without deleting the software from my computer) and re-installed it after restarting my computer.
Still there is no other options bar those 2
 

I even uninstalled the Realtek audio driver and downloaded the latest one but nothing changed
 

 

Link to comment
Share on other sites

Hi! I'm having this same exact problem.

 

I've tried all of the methods Legs11 mentioned to no avail. I've also tried to change my sound settings as described above but I also only have those two same options to choose from (I also have Realtek). I'd really like to get back into the game, but having no sound is no fun. 

 

If anyone could find a solution for this, it would be much appreciated.

log.txt

DxDiag.txt

Link to comment
Share on other sites

@MovieApparatus Of the following, which have you tried:

  • Reinstall RealTek
  • Disable Nahimik 3D or any other Audio Enhancing Programs through Task Manager
  • Run Troubleshooter with game running without audio (start game then while no sound, right click Sound Icon and select Troubleshoot sound problems)
  • Check if Don't Starve is not muted in Volume Mixer
Link to comment
Share on other sites

9 hours ago, MovieApparatus said:

Checked, I don't have any audio enhancing programs running. I ran the troubleshooter and it didn't find anything. Also the game isn't muted in the mixer.

 

Hadn't reinstalled Realtek before, did that, but still nothing changed :/

This is exactly the same thing for me. Also, I have tried all the things in that post

As annoying as this all is, it is nice to know I'm not the only one having this issue

I have a friend who has an Asus laptop (same as me) but is a few years older and they have more Hz options than I do.

 

OKAY UPDATE

There is definitely something going wrong with Realtek audio and Dont Starve
I connected my bluetooth headphone to my laptop, started the game and changed the settings in game to '3' and it has worked

 

My other headphones that I talked about before don't work, and I think its because when I plug them in they are not recognised as a separate sound device. Rather it still says im using Realtek audio

So there is definitely something going on with Realtek and the Dont Starve game. Someone is not playing nice

 

Thank you all for the help and I hope what I have done helps

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...