bizziboi

If you have the "completely black room" bug we could really use your help

Recommended Posts

I think one of the key triggers for this bug has to be exiting the game while in your house. This has happened to me twice now and both were caused by me returning to the game while inside. On both occasions, when I first logged in the floor was black, but the furniture/machines stayed the same. Leaving and exiting causes everything to go black.

 

((also the game doesn't pause when you click the 'go to forum' option, I just died inside my house while typing this lmao))

log.txt

  • Like 2
  • Sad 2

Share this post


Link to post
Share on other sites
Alarsin    582

The in-game message about the bug helped me to get out. I ran into this bug accidentally when I left and rejoined the game while being inside the house.

log.txt

  • Thanks 1

Share this post


Link to post
Share on other sites
Xanderon    7
1 hour ago, megaunit321312 said:

I think one of the key triggers for this bug has to be exiting the game while in your house. This has happened to me twice now and both were caused by me returning to the game while inside. On both occasions, when I first logged in the floor was black, but the furniture/machines stayed the same. Leaving and exiting causes everything to go black.

 

((also the game doesn't pause when you click the 'go to forum' option, I just died inside my house while typing this lmao))

log.txt

happened to me on some saves without exiting game/to main menu, gameplay without breaks

  • Thanks 1

Share this post


Link to post
Share on other sites
The 2C3D    289
8 minutes ago, beeker23 said:

It happened to me now when I entered the ruins, use the command but it does not work

log.txt

Oh boy... I read this log.txt and it had a several thousand lines of "this thing should be in limbo" followed by over 500 consecutive lines insisting that you did not have hayfever followed by about another thousand "THIS IS IN INTERIOR LIMBO"

Edited by The 2C3D
  • Thanks 1

Share this post


Link to post
Share on other sites
4k33m    26

Went in the first temple on day one. I entered the second room and immediately went back to the first by pressing space. That's when the bug hit me.

log.txt

20181021222719_1.jpg

Edited by 4k33m
  • Thanks 1

Share this post


Link to post
Share on other sites
Lenaiya    11

Logged out yesterday in my house. Logged back in and the walls and floor was black, but I could see everything in the house I had dropped on the ground. I exited my house, then went back inside and that's when the black room dialogue box popped. 

I did subscribe to DS Performance mod in between logging out last night and logging in today. 

log.txt

  • Thanks 1

Share this post


Link to post
Share on other sites
killer1one    1

The bug happened once i reloaded my saved game. I saved and exit when I was inside my hamlet house. Everything was fine. I remember that once I reached the main menu when I was exiting, I ALT+F4 out of the game. Later I went back in, and VOILA, Dark Room. 

Just in case some details I remember: I built 3 chests inside the house, and alchemy engine, a croc pot, and at least one decoration that I don't remember anymore. I was in the fog/rain season. 

If my log is useful, you can ask whatever else you want to know.

log.txt

  • Thanks 1

Share this post


Link to post
Share on other sites
Xanderon    7
6 hours ago, bizziboi said:

Thanks for the logs guys, I am pretty confident I fixed it.

A patch should come Monday.

Great job! Will that fix actual saves or only will prevent it from happening again? also would be awesome if u tell us what cause that? :p

Edited by Xanderon
Patch already here

Share this post


Link to post
Share on other sites
4k33m    26

It hit me again. This time on my house. I entered and all things but not the house textures were visible. Left house, went back in and got the black room screen. 

log.txt

Share this post


Link to post
Share on other sites
bizziboi    1,249
8 hours ago, Xanderon said:

Great job! Will that fix actual saves or only will prevent it from happening again? also would be awesome if u tell us what cause that? :p

Sadly, affected worlds can not be repaired. I contemplated it for sure but getting that working would be rather tricky and I might miss certain things or introduce new bugs in the process. The game will show a pop-up if your world is affected informing you.
New words should not have the issue, unless there lurks another bug that can cause similar issues.

Trying to explain what the issue was is tricky without going into detail about the interior system, which will be documented at some point, but basically when an interior is spawned it's spawned at a "secret location" that is created at worldgen - the interior spawn location. When you leave the interior, it's stored at another "secret location" - the interior storage location.
Due to some faulty logic, if these two were generated in too close proximity, the storage location would move around, causing related calculations to be off, putting things in the wrong location, effectively getting lost.
Finding the bug was made harder because when I realized it might be related to them being in too close proximity, I received a bunch of log files that indicated the two clearly didn't meet the proximity condition, throwing me for a loop until I realized that the storage location itself had jumped out of that range.

I hope that...somewhat makes sense.

 

  • Thanks 3
  • Confused 1

Share this post


Link to post
Share on other sites
zVince    1,047
19 minutes ago, bizziboi said:

Sadly, affected worlds can not be repaired. I contemplated it for sure but getting that working would be rather tricky and I might miss certain things or introduce new bugs in the process. The game will show a pop-up if your world is affected informing you.
New words should not have the issue, unless there lurks another bug that can cause similar issues.

Trying to explain what the issue was is tricky without going into detail about the interior system, which will be documented at some point, but basically when an interior is spawned it's spawned at a "secret location" that is created at worldgen - the interior spawn location. When you leave the interior, it's stored at another "secret location" - the interior storage location.
Due to some faulty logic, if these two were generated in too close proximity, the storage location would move around, causing related calculations to be off, putting things in the wrong location, effectively getting lost.
Finding the bug was made harder because when I realized it might be related to them being in too close proximity, I received a bunch of log files that indicated the two clearly didn't meet the proximity condition, throwing me for a loop until I realized that the storage location itself had jumped out of that range.

I hope that...somewhat makes sense.

 

It makes a lot of sense, when I tried to create a house inside a house. The house created inside the house always occurred the bug xD 

wesfuck

Share this post


Link to post
Share on other sites

I was in my house when I left my game and when I opened it today I encountered the bug. At first, I was able to see my items, but when I exited and re-entered my home it was completely black. I am able to exit the room but not interact with anything, and all of my stuff is in there so I'm worried that I'll have to start over. I had to restart once already due to the outside of map glitch, where I entered a shop close to the edge of the map and was forced outside the map when I exited.

BlackRoom Bug 1.png

BlackRoom Bug 2.png

Share this post


Link to post
Share on other sites