Jump to content

Hamlet runs poorly


Recommended Posts

Now, I will admit it. My pc isn't exactly up to snuff. I have Windows 7 and my parts are outdated. However, it can run Don't Starve and all DLC packs for it, DST servers, and even some power hungry games like A Hat in Time. When I generated my file, I was met with terrible frame rates, laggy inputs, and choppy gameplay. However, it ran well enough to play, so I explored what was new. Exploring new parts of the map was ungodly, but doubling back to previous places was not the worst. I quickly found the ruins to explore, and, bring the dummy I am, decided to hop in on day 1. Surprisingly, it ran smoothly. I guess the abundance of stuff on the over world lagged my game? But, I had the same amount of stuff loaded in on my RoG and SW files and it ran with no problem. I don't exactly know, but playing it is kind of a nightmare. Hopefully Klei fixes this in the proper release.

Link to comment
Share on other sites

Mine was experiencing the same thing. I also am running Windows 7 on slightly older hardware. I turned off weather and lessened some mobs and it helped. But then I also cleaned my CPU and reapplied thermal paste too... In case it was hardware. Still kind of choppy. Makes me wonder if it is beta after all.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...