Recommended Posts

Grifta    1

I have 100% not built any of those, but it's still been invalidated (says failed, and I'm well beyond the 240,000KJ that was fixed in the last hotfix, but I don't have it). I don't think this is a problem with your mod since the other achievement tracker has the same issue.

Are you able to let me know the name of the variable that you're pulling this from? I just need something as a starting point so that I can have a chance at figuring out how to fix it in my save file.

Share this post


Link to post
Share on other sites
Cairath    857
Posted (edited)
1 hour ago, Grifta said:

(says failed, and I'm well beyond the 240,000KJ that was fixed in the last hotfix, but I don't have it

This achievement was NOT fixed. Another two were. Tracking for this one is insanely broken, refer to this post: https://forums.kleientertainment.com/forums/topic/109948-achievements-broken/?page=3&tab=comments#comment-1240589

 

As to field names, Generate240000kJClean.amountProduced and Generate240000kJClean.usedDisallowedBuilding.

I have to fix the 'failed' part in my tracker, the workaround about one issue gone wrong :p 

Edited by Cairath

Share this post


Link to post
Share on other sites
Grifta    1

Ah, thank you for the info, and the field names. I look forward to your mod update.

Share this post


Link to post
Share on other sites
Cairath    857

@Grifta I've just pushed an update with some fixes, including adjustment for today's Sustainable Power fix

Share this post


Link to post
Share on other sites
Cairath    857

New mod from my in-progress automation series, Notification Trigger, available here

An automation device that allows triggering a configurable custom notification.

To set your notification message click the pencil icon next to the building name after you have built it. Character limit: 50.

There are 4 notification types:
- neutral (default with no symbol)
- warning (symbol: [!])
- danger (symbol: [!!])
- danger, will pause when triggered (symbol [!!!])

 

e04a4bc7c8.png

  • Like 1

Share this post


Link to post
Share on other sites
Grifta    1

Looks like once that achievement is flipped to false, it doesn't come back. I tried to dig through the save file, but it's probably quicker for me to restart than to learn how to find and fix the save file. I'll let the devs know if/when I find the building that messes up that trigger. Your tracking mod will really help with that.

Share this post


Link to post
Share on other sites
Cairath    857

@Grifta With today's fix the progress on that has been completely reset anyway. Now daily reports have info about building generated power, and the exclusion list is still only what I provided above.

Make sure that steam actually updated the mod, it's been acting up. The easiest way to recognize if it updated correctly would be checking the number formatting -- I cleaned up a little:

ac0e6f2c49.png

Share this post


Link to post
Share on other sites
Grifta    1

Awesome. Yes, I rechecked the files and it looks like it's works. Thank you again.

Share this post


Link to post
Share on other sites
Grifta    1

Unfortunately it looks like it still doesn't work

The number seems to be locked at 76622.89kJ for some reason (run for ~20 cycles and it's not moving). Tune Up For What? (you listed it as Finely Tuned Machine) also seems to be wonky. I can send my save file if it will help you diagnose the problem.

20190809235135_1.jpg.ab41afd0ec172003464cbe5616680831.jpg

Share this post


Link to post
Share on other sites
Cairath    857
2 hours ago, Grifta said:

Unfortunately it looks like it still doesn't work

The number seems to be locked at 76622.89kJ for some reason (run for ~20 cycles and it's not moving). Tune Up For What? (you listed it as Finely Tuned Machine) also seems to be wonky. I can send my save file if it will help you diagnose the problem.

20190809235135_1.jpg.ab41afd0ec172003464cbe5616680831.jpg

As you can see, old formatting - the mod hasn't updated. I can't help you with steam problems (and it's being awfully stupid recently) but try removing the mod folder, even a few times, til it updates correctly. You will recognize the new version with improved formatting - delimiters and completion % capped at 100% 

Share this post


Link to post
Share on other sites
Grifta    1
Posted (edited)

*sigh* Ok, thank you for coming on this roller coaster ride with me ;). I thought that the font had correctly updated, but as you say this was a Steam issue. Deleting the mod folder worked just fine.

Again, thank you for the mod. I really appreciate people busting their asses to make games just a little better for other players.

Edited by Grifta
  • Like 1

Share this post


Link to post
Share on other sites
Kayle Main    0

I can't find your mod, Piped Algae Terrarium, anywhere in the steam workshop. It's also no longer in your list on github. I really liked it, waiting for it to play ONI.

Share this post


Link to post
Share on other sites
SharraShimada    557

I´ve noticed, your githup only has links to steam. Did i miss something, or is this true? If so, why? With the current steam-problems with the workshop, i like to download the mods directly, and avoid steam problems completely. 

Share this post


Link to post
Share on other sites
SharraShimada    557
1 hour ago, Cairath said:

it does NOT get disabled when all other mods are disabled during a mod error, so you can click that button right away after restart.

How did you achieve that? Is there a flag of some kind, that prevents a mod to be disabled on general error?

Share this post


Link to post
Share on other sites
Outrate    5

Hello! 

Any news about darkness mode? It seems that "absolute zero" mode are also broken... After release this game lost everything that made it interesting.

I can't even find this one:

On 2/2/2019 at 3:24 PM, Cairath said:

Also, released a mod I finished last night: Eerie Colors. 

f74233ae5a.jpg

 

Share this post


Link to post
Share on other sites
Cairath    857
On 07/09/2019 at 9:24 PM, SharraShimada said:

How did you achieve that? Is there a flag of some kind, that prevents a mod to be disabled on general error?

No, not a flag. I re-enable it every time the game does "hurr durr lets disable everything" :p  Not the cleanest solution but it works, used it only due to the nature of this mod.

 

@Outrate

Soz, I've been really busy irl

Lights Out: https://steamcommunity.com/sharedfiles/filedetails/?id=1860377458 - the no-light downsides are still a work in progress, but the general thing works

Eerie colors: https://steamcommunity.com/sharedfiles/filedetails/?id=1860425906

Edited by Cairath
  • Thanks 2

Share this post


Link to post
Share on other sites
Outrate    5
22 hours ago, Cairath said:

@Outrate

Lights Out: https://steamcommunity.com/sharedfiles/filedetails/?id=1860377458 - the no-light downsides are still a work in progress, but the general thing works

Works just great! It perfectly lay on the old save and moreover it correct few bugs with deep black in the space biom (with old mod it became ridiculous 100% black, but now works just fine :))

Share this post


Link to post
Share on other sites
Cairath    857
18 minutes ago, Outrate said:

Works just great! It perfectly lay on the old save and moreover it correct few bugs with deep black in the space biom (with old mod it became ridiculous 100% black, but now works just fine :))

It should also be a LOT better when it comes to performance -- the previous mod's code was quite bad performance wise -- I wrote my own. Currently there's a bug that if you turn on dupe-light they wake themselves up at night (oops) but I will fix that this weekend and try to add new stuff :)
 

and thank you very much for supporting the development! <3

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Ashotep    0

Don't know if it's just me or everybody.  The critter sensors don't copy their setting correctly to each other.  Otherwise it seems to work as promised.  Thanks of all your great mods.

Share this post


Link to post
Share on other sites
Haze33E    14

Someone else made a request list and one of the things they had on the list was teleporters. It would be great if you could make a mod for that.

I was thinking it would be a fiber optic wire system. 

Materials

Fiber optic wire

Either Glass or Plastic + Reed fiber for the wires and have them look similar to automation wire.

Teleport pad 

refined metal, plastic, and glass

Function

A system similar to the transit tubes but dupes can only exit where there's a teleport pad attached to the fiber optic wire. Travel time is instant between pads. 

Multiple dupes can travel both ways at the same time.

Power

I figure power consumption would be 250 W per teleport pad with continuous power draw.

 

No idea if the mod is possible I hope it is though. It's something that has been nagging at me for the past few weeks. So I figured I'd finally ask about it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now