Recommended Posts

Camaro69327    12
10 hours ago, Cairath said:

Alright. Temporarily I've uploaded everything here: https://static.toolsnotincluded.net/Mods.zip

Please switch to steam versions once the mod manager stops acting up -- I ignore complaints with old mod versions :p

Thank you very much.

I was using mods from way back when, (2 years?) and am STILL doing it the old way...:) Steam and ONI mods do not get along ,( I tried ) but the constant , crash, reload, mod is enabled , no its not its disabled, oh wait restart, no click again, got OLD real fast, but if done using the old .dll loader they work , except some that the mod makers have not updated their git hub pages....sigh.

Making large maps still works using the (edit worldgen yaml) and placing mods in the "mod" folder in game dir still works. 

So again thank you very much , for thinking of us that mod a little differently then the masses.

 

:)

Share this post


Link to post
Share on other sites
Cairath    857
1 minute ago, Camaro69327 said:

but if done using the old .dll loader they work

don't use the old modloader please!!! many of my mods are incompatible with it.

the game has its own loader which works just fine, it's just the steam updating that is currently messed up

 

the mod folders should be placed in C:\Users\<user>\Documents\Klei\OxygenNotIncluded\mods\local

 

Share this post


Link to post
Share on other sites
Camaro69327    12

OHHHH....but my game is working...hahahhahh.

back in a bit , gonna test this now, 

LOL>> but my game is installed on E: and the "C:" users is a jump dir pointing to my "user docs on E:...<<<<to funny

Share this post


Link to post
Share on other sites
Cairath    857

All modders have switched to the in-game loading system so your best bet is using that one :) It has some stuff the custom one did not, so some mods may still work in the old one but some will definitely break 

Share this post


Link to post
Share on other sites
Camaro69327    12

So i must have done something wrong....see if it stands out ..

Removed old modloader.dll

Moved mods to a newly created dir (E:\Users\Dark\Documents\Klei\OxygenNotIncluded\mods\local) I had a steam dir but not a "local" dir.

Tried with and without "oni common" , (with files mono.ceil and ONI-common.dlls.)

Nothing i have tried gets my mods loading, its easy to see if working as , the second i load , the "icon (sprite) for material color is MIA and no camera zoom outs, the material color is default and not what i have with material color working.

IN my log i see...

[22:55:47.467] [1] [INFO] Initializing at 2019-08-03 22:55:47.466


[22:55:47.467] [1] [INFO] Save path: E:\Users\Dark\Documents\Klei\OxygenNotIncluded
[22:55:47.752] [1] [INFO] Load mod database
[22:55:47.832] [1] [INFO] ModLoader.dll failed to load. Either it is not present or it encountered an error
[22:55:47.833] [1] [INFO] Load content (DLL) for mods:
[22:55:47.833] [1] [INFO] Load content (Animation) for mods:
[22:55:47.833] [1] [INFO] Load content (Strings) for mods:
[22:55:47.908] [1] [INFO] Distribution platform: Steam
[22:55:47.908] [1] [INFO] Localization.Initialize!
[22:55:47.910] [1] [INFO] Load content (Translation) for mods:
[22:55:47.910] [1] [INFO] Register mods/Local/ and mods/Dev as mod distribution platforms
[22:55:47.913] [1] [INFO] Subscribe to mod biggerbuildingmenu
[22:55:47.914] [1] [INFO]     Already subscribed mod: biggerbuildingmenu

ECT....ect...

In the past it used to say something like ...mod loader missing :using internal mod loader. but i did not see that line this time??

<<patient guy behind screen, can wait a few months till steam and ONI play together nicely as i have not played for the past 4 months because i knew the game was finally going "Launch" and i was going to start a new colony , and wanted new surprises in the game, WOW they have changed a lot...lol, From the early days in ALPHA till now, over 1040 hours. 

Again thank you for all your mods and help , sorry to clutter up your thread..

 

Share this post


Link to post
Share on other sites
Cairath    857
19 minutes ago, Camaro69327 said:

[22:55:47.832] [1] [INFO] ModLoader.dll failed to load. Either it is not present or it encountered an erro

This line is correct.

Have you actually enabled mods in the mod menu after placing them in the local folder? and is every mod in its own folder?

Share this post


Link to post
Share on other sites
Camaro69327    12

lol...not at first i thought that was for steam files only...i am getting closer...I found that out as i ""edited" mods.json" to say "True" instead of false then when i went in game i noticed it had a checkmark for that mod...Don't shake your head...just LOL...

Getting closer...least now it mentions the built in loader.

[23:33:37.873] [1] [INFO] Load mod database
[23:33:37.953] [1] [INFO] ModLoader.dll failed to load. Either it is not present or it encountered an error
[23:33:37.954] [1] [INFO] Load content (DLL) for mods:
[23:33:37.955] [1] [INFO] Using built-in mod system...looking for DLL mods in E:\Users\Dark\Documents\Klei\OxygenNotIncluded\mods/
[23:33:37.956] [1] [INFO] Loading MOD dll: RoomSizeMod.dll
[23:33:37.959] [1] [INFO] Failed to load mod roomsize...disabling
[23:33:37.971] [1] [INFO] Load content (Animation) for mods:
[23:33:37.971] [1] [INFO] Load content (Strings) for mods:

stop laughing damnit...hahah

AND yes i realize this IS the reason you don't want to mess with both steam and the GIT hub....holler and i will stop making you pull your hair out...

<<<stubborn old guy

Share this post


Link to post
Share on other sites
Outrate    5

After mods collapsed I played vanilla for ten minutes.. Wasted ten minutes. 

Share this post


Link to post
Share on other sites
Cairath    857
36 minutes ago, Camaro69327 said:

lol...not at first i thought that was for steam files only...i am getting closer...I found that out as i ""edited" mods.json" to say "True" instead of false then when i went in game i noticed it had a checkmark for that mod...Don't shake your head...just LOL...

Getting closer...least now it mentions the built in loader.

[23:33:37.873] [1] [INFO] Load mod database
[23:33:37.953] [1] [INFO] ModLoader.dll failed to load. Either it is not present or it encountered an error
[23:33:37.954] [1] [INFO] Load content (DLL) for mods:
[23:33:37.955] [1] [INFO] Using built-in mod system...looking for DLL mods in E:\Users\Dark\Documents\Klei\OxygenNotIncluded\mods/
[23:33:37.956] [1] [INFO] Loading MOD dll: RoomSizeMod.dll
[23:33:37.959] [1] [INFO] Failed to load mod roomsize...disabling
[23:33:37.971] [1] [INFO] Load content (Animation) for mods:
[23:33:37.971] [1] [INFO] Load content (Strings) for mods:

stop laughing damnit...hahah

AND yes i realize this IS the reason you don't want to mess with both steam and the GIT hub....holler and i will stop making you pull your hair out...

<<<stubborn old guy

well, roomsize mod isn't mine so I cannot help with it crashing ;) but make sure you've got an updated version of it, I think it was Trevice's and he was updating mods (at least on steam) earlier today

Share this post


Link to post
Share on other sites
Camaro69327    12

@Cairath Thank you for your input.

Mods are now working and i still have an empty steam folder...lol even finally got the "Overlay" for material color to show.

I am using about 10 or 12 of your mods, that is what i originally liked about the GIT hub , i go to your page and ALL your mods show , with one page load i see all your mods and can download them in seconds, instead of with steam i would have to go to ? 34 different pages to have seen all your mods?..

I think i have a handle on this now , thank you again!!!

PS, the mod that is a MUST have for me is >>BiggerCameraZoomOut.dll I cant play without it, and it IS working now.

  • Like 1

Share this post


Link to post
Share on other sites
DesktopMan    35
Posted (edited)

Here's a mod I think would be useful: A pause sensor. Pauses the game when it receives green.

Usage ideas:

  • Temperature of your water supply reaches 20 degrees
  • Oxygen pressure goes below 1000g
  • Fridge is empty
  • Stable has been populated

Can be used for anything that takes a while.

Edited by DesktopMan

Share this post


Link to post
Share on other sites
erny0507    211

I have another crazy idea, after i finish the 3 hatchs art (babies included), what about a new building!
The gene modifier, uses the incubator as a base, i could modify its art, allow to modify eggs, like life span, production rate, and so on and finally allow create new species not found in the world, i have 2 originals I wanna create.
The building would work with recipes, example:
Drecco egg+bleach stone=the slug i made up before
The building would be operated by a researcher.

  • Like 1

Share this post


Link to post
Share on other sites
erny0507    211

Cairath i gave it more thought,
the recipe could be random, cause the ui limitations.
Example
Hatch egg splicing:
Description: Play with this eggs genome, something has to come out right?
Recipe:
1 x hatch egg + something else(posible other eggs?)= new egg

The result is show is a notification if posible, if the trait is unwanted the egg can be cracked.
If posible the egg would show the trait adquired in its tabs like the Industrial Tag.
Another posibility is that not random but the recipe are set straight forward.
Example:
Trait longer life span:
1x hatch egg+ n x abyss bugs eggs =1x hatch egg modified with trait longer life span.

  • Like 1

Share this post


Link to post
Share on other sites
Guinaro    31

Would it be possible to have the Conductive Wire upgrade from 2kW to 4 kW. This would finally allow us to properly use a Large Power Transformer to full capacity.
With your 50 kW mod, we then have:
50 kW and 20 kW heavy lifting wires
Large Power Transformer Output a 4kW to the new 4kW Conductive Wire
Small Power Transformer Output at 1kW to 1kW Basic Power Wire

Thanks for your consideration.
Guinaro

 

Share this post


Link to post
Share on other sites
Cairath    857

@Guinaro I'm gonna pass on that one - I've changed the heavy ones cause it made no sense to me that they are more costly yet the same properties. The normal conductive wire is already a x2 upgrade over the basic wire, so I'm going to leave it at that, despite of transformer logic.

 

Today on "just one more thing that annoys me, I'll finish this and I'll surely play today"

b12a8da4f9.png

Self explanatory I think. Since I didn't have time to actually play to test it well... if something odd happens, let me know :p 

https://steamcommunity.com/sharedfiles/filedetails/?id=1828274492

Share this post


Link to post
Share on other sites
CDoroFF    73
Posted (edited)

Super Sustainable: failed.
but the only generator i built and used is manual generator.

p.s.
It's become ok as soon as one of the dupes used it. 

Edited by CDoroFF

Share this post


Link to post
Share on other sites
Cairath    857
14 minutes ago, CDoroFF said:

Super Sustainable: failed.
but the only generator i built and used is manual generator. How could it be?

Currently bugged at the start of the colony -- it'll fix itself once it actually registers some energy produced. I'll fix it soon

  • Like 1

Share this post


Link to post
Share on other sites
Guinaro    31

@Cairath Are you still working on Eerie Colors? I saw it mentioned earlier in the thread, but couldn't find any reference to it?

Share this post


Link to post
Share on other sites
Grifta    1

Are you able to list the value that makes Super Sustainable true/false? I'm 700 cycles in with never having had any non-sustainable power, but is says false (some speculation that refining coal kills it), and I was hoping to fix that.

Share this post


Link to post
Share on other sites
Cairath    857

@Grifta I have to fix that one. But the only buildings that invalidate it are coal generator, petroleum generator, wood burner and nat gas gen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now