Jump to content

[RESOLVED] Can't access mod screen anymore


Recommended Posts

Hi !

I have DS with RoG et Shipwreck. I play on a mac with os X.12.6, an i3 pross at 3,5ghz, 16gb of ram and NVIDIA GeForce GTX 760.

I was playing just fine yesterday and a little at lunch time. When I tried to reload the game, wanted to check on my mods, the mod screen appeared then game crashed with this message

scripts/screens/modsscreen.lua:190: attempt to index field 'modnames' (a nil value)
LUA ERROR stack traceback:
    scripts/screens/modsscreen.lua:190 in (method) OnStatsQueried (Lua) <175-210>
    scripts/screens/modsscreen.lua:404 in () ? (Lua) <404-404>

On the next launch, I clicked disable mods, then reinstalled those, but same crash. Strangely, I don't have anymore the warning at the launching of the game about using mods. I uninstalled all the mods but still same crash. So I tried to throw the data folder and made a verification with steam that reinstalled all the files, with no luck.

Basically, I tried to launch the game with every folders that I could find moved away, but same problem occurs (in documents/klei in the app don't starve after showing content, and in the user/library/application support/steam/.../.../remote.

I can launch a game or a previous save but as all my mods are deactivated and I can't activate them it means there's still a bug.

I read somewhere that preset for worlds could bring this message so as I made a new preset just before the bug, I replaced them all but with no luck.

Mods, in case it's useful (but as without them it still crash, I don't think it's the problem) : sort inventory, minimap hud, geometric placement, combined status, craft pot.

Here's a screen of the crash (and before it was allowing me to diable mod on the very same screen, not anymore)

captur10.png

 

I spent 3 hours looking for this, so please, help me Klei forum people, you're my only hope (sorry I don't have a droid at hand to transmit my request)

Thanks !

 

[edit] 

Forget to say that I unsubscribed every mod in steam, try to launch, same problem occurred !

And in this topic 

 it was suggested to disable internet connection, which worked !

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...