Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

XxIvanxX

Need Help - Error Publishing Mod

Recommended Posts

XxIvanxX    0

Can somebody help me please?
I try to load a mod with the tool "Do not Starve Mod Tools", but the following error appears: "Error loading the preview image" I do not know what I am doing wrong.

18:49:43: Logging to [C:\Users\Miguel\AppData\Local\Don't Starve Mod Uploader\ModUploader.log]
18:49:43: UploaderApp::OnInit()
18:49:43: EnumerateUserCloudFiles
18:49:43:      0. mod_publish_data_file.zip (2068271 bytes)
18:49:43:      1. mod_publish_preview.png (358905 bytes)
18:49:43:      2. mod_publish_preview.jpg (95362 bytes)
18:49:43: RefreshPublishedModInfo
18:49:43: EnumerateUserPublishedFiles(0)
18:49:43: Progress: Updating Mod List...
18:49:43: OnEnumerateUserPublishedFiles 
18:49:43:    EResult 1, results 0/0
18:49:43:    Complete
18:49:43: EndProgress ok: No mods found
18:49:43: MainFrame::OnRefreshComplete ok: No mods found
18:49:47: GetLuaString: [version_compatible] is not a global lua string!
18:49:47: GetLuaBool: [client_only_mod] is not a global lua boolean!
18:49:47: GetLuaBool: [all_clients_require_mod] is not a global lua boolean!
18:49:53: GetLuaString: [version_compatible] is not a global lua string!
18:49:53: GetLuaBool: [client_only_mod] is not a global lua boolean!
18:49:53: GetLuaBool: [all_clients_require_mod] is not a global lua boolean!
18:49:53: Progress: Publishing...
18:49:53: ShareDataFile [mod_publish_data_file.zip] ...
18:49:53: GenerateModPackage: [C:\Users\Miguel\Desktop\Traducción\]
18:49:53: Progress: Generating mod data file...
18:49:53: CollectFileNames [C:\Users\Miguel\Desktop\Traducción\] []
18:49:53:    [modicon.tex]
18:49:53:    [modicon.xml]
18:49:53:    [modinfo.lua]
18:49:53:    [modmain.lua]
18:49:53:    [preview.png]
18:49:53:    [spanish.mo]
18:49:53:    [spanish.po]
18:49:53: zipOpen(C:\Users\Miguel\AppData\Local\Temp\mod1CA9.tmp) ok
18:49:53: zipOpenNewFileInZip(modicon.tex) ok
18:49:53: fopen(C:\Users\Miguel\Desktop\Traducción\modicon.tex) ok: 0
18:49:53: zipWriteInFileInZip ok
18:49:53: zipOpenNewFileInZip(modicon.xml) ok
18:49:53: fopen(C:\Users\Miguel\Desktop\Traducción\modicon.xml) ok: 0
18:49:53: zipWriteInFileInZip ok
18:49:53: zipOpenNewFileInZip(modinfo.lua) ok
18:49:53: fopen(C:\Users\Miguel\Desktop\Traducción\modinfo.lua) ok: 0
18:49:53: zipWriteInFileInZip ok
18:49:53: zipOpenNewFileInZip(modmain.lua) ok
18:49:53: fopen(C:\Users\Miguel\Desktop\Traducción\modmain.lua) ok: 0
18:49:53: zipWriteInFileInZip ok
18:49:53: zipOpenNewFileInZip(preview.png) ok
18:49:53: fopen(C:\Users\Miguel\Desktop\Traducción\preview.png) ok: 0
18:49:54: zipWriteInFileInZip ok
18:49:54: zipOpenNewFileInZip(spanish.mo) ok
18:49:54: fopen(C:\Users\Miguel\Desktop\Traducción\spanish.mo) ok: 0
18:49:54: zipWriteInFileInZip ok
18:49:54: zipOpenNewFileInZip(spanish.po) ok
18:49:54: fopen(C:\Users\Miguel\Desktop\Traducción\spanish.po) ok: 0
18:49:54: zipWriteInFileInZip ok
18:49:54: Progress: Writing mod data file...
18:49:54: WriteFileToCloud() Writing [C:\Users\Miguel\AppData\Local\Temp\mod1CA9.tmp] to [mod_publish_data_file.zip]
18:49:54: Steam file exists.
18:49:54: Steam FileWrite ok.
18:49:54: Start FileShare [mod_publish_data_file.zip] ...
18:49:54: Progress: Uploading mod data file...
18:49:54: OnShareModFileResult 
18:49:54:    EResult 1, 0cc994b41ce69442
18:49:54: SharePreviewImage [mod_publish_preview.png] ...
18:49:54: Progress: Writing preview image...
18:49:54: WriteFileToCloud() Writing [C:\Users\Miguel\Desktop\Traducción\preview.png] to [mod_publish_preview.png]
18:49:54: Steam file exists.
18:49:55: Steam FileWrite ok.
18:49:55: Start FileShare [mod_publish_preview.png] ...
18:49:55: Progress: Uploading preview image...
18:49:55: OnSharePreviewImgResult 
18:49:55:    EResult 9, ffffffffffffffff
18:49:55: EndProgress FAILED: Error uploading preview image.
18:49:55: MainFrame::OnPublishComplete FAILED: Error uploading preview image.

Share this post


Link to post
Share on other sites
Zillvr    1,554

Hello @XxIvanxX, welcome to the forums. I've never made mods but I think I recall seeing this kind of errors appear in log files a handful of times from other people. I think the issue is with the special character "ó" you have in the mod file name and else where on the mod. I recommend trying to change all letters like that to something simpler like an "o", so the mod loader can read it. Thats my best guess. Good luck.

Cheers.

Share this post


Link to post
Share on other sites
XxIvanxX    0
1 hour ago, Zillvr said:

Hello @XxIvanxX, welcome to the forums. I've never made mods but I think I recall seeing this kind of errors appear in log files a handful of times from other people. I think the issue is with the special character "ó" you have in the mod file name and else where on the mod. I recommend trying to change all letters like that to something simpler like an "o", so the mod loader can read it. Thats my best guess. Good luck.

Cheers.

I changed the character but keep giving the same error :(

Share this post


Link to post
Share on other sites
Zillvr    1,554

@XxIvanxX changed everything? Even inside the mod files lua files, etc. and not just the modfile name.

Share this post


Link to post
Share on other sites
XxIvanxX    0
18 hours ago, Zillvr said:

@XxIvanxX  cambió todo? Incluso dentro de los archivos mod archivos lua, etc. y no solo el nombre del archivo de modificación.

Yes, but nothing, still giving the same error, I tried everything and I can not solve it. Check the .lua files, the mod files and nothing. :(
According to me the problem is in the image, I have tried it with a PNG and JPG image and nothing, the size is correct 512x512 

Share this post


Link to post
Share on other sites