Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

deekay

Fresh DServer without mods have lags.

Recommended Posts

deekay    3

Hi,

I've read some another posts about lags, but I don't get it work better in any way.
On a fresh Server without mods, I am regularly reset while running and it takes some time to pick things up.
See here:

First my Setup:
Dedicated Server - Hetzner https://www.hetzner.com/cloud (CX21)
Debian 9 - 64bit
2vCPUs
4 GB Ram
40GB SSD
The Server is complete fresh installed, only fail2ban was added.
Used install guide (all configs original, tried just the tick_rate = 60 option, but without success)

Home PC
8Core CPU
16 GB DDR4
GTX1080Ti
DualWAN Internet - A fast WAN for downloading and a another WAN for low ping. (Tried both)

 

CMD Ping have 42ms
Ingame Ping (Server browser) have around 55ms

The Server runs smooth:

du9cw2km8gkdglkgn.png

Share this post


Link to post
Share on other sites
Daniel86268    314

I blame the current load/overuse on the virtual cores on your server. What you showed in the video there is the infamous rubberbanding, which is usually either caused by a slow host, or a high latency. And your latency is decently good.

Thing with virtualised Servers is that you aren't the only one using those cores, and during peak loads the server performance might drop (In the video the performance first seemed fine, but later it suddenly dropped really bad, which is a strong indication that there was a load spike on those cores from other users.)

This ofc depends on the Hoster, and the type of server you are renting. For example most people recommend root servers (where you have cores for your own) because you have a much more consistent and high performance.

Share this post


Link to post
Share on other sites
deekay    3

Hetzner is market leader in germany for servers.
And I tried a another one before too, same effect.

I can't rent a complete root Server just for that game.
Then I rent a VPS and lets run Minecraft on it with over 100 Mods, we can play with a few people, without any lags. And Minecraft is very inefficient with java behind it, but still its run much smoother then DST.

Never had problems with VPS on many games - Minecraft, Starbound, Factorio, 7DayToDie and GarrysMod.
 

Anyway it's runs now a bit better with the client config "Lag Compensation"->None.
But smooth is something different!

Share this post


Link to post
Share on other sites
Daniel86268    314

You can also try and see if it runs better when connecting directly to your server instead of going over Klei's servers. In my xp that sometimes can fix or at least reduce lags.

Run

c_connect("<ip>",<port>,"<password>")

from the command line on your main menu and see if it makes things better.

Share this post


Link to post
Share on other sites