Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Recommended Posts

Ondra3211    0

How can I add mods on server?

 

This not working

--There are two functions that will install mods, ServerModSetup and ServerModCollectionSetup. Put the calls to the functions in this file and they will be executed on boot.

--ServerModSetup takes a string of a specific mod's Workshop id. It will download and install the mod to your mod directory on boot.
	--The Workshop id can be found at the end of the url to the mod's Workshop page.
	--Example: http://steamcommunity.com/sharedfiles/filedetails/?id=350811795
	--ServerModSetup("350811795")

--ServerModCollectionSetup takes a string of a specific mod's Workshop id. It will download all the mods in the collection and install them to the mod directory on boot.
	--The Workshop id can be found at the end of the url to the collection's Workshop page.
	--Example: http://steamcommunity.com/sharedfiles/filedetails/?id=379114180
	--ServerModCollectionSetup("379114180")
	

--#Wormhole Marks
ServerModSetup("362175979")

--#Health Info
ServerModSetup("375859599")

--#Global Positions
ServerModSetup("378160973")

--#Food Values
ServerModSetup("458940297")

--#Finder Mod
ServerModSetup("786654500")

--#Epic Health Bar
ServerModSetup("1185229307")

 

-- Use the "ForceEnableMod" function when developing a mod. This will cause the
-- game to load the mod every time no matter what, saving you the trouble of
-- re-enabling it from the main menu.
--
-- Note! You shout NOT do this for normal mod loading. Please use the Mods menu
-- from the main screen instead.

--ForceEnableMod("kioskmode_dst")


-- Use "EnableModDebugPrint()" to show extra information during startup.

--EnableModDebugPrint()

-- Use "EnableModError()" to make the game more strict and crash on bad mod practices.

--EnableModError()

return {
--#Wormhole marks
["workshop-362175979"] = { enabled = true },
--#Health Info
["workshop-375859599"] = { enabled = true },
--#Global Positions
["workshop-378160973"] = { enabled = true },
--#Food Values
["workshop-458940297"] = { enabled = true },
--#Finder Mod
["workshop-786654500"] = { enabled = true },
--#Epic Health Bar
["workshop-1185229307"] = { enabled = true },
}

 

Fixed

Share this post


Link to post
Share on other sites
Daniel86268    364
3 hours ago, Ondra3211 said:

Fixed

I assume you figured it out, and got it working?

I guess the only thing to do then is to say: Have fun playing! :D

Share this post


Link to post
Share on other sites