Jump to content

Error During Initialization (OpenGL Issue) - Haven't been able to play for over a week


DDiran

Recommended Posts

Uuuugggghhh... So I was really enjoying playing Don't Starve.

Then I went ahead and installed Duet Display on my laptop so I can connect my iPad as a second screen. And now DS AND DST have both stopped working completely. 'Error during initialization' shows when starting.

Things I've tried:

1. Restarting Steam
2. Restarting my PC
3. "Verifying Integrity of Game Files" on Steam
4. Editing `Settings.ini`
5. Deleting `Settings.ini` entirely
6. Re-installing DirectX from the installation file provided by DS in program files
7. Changing laptop resolution settings
8. Updating drivers
9. Running `DxDiag` to see if issue is with my hardware. It isn't.
10. Downloaded `DXFix` as it had helped someone else, but the scan returned with an all clear
11. Trying to launch game with Windows compatibility settings enabled.
12. Deleting and re-installing both DS and DST. This was a last resort as I didn't want to lose my saves.

Nothing seems to be working. Which is really annoying given that the game should play perfectly on my laptop at max settings. I tried writing to the Klei Games support email address. Twice. No answer in over a week...

- Error log.txt
- DxDiag.txt
- No need to share settings.ini as it is now empty   

I've exhausted all options and don't know what to do anymore...

 

Link to comment
Share on other sites

Sorry to hear that you are having trouble launching the game, from what you have described, it sounds like the Duet Display software is causing a conflict with the game's initialization process. Could we get you to try temporarily disabling/uninstalling Duet Display to see if that allows the game to launch once more?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...