Sign in to follow this  
code4240

[SOLVED] Getting a custom axe to animate properly

Recommended Posts

code4240    20

EDIT: nevermind! I figured out what was wrong!

A) The reason the krane output was bugged is because some of the textures were used for more than one frame and it didn't realize this so it exported them with weird names and the build didn't reuse anything. I was able to fix this by duplicating some frames in the scml in notepad++. (I ended up duplicating the textures instead later, just for future uses)

B) The BUILD animation in the scml has to have only a single frame in order for the anim to not override the normal ingame anim. Once I fixed that it started using the frames properly. (it was also possible to just delete anim.bin from the zip file that was output but having to do that every time I recompiled would be tedious.)

Since it doesn't seem like there's any other resources for this problem, I'll be posting a template axe for future modders who have trouble with this once I'm done working on it. :D

 

ORIGINAL POST:

I'm trying to make a custom axe. I followed the "handslot item from scratch" tutorial and it worked pretty well for my spear, but it doesn't explain how to do anything that has more than one frame in its movements.

I tried decompiling the axe build into an scml project with krane to look at it, and while it did get the symbols out, the output seemed to be pretty buggy in terms of build data. When I tried copying the data from that (pivot points etc) from that into the custom build to see if it worked, it did animate but they were in the wrong order and not all the frames were showing properly.

I haven't been able to find any templates for axes, I'm not personally aware of any mods that add axes with custom graphics, and I've only see one other question about this problem which went unanswered.

So basically I'm wondering whether anyone could tell me how to get a custom axe that actually looks right.

(I've attached the swap anim so people can look at it. It's using the normal axe frames right now, I wanna get the anim to work before I start making the textures)

 

Edited by code4240

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this