Sign in to follow this  
ImaginaryKnight

Assistance with Custom Axe

Recommended Posts

Hello,

I've been working on a Shadow Wilson mod for a few days and everything seems to be in order, except for the custom axe I'm trying to make.

I made a recipe for it and placed the recipe in the game, but the image for the axe won't show up in game and when you try to create the item it just takes your ingredients and the log notes that it can't find the prefab for the item. 

Spoiler

sh adow error.PNG

The game boots up just fine and the long configuration text from the mod tools at boot-up doesn't show any errors. 

I've included a .zip for the mod but if you need individual files instead let me know. Help would really be appreciated!

shadowwilson dst.zip

Share this post


Link to post
Share on other sites
Aquaterion    821

try this

AddRecipe("shadowaxe", { Ingredient("twigs", 1), Ingredient("flint", 2), Ingredient("nightmarefuel", 2) }, RECIPETABS.WAR, TECH.SCIENCE_ONE,
nil,nil,nil,nil,nil,
"images/inventoryimages/shadowaxe.xml"
)

also, at the top of your modmain.lua you forgot to add "shadowaxe" in the PrefabFiles table.

Edited by Aquaterion

Share this post


Link to post
Share on other sites
16 minutes ago, Aquaterion said:

try this


AddRecipe("shadowaxe", { Ingredient("twigs", 1), Ingredient("flint", 2), Ingredient("nightmarefuel", 2) }, RECIPETABS.WAR, TECH.SCIENCE_ONE,
nil,nil,nil,nil,nil,
"images/inventoryimages/shadowaxe.xml"
)

also, at the top of your modmain.lua you forgot to add "shadowaxe" in the PrefabFiles table.

Thank you very much that seems to have done the trick! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this