Sign in to follow this  
KittenCanaveral

Trouble with Twitch Plays syntax

Recommended Posts

I am having trouble making overrides to the Twitch Plays mod  I wish to disable nightmare ' and tweek the voting and the cooldowns on my dedicated server , but it's not working. I copied the configuration options over and tried to put the settings I wished for in but it's failing and causing all mods to be disabled. 

here are the configuration options form the mod info file, it seems not to have a list of options for each thing to vote for , most other mods I have not had a problem with this, so I am a little confused

configuration_options =
{
    {
        name = "bar_size",
        label = "Action Bar Size",
        options = bar_size_options,
        default = 6,
    },
    {
        name = "vote_period",
        label = "Vote Period (per Player)",
        options = vote_period_options,
        default = 30,
    },
}

local function AddAction(name, votes, cooldown)
    configuration_options[#configuration_options + 1] =
    {
        name = name.."_votes",
        label = "!"..name,
        options = vote_options,
        default = votes,
    }
    configuration_options[#configuration_options + 1] =
    {
        name = name.."_cooldown",
        label = "!"..name.." Cooldown",
        options = cooldown_options,
        default = cooldown,
    }
end

AddAction("biggie", 5, 60)
AddAction("butterfingers", 5, 60)
AddAction("frograin", 10, 90)
AddAction("nightmare", 10, 90)
AddAction("skyfall", 10, 60)
AddAction("smalls", 5, 60)

I have tried

["nightmare"] = {"off"},
["butterfingers"] = {"15, 120"},
["frograin"] = {"15, 90"},

and

["nightmare"] = {"0 , 0"},
["butterfingers"] = {"15, 120"},
["frograin"] = {"15, 90"},

and

["nightmare"] = {"0", "0"},
["butterfingers"] = {"15", "120"},
["frograin"] = {"15", "90"},

 

Share this post


Link to post
Share on other sites
DarkXero    2893
10 hours ago, KittenCanaveral said:

I wish to disable nightmare '

Turn

AddAction("nightmare", 10, 90)

into

--AddAction("nightmare", 10, 90)

in the modinfo.

Even if a command got 0 votes or was turned off, it still came back, if I remember correctly.

But you can try setting the votes to 0 for nightmare.

10 hours ago, KittenCanaveral said:

and tweek the voting and the cooldowns on my dedicated server

["butterfingers"] = {"15, 120"},

should be

["butterfingers_votes"] = 15,
["butterfingers_cooldown"] = 120,

in the modoverrides.lua.

Share this post


Link to post
Share on other sites

nope failed to work at all I tried only commenting out the nightmare string and the modoverides file failed to load

edit , it seems that haveing the config options in my mod overrides at all for this mod borkes up everything even with out any changes .

Edited by KittenCanaveral

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this