V2C

[Game Update] - 174230

Recommended Posts

Soto8969    2,014

Maybe the issue is with the resources? Now that trees can be petrified, trees before the update causes crashes?

Share this post


Link to post
Share on other sites
KimThought    8

at the end of my server log, it says

[00:00:56]: SpawnSaveRecord [nil, skeleton_player] FAILED

so i'm assuming it has something to do with skeletons :/

Share this post


Link to post
Share on other sites
Mudley    1,144

I noticied that I can now change loadouts when offline, is this related to the "Character portraits are now dynamically loaded to save memory" thing?

  • Like 1

Share this post


Link to post
Share on other sites
Dante1102    1

i try make new world with mod and sv work but game crashes at 3mins even i try offline and game still crashes

pls fix is :'(

Edited by Dante1102

Share this post


Link to post
Share on other sites
PeterA    4,986
17 hours ago, Mudley said:

I noticied that I can now change loadouts when offline, is this related to the "Character portraits are now dynamically loaded to save memory" thing?

Nope, shouldn't be affected by the dynamic loading. How are you putting your game into offline mode? Is it happening 100% of the time?

Are you referring to changing your clothing in the lobby/character select, or with the wardrobe, or with the loadout button from the collection screen in the frontend?

Share this post


Link to post
Share on other sites
Mudley    1,144
3 minutes ago, PeterA said:

Nope, shouldn't be affected by the dynamic loading. How are you putting your game into offline mode? Is it happening 100% of the time?

Are you referring to changing your clothing in the lobby/character select, or with the wardrobe, or with the loadout button from the collection screen in the frontend?

By selecting offline while trying to login.

I can change clothing via lobby and wardrobe, but not via the colletion menu.

And yes, 100% of the time.

Edited by Mudley
  • Like 1

Share this post


Link to post
Share on other sites
PeterA    4,986
8 minutes ago, Mudley said:

I can change clothing via lobby and wardrobe, but not via the colletion menu.

Hmm I haven't been able to reproduce this. Do you have any mods or local changes to dressuppanel.lua? Might be worth doing a verify cache in Steam to make sure there aren't any out of date files.

If you're comfortable in lua, you could try adding a print( "### Is game online?", TheNet:IsOnlineMode() ) to line 48 of dressuppanel.lua. That'll tell us if the UI is thinking you're online for some reason.

Share this post


Link to post
Share on other sites
Mudley    1,144
38 minutes ago, PeterA said:

Hmm I haven't been able to reproduce this. Do you have any mods or local changes to dressuppanel.lua? Might be worth doing a verify cache in Steam to make sure there aren't any out of date files.

If you're comfortable in lua, you could try adding a print( "### Is game online?", TheNet:IsOnlineMode() ) to line 48 of dressuppanel.lua. That'll tell us if the UI is thinking you're online for some reason.

I actually just found out that you have to make the game restart via the 'Apply' button on the 'Mods' menu, then it will always happen. And no, no mods active while doing this.

Just informing that, while I'm capable of changing clothes, everything else works as it should when offline, such as the red "Offline" on the top right and the warnings.

Also, I put the code on dressuppanel.lua, but I was not able to notice any difference, it's suppose to go like this, right?

Spoiler

jTYk1GA.png

Nevermind, I'm blind. Here it is, apparently, even with the warning and everything, the game thinks I'm actually online:

Spoiler

10wE5E6.png

 

Edited by Mudley
  • Like 1

Share this post


Link to post
Share on other sites
PeterA    4,986
26 minutes ago, Mudley said:

I actually just found out that you have to make the game restart via the 'Apply' button on the 'Mods' menu, then it will always happen. And no, no mods active while doing this.

Just informing that, while I'm capable of changing clothes, everything else works as it should when offline, such as the red "Offline" on the top right and the warnings.

Interesting! Thanks for tracking down those repro steps!

Share this post


Link to post
Share on other sites
Mudley    1,144
2 minutes ago, PeterA said:

Interesting! Thanks for tracking down those repro steps!

Glad I was able to help, good luck for you guys at the official launch tomorrow!

  • Like 3

Share this post


Link to post
Share on other sites
Maris    229

Note that the order that items are returned is not defined for lua pairs function.

It's important for your new EQUIPSLOT_IDS variable and compatibility and synchronization.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now