255

Dedicated Server Quick Setup Guide - Linux

Recommended Posts

bizziboi    1,929

That's normal, there is no 64 bit version. You probably had to install the libs because the system didn't have the 32 bit versions available.

Share this post


Link to post
Share on other sites
Myszuwa    7
34 minutes ago, bizziboi said:

That's normal, there is no 64 bit version. You probably had to install the libs because the system didn't have the 32 bit versions available.

Right, didnt notice :386, do you see anything strange in log, is there anything else I can check?

Share this post


Link to post
Share on other sites
bizziboi    1,929

No, I don't notice anything strange in the log. Does launching a world with caves from in-game work?

Share this post


Link to post
Share on other sites
Myszuwa    7
2 minutes ago, bizziboi said:

No, I don't notice anything strange in the log. Does launching a world with caves from in-game work?

Yes.

Share this post


Link to post
Share on other sites
bizziboi    1,929

Hmmmm, I'll do some asking around to see if anyone has better ideas than me.

Do you happen to know other people running Debian 9?

Share this post


Link to post
Share on other sites
Myszuwa    7
Just now, bizziboi said:

Do you happen to know other people running Debian 9?

No. It's my first time.
Let me know if you find something.

Share this post


Link to post
Share on other sites
Myszuwa    7
On 26.11.2019 at 11:26 PM, bizziboi said:

Hmmmm, I'll do some asking around to see if anyone has better ideas than me.

Do you happen to know other people running Debian 9?

Well, we change the server. So I got another question.
Is this config alright? I can go into cave and when I leave, I have message "connecting", then "loading" and puff - application doesn't answer. I need to close the window with the game and just log into game again. 


 

MASTER ------------------------
cluster.ini:
[NETWORK]
cluster_name =  ...
cluster_description = ...
cluster_intention = cooperative
cluster_password = ...

[GAMEPLAY]
max_players = 6
pause_when_empty = true

[SHARD]
shard_enabled = true

--
server.ini:
[NETWORK]
server_port = 10999


[SHARD]
is_master = true
bind_ip = 0.0.0.0
master_ip = overworld
cluster_key = random-secret-key
name = overworld


[ACCOUNT]
encode_user_path = true


CAVES -------------------------
cluster.ini:
[NETWORK]
cluster_name =  ...
cluster_description = ...
cluster_password = ...

[SHARD]
shard_enabled = true

--
server.ini:
[NETWORK]
server_port = 11000


[SHARD]
is_master = false
bind_ip = 0.0.0.0
master_ip = overworld
cluster_key = random-secret-key
name = underworld
id = 2935298355


[ACCOUNT]
encode_user_path = true

 

 

 

 Log from master after  leaveing cave

[22:16:43]: ValidateGameSessionToken <token> for <3664271436496857343>
[22:16:43]: Client authenticated: (KU_DcBDQF5Y) myszuwa
[22:16:43]: [Steam] Authenticated host '76561198191558527'
[22:16:43]: [Shard] Completed incoming migration #8 for (KU_DcBDQF5Y)
[22:16:43]: [Shard] Completed migration #8 for player (KU_DcBDQF5Y)
[22:16:43]: [Shard] Writing save location file for (KU_DcBDQF5Y)
[22:16:54]: Resuming user: session/18D86F1AB08B6B8B/A7HMCB6MHSB2/0000000005
[22:16:54]: Could not find anim build FROMNUM
[22:16:54]: Player will spawn close to portal #7
[22:16:54]: Spawning player at: [Load] (518.55, 0.00, -159.72)

Share this post


Link to post
Share on other sites
the_thermal    0

hi:

thanks for this passage. after all the commands i got this :

Sim paused

 Registering slave in China lobby

and i can not found my server in filter of DST

could you give me some help,very thanks 

 

 

OK very thanks. have fixed. it is just ok

Edited by the_thermal

Share this post


Link to post
Share on other sites
SAMULLL    0

How can i customize my server? im making a "worldgenoverride.lua" archive in 'Master' and 'Caves' directories, but the changes do not appear.

Share this post


Link to post
Share on other sites
Zillvr    1,685

Hello @SAMULLL, welcome to the forums. Usually the worldgenoverride.lua doesn't take effect because the world has already been generated prior to adding worldgenoverride.lua changes. For them to take affect, you should reset the world so it can go through the world generation phase again AFTER you've made your changes for the worldgenoverride.lua file.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now