V2C

Dedicated Server Quick Setup Guide - Windows

Recommended Posts

Octial    0

ok so ive been trying for 7 hours now to make a sever in oder to to play with the caves but now that I found this guide and did everything it asked when I start the batch file its says it missing

Don'tstarve_dedicated_server_nullrenderer

it says this twice so how do I fix this

 

Share this post


Link to post
Share on other sites
megastu    6
8 hours ago, Gingerbread said:

You should not copy paste server_token.txt's content. Just take file as a whole and rename it to cluster_token.txt.. Don't go into its content, copy it and paste to a new txt file. It won't work. 

@V2C

Why??

I understand that the token parser or validation will choke if the file isn't terminated with the exact sequence of NUL,CR,LF, whatever. But why is that?

Why don't you do something like this after reading tokens, before validating them?

token = string.match(token, '[%a%d%+]') .. \0

There may be slightly more to it than that, but in principle this would allow it to work so long as a valid token is in there, no matter what kind of nul-byte, line endings, whitespace, or other magic unprintable characters are there. 

It's astonishing to watch people fall on their face over this month after month when a fix seems so trivial! 

Share this post


Link to post
Share on other sites
Gingerbread    324
4 hours ago, doraemoe said:

Each shard need a dedicated cpu core? Is this the reason why I can't run over world and cave at the same time ?

each shard does not need a dedicated cpu core... It is just there is no multi-threading in DST. You should check your log files and see what it says. I don't know why u cannot run both shards.

Share this post


Link to post
Share on other sites
Gingerbread    324
2 hours ago, megastu said:

@V2C

Why??

I understand that the token parser or validation will choke if the file isn't terminated with the exact sequence of NUL,CR,LF, whatever. But why is that?

Why don't you do something like this after reading tokens, before validating them?


token = string.match(token, '[%a%d%+]') .. \0

There may be slightly more to it than that, but in principle this would allow it to work so long as a valid token is in there, no matter what kind of nul-byte, line endings, whitespace, or other magic unprintable characters are there. 

It's astonishing to watch people fall on their face over this month after month when a fix seems so trivial! 

I got you it can be a headache but this is a well known problem happened to me too when I first tried to make a server and I had no idea. It is actually written in all DST dedic server guides (forums, wikia...). "Do not copy its content and copy and paste file itself for server_token.txt aka cluster_token.txt (new name)." You learn it either by falling into that trap or reading everything carefully before doing every little bit of step.

Edited by Gingerbread

Share this post


Link to post
Share on other sites
doraemoe    0
1 hour ago, Gingerbread said:

each shard does not need a dedicated cpu core... It is just there is no multi-threading in DST. You should check your log files and see what it says. I don't know why u cannot run both shards.

By log do you mean server_log.txt under Master and Caves folders? If so, there is nothing interesting, no error, nothing. Just like when one shard start, the other one just stop without say anything.

Share this post


Link to post
Share on other sites
obzerverlk    14
@ToNiO55 @Gingerbread

i just want to know that whether the modoverrides.lua can be used to able the mods....  although we can use the modsetting.lua , but only modoverrides.lua can config the mods ...

and how to use the modoverrides.lua after the update..

Share this post


Link to post
Share on other sites
BeastNips    105

I managed to get past the server token issues. I did as you guys said, dragging instead of copying but I didn't rename it to .txt because it didn't work after the rename.

So one of my servers fires up correctly but on the other one I get a message like "server port occupied". I can't give you the exact one until I'm near a computer but I'll post a screen shot then. 

Any ideas? 

Share this post


Link to post
Share on other sites
ToNiO55    298

Hi all,

if someone is interesting,

i have update my all guides with new settings for install dedicated server with caves on Linux, Windows Server, and on Mac OS X:

Linux:

Windows Server:

Mac OS X:

coming soon, i going update my guide for install,configure and updated mods on dedicated server for all systems, i just need much time for finish my all tests and update the guide, thank you for your waiting

good luck guys and have fun on DST

Edited by ToNiO55
  • Like 1

Share this post


Link to post
Share on other sites
Monkeysnott    10

if i have a rental server (my friends live on the other side of the country and for them to host i have tremendous lag, when i host they have lag. so we rent one in the middle somewhere) can i still set up a caves server some how? i've been trying to for an hour or so but files paths seem different than on my home PC.

Share this post


Link to post
Share on other sites
CassieCroft    73

I am so confused. I rent a dedicated server and their system is so different to this.

I have issued a ticket but the support worker who is helping me said last night that the update has made it very difficult. He is under the impression that I may still need two servers to run the game because the bat folder uses two folders to run the server which is essentially just two servers. He said that it causes issues because each server can only have so many ports or something.

I've been trying to set it up myself but am not having much luck. I have attached a picture which shows my file options in the online server. It doesn't have a Klei folder - so I'm stuck trying to figure out where to put things. Any help would be appreciated. I want to get it up and running again :( While I am grateful for the update I am frustrated too since I am not able to use a service I am paying for. Please help @V2C! :) 

1.JPG.2e607bc2353afdd5abdef0f39a8eed90.J

Share this post


Link to post
Share on other sites
Gingerbread    324
1 hour ago, CassieCroft said:

I am so confused. I rent a dedicated server and their system is so different to this.

I have issued a ticket but the support worker who is helping me said last night that the update has made it very difficult. He is under the impression that I may still need two servers to run the game because the bat folder uses two folders to run the server which is essentially just two servers. He said that it causes issues because each server can only have so many ports or something.

I've been trying to set it up myself but am not having much luck. I have attached a picture which shows my file options in the online server. It doesn't have a Klei folder - so I'm stuck trying to figure out where to put things. Any help would be appreciated. I want to get it up and running again :( While I am grateful for the update I am frustrated too since I am not able to use a service I am paying for. Please help @V2C! :) 

1.JPG.2e607bc2353afdd5abdef0f39a8eed90.J

Did they say it is very difficult? Hmm. They are just trying to buy some time and probably nobody worked on it yet. It is same directory system just locations changed. That customer service and provider really sucks if they cannot fix this in 2 days.I am not really sure even if you fix that manually I wonder if that works because some ports may be blocked by their firewall. I guess better to wait for them to fix in this case.

 

Share this post


Link to post
Share on other sites
Gingerbread    324
4 minutes ago, BeastNips said:

Ok my error message is now:

"Details: SOCKET_PORT_ALREADY_IN_USE"

Any ideas?

If you have a pre-config dedic server try closing the in game server (non dedic server) and run the pre-config server again. If not, then you may wanna try changing the port number that is not used.. Apparently something else is using the port so ur server cannot use that port.

Share this post


Link to post
Share on other sites
BeastNips    105

I'm not running the game at the time if that's what you mean.

Yes I assumed changing the port would help so I've been messing arouynd with the port numbers; would you mind telling me which one I'm changing here?

  • "master_port = 10889" in cluster.ini
  • "server_port = 11000  "master_server_port = 27018"  "authentication_port = 8768" in Master\server.ini
  • "server_port = 11001"  "master_server_port = 27019"  "authentication_port = 8769" in Caves\server.ini

Thanks mate!

Share this post


Link to post
Share on other sites
BeastNips    105

Master:

Spoiler

[00:00:00]: PersistRootStorage is now APP:Klei//DoNotStarveTogether/MyDediServer/Master/
[00:00:00]: Starting Up
[00:00:00]: Version: 166227
[00:00:00]: Current time: Mon Feb 15 10:05:26 2016

[00:00:00]: Don't Starve Together: 166227 WIN32
NNN Build Date: 175
[00:00:00]: Parsing command line
[00:00:00]: Command Line Arguments: -console -cluster MyDediServer -shard Master
[00:00:00]: Initializing Minidump handler
[00:00:00]: ....Done
[00:00:00]: Fixing DPI
[00:00:00]: ...Done
[00:00:00]: THREAD - started 'GAClient' (3840)
[00:00:00]: CurlRequestManager::ClientThread::Main()
[00:00:00]: Legacy saves detected. Migrating to new structure...
[00:00:00]: ProfileIndex:3.46
[00:00:00]: [Connect] PendingConnection::Reset(true)
[00:00:00]: Network tick rate: U=15(2), D=0
[00:00:00]: Network tick rate: U=15(2), D=0
[00:00:00]: Error trying to change cluster setting (NETWORK->cluster_intention) from '' to 'cooperative'
[00:00:00]: Authorized application e:\SteamCMD\steamapps\common\Don't Starve Together Dedicated Server\bin\dontstarve_dedicated_server_nullrenderer.exe is enabled in the firewall.
[00:00:00]: WindowsFirewall - Application already authorized
[00:00:00]: OnLoadPermissionList: APP:Klei//DoNotStarveTogether/MyDediServer/blocklist.txt (Failure)
[00:00:00]: THREAD - started 'ConsoleInput' (3336)
[00:00:00]: OnLoadPermissionList: APP:Klei//DoNotStarveTogether/MyDediServer/adminlist.txt (Failure)
[00:00:00]: OnLoadUserIdList: APP:Klei//DoNotStarveTogether/MyDediServer/whitelist.txt (Failure)
[00:00:00]: Token retrieved from: APP:Klei//DoNotStarveTogether/MyDediServer/cluster_token.txt
[00:00:00]: Token retrieved from: APP:Klei//DoNotStarveTogether/MyDediServer/cluster_token.txt
[00:00:00]: cGame::InitializeOnMainThread
[00:00:00]: Renderer initialize: Okay
[00:00:00]: AnimManager initialize: Okay
[00:00:00]: Buffers initialize: Okay
[00:00:00]: cDontStarveGame::DoGameSpecificInitialize()
[00:00:00]: FMOD Error: An invalid object handle was used.
[00:00:00]: GameSpecific initialize: Okay
[00:00:00]: cGame::StartPlaying
[00:00:00]: LOADING LUA
[00:00:00]: DoLuaFile scripts/main.lua
[00:00:00]: DoLuaFile loading buffer scripts/main.lua
[00:00:01]: scripts/main.lua(166,1) running main.lua
    
[00:00:01]: loaded modindex    
[00:00:01]: ModIndex: Beginning normal load sequence for dedicated server.
    
[00:00:01]: DownloadMods(0)
[00:00:01]: FMOD Error: An invalid object handle was used.
[00:00:02]: LOADING LUA SUCCESS
[00:00:02]: PlayerDeaths could not load morgue    
[00:00:02]: PlayerHistory could not load player_history    
[00:00:02]: bloom_enabled    false    
[00:00:02]: loaded saveindex    
[00:00:02]: OnFilesLoaded()    
[00:00:02]: OnUpdatePurchaseStateComplete    
[00:00:10]:     Load FE    
[00:00:10]:     Load FE: done    
[00:00:10]: ModIndex: Load sequence finished successfully.    
[00:00:10]: Reset() returning
[00:00:12]: [200] Account Communication Success (6)
[00:00:12]: Received (KU_H6dp9dW9) from TokenPurpose
[00:00:12]: Starting Dedicated Server Game    
[00:00:12]: Network tick rate: U=15(2), D=0
[00:00:12]: About to start a server with the following settings:
[00:00:12]:   Dedicated: true
[00:00:12]:   Online: true
[00:00:12]:   Passworded: false
[00:00:12]:   ServerPort: 10999
[00:00:12]:   SteamAuthPort: 8766
[00:00:12]:   SteamMasterServerPort: 27016
[00:00:12]:   ClanID: false
[00:00:12]:   ClanOnly: false
[00:00:12]:   ClanAdmin: false
[00:00:12]:   LanOnly: false
[00:00:12]:   FriendsOnly: false
[00:00:12]:   EnablePunchthrough: false
[00:00:12]:   EnableAutosaver: false
[00:00:12]:   PVP: false
[00:00:12]:   MaxPlayers: 16
[00:00:12]:   GameMode: survival
[00:00:12]:   OverridenDNS:
[00:00:12]:   PauseWhenEmpty: false
[00:00:12]:   InternetBroadcasting: true
[00:00:12]:   Intent: cooperative
[00:00:12]: [Warning] Could not confirm port 10999 is open in the firewall.
[00:00:12]: [Shard] Shard server mode disabled by configuration file
[00:00:12]: Online Server Started on port: 10999
[00:00:12]: Error trying to change cluster setting (NETWORK->cluster_name) from '' to '[Host]'s World'
[00:00:12]: Collecting garbage...
[00:00:12]: lua_gc took 0.01 seconds
[00:00:12]: ~ShardLuaProxy()
[00:00:12]: ~ItemServerLuaProxy()
[00:00:12]: ~InventoryLuaProxy()
[00:00:12]: ~NetworkLuaProxy()
[00:00:12]: ~SimLuaProxy()
[00:00:12]: lua_close took 0.01 seconds
[00:00:12]: ReleaseAll
[00:00:12]: ReleaseAll Finished
[00:00:12]: cGame::StartPlaying
[00:00:12]: LOADING LUA
[00:00:12]: DoLuaFile scripts/main.lua
[00:00:12]: DoLuaFile loading buffer scripts/main.lua
[00:00:12]: scripts/main.lua(166,1) running main.lua
    
[00:00:12]: loaded modindex    
[00:00:12]: ModIndex: Beginning normal load sequence for dedicated server.
    
[00:00:12]: LOADING LUA SUCCESS
[00:00:12]: PlayerDeaths could not load morgue    
[00:00:12]: PlayerHistory could not load player_history    
[00:00:12]: bloom_enabled    false    
[00:00:12]: loaded saveindex    
[00:00:12]: OnFilesLoaded()    
[00:00:12]: OnUpdatePurchaseStateComplete    
[00:00:12]:     Unload FE    
[00:00:12]:     Unload FE done    
[00:00:13]:     LOAD BE    
[00:00:14]:     LOAD BE: done    
[00:00:14]: Loading world: session/61E8130D91837C92/0000000005    
[00:00:14]: Save file is at version 1    
[00:00:15]: Begin Session: 61E8130D91837C92
[00:00:15]: saving to server_temp/server_save    
[00:00:15]: MiniMapComponent::AddAtlas( minimap/minimap_data.xml )
[00:00:15]: Could not preload undefined prefab 0x1872ccf0 (FROMNUM)
[00:00:15]: Loading Nav Grid    
[00:00:15]: setting     summerlength    15    
[00:00:15]: setting     isnightmaredawn    false    
[00:00:15]: setting     elapseddaysinseason    0    
[00:00:15]: setting     isfullmoon    false    
[00:00:15]: setting     moisture    14.116537094116    
[00:00:15]: setting     cavephase    day    
[00:00:15]: setting     isnightmarewild    false    
[00:00:15]: setting     moonphase    new    
[00:00:15]: setting     precipitationrate    0    
[00:00:15]: setting     iswet    false    
[00:00:15]: setting     winterlength    15    
[00:00:15]: setting     temperature    31.186368737118    
[00:00:15]: setting     isnightmarewarn    false    
[00:00:15]: setting     iswinter    false    
[00:00:15]: setting     moistureceil    873.43975830078    
[00:00:15]: setting     isday    true    
[00:00:15]: setting     israining    false    
[00:00:15]: setting     remainingdaysinseason    20    
[00:00:15]: setting     precipitation    none    
[00:00:15]: setting     wetness    0    
[00:00:15]: setting     isnightmarecalm    false    
[00:00:15]: setting     timeinphase    0.23532803853353    
[00:00:15]: setting     isdusk    false    
[00:00:15]: setting     iscavedusk    false    
[00:00:15]: setting     isautumn    true    
[00:00:15]: setting     issnowing    false    
[00:00:15]: setting     iscaveday    true    
[00:00:15]: setting     phase    day    
[00:00:15]: setting     snowlevel    0    
[00:00:15]: setting     issnowcovered    false    
[00:00:15]: setting     autumnlength    20    
[00:00:15]: setting     pop    0.016162004259548    
[00:00:15]: setting     nightmaretime    0    
[00:00:15]: setting     springlength    20    
[00:00:15]: setting     isspring    false    
[00:00:15]: setting     nightmarephase    none    
[00:00:15]: setting     season    autumn    
[00:00:15]: setting     time    0.11766401926676    
[00:00:15]: setting     iscavenight    false    
[00:00:15]: setting     cycles    0    
[00:00:15]: setting     isnight    false    
[00:00:15]: setting     nightmaretimeinphase    0    
[00:00:15]: setting     issummer    false    
[00:00:17]: Reconstructing topology    
[00:00:17]:     ...Sorting points    
[00:00:17]:     ...Sorting edges    
[00:00:17]:     ...Connecting nodes    
[00:00:17]:     ...Validating connections    
[00:00:17]:     ...Housekeeping    
[00:00:17]:     ...Done!    
[00:00:17]: 1 uploads added to server. From server_temp
[00:00:17]: Telling Client our new session identifier: 61E8130D91837C92
[00:00:17]: ModIndex: Load sequence finished successfully.    
[00:00:17]: Reset() returning
[00:00:17]: [Steam] SteamGameServer_Init(8766, 10999, 27016)
[00:00:17]: [Steam] SteamGameServer_Init success
[00:00:17]: Validating portal[7] <-> <nil>[7] (inactive)    
[00:00:17]: Validating portal[10] <-> <nil>[10] (inactive)    
[00:00:17]: Validating portal[6] <-> <nil>[6] (inactive)    
[00:00:17]: Validating portal[8] <-> <nil>[8] (inactive)    
[00:00:17]: Validating portal[1] <-> <nil>[1] (inactive)    
[00:00:17]: Validating portal[3] <-> <nil>[3] (inactive)    
[00:00:17]: Validating portal[9] <-> <nil>[9] (inactive)    
[00:00:17]: Validating portal[4] <-> <nil>[4] (inactive)    
[00:00:17]: Validating portal[5] <-> <nil>[5] (inactive)    
[00:00:17]: Validating portal[2] <-> <nil>[2] (inactive)    
[00:01:00]: Serializing world: session/61E8130D91837C92/0000000006
[00:01:00]: Could not unload undefined prefab 0x1872ccf0 (FROMNUM)
[00:01:00]: Collecting garbage...
[00:01:00]: lua_gc took 0.06 seconds
[00:01:00]: ~ShardLuaProxy()
[00:01:00]: ~ItemServerLuaProxy()
[00:01:00]: ~InventoryLuaProxy()
[00:01:00]: ~NetworkLuaProxy()
[00:01:00]: ~SimLuaProxy()
[00:01:00]: lua_close took 0.08 seconds
[00:01:00]: CurlRequestManager::ClientThread::Main() complete
[00:01:00]: HttpClient2 discarded 1 callbacks.
[00:01:00]: Shutting down

 

Caves:

Spoiler

[00:00:00]: PersistRootStorage is now APP:Klei//DoNotStarveTogether/MyDediServer/Caves/
[00:00:00]: Starting Up
[00:00:00]: Version: 166227
[00:00:00]: Current time: Mon Feb 15 10:05:26 2016

[00:00:00]: Don't Starve Together: 166227 WIN32
NNN Build Date: 175
[00:00:00]: Parsing command line
[00:00:00]: Command Line Arguments: -console -cluster MyDediServer -shard Caves
[00:00:00]: Initializing Minidump handler
[00:00:00]: ....Done
[00:00:00]: Fixing DPI
[00:00:00]: ...Done
[00:00:00]: THREAD - started 'GAClient' (5564)
[00:00:00]: CurlRequestManager::ClientThread::Main()
[00:00:00]: Legacy saves detected. Migrating to new structure...
[00:00:00]: ProfileIndex:3.42
[00:00:00]: [Connect] PendingConnection::Reset(true)
[00:00:00]: Network tick rate: U=15(2), D=0
[00:00:00]: Network tick rate: U=15(2), D=0
[00:00:00]: Error trying to change cluster setting (NETWORK->cluster_intention) from '' to 'cooperative'
[00:00:00]: Authorized application e:\SteamCMD\steamapps\common\Don't Starve Together Dedicated Server\bin\dontstarve_dedicated_server_nullrenderer.exe is enabled in the firewall.
[00:00:00]: WindowsFirewall - Application already authorized
[00:00:00]: OnLoadPermissionList: APP:Klei//DoNotStarveTogether/MyDediServer/blocklist.txt (Failure)
[00:00:00]: THREAD - started 'ConsoleInput' (628)
[00:00:00]: OnLoadPermissionList: APP:Klei//DoNotStarveTogether/MyDediServer/adminlist.txt (Failure)
[00:00:00]: OnLoadUserIdList: APP:Klei//DoNotStarveTogether/MyDediServer/whitelist.txt (Failure)
[00:00:00]: Token retrieved from: APP:Klei//DoNotStarveTogether/MyDediServer/cluster_token.txt
[00:00:00]: Token retrieved from: APP:Klei//DoNotStarveTogether/MyDediServer/cluster_token.txt
[00:00:00]: cGame::InitializeOnMainThread
[00:00:00]: Renderer initialize: Okay
[00:00:00]: AnimManager initialize: Okay
[00:00:00]: Buffers initialize: Okay
[00:00:00]: cDontStarveGame::DoGameSpecificInitialize()
[00:00:00]: FMOD Error: An invalid object handle was used.
[00:00:00]: GameSpecific initialize: Okay
[00:00:00]: cGame::StartPlaying
[00:00:00]: LOADING LUA
[00:00:00]: DoLuaFile scripts/main.lua
[00:00:00]: DoLuaFile loading buffer scripts/main.lua
[00:00:01]: scripts/main.lua(166,1) running main.lua
    
[00:00:01]: loaded modindex    
[00:00:01]: ModIndex: Beginning normal load sequence for dedicated server.
    
[00:00:01]: DownloadMods(0)
[00:00:01]: FMOD Error: An invalid object handle was used.
[00:00:02]: LOADING LUA SUCCESS
[00:00:02]: PlayerDeaths could not load morgue    
[00:00:02]: PlayerHistory could not load player_history    
[00:00:02]: bloom_enabled    false    
[00:00:02]: loaded saveindex    
[00:00:02]: OnFilesLoaded()    
[00:00:02]: OnUpdatePurchaseStateComplete    
[00:00:10]:     Load FE    
[00:00:10]:     Load FE: done    
[00:00:10]: ModIndex: Load sequence finished successfully.    
[00:00:10]: Reset() returning
[00:00:12]: [200] Account Communication Success (6)
[00:00:12]: Received (KU_H6dp9dW9) from TokenPurpose
[00:00:12]: Starting Dedicated Server Game    
[00:00:12]: Network tick rate: U=15(2), D=0
[00:00:12]: About to start a server with the following settings:
[00:00:12]:   Dedicated: true
[00:00:12]:   Online: true
[00:00:12]:   Passworded: false
[00:00:12]:   ServerPort: 10999
[00:00:12]:   SteamAuthPort: 8766
[00:00:12]:   SteamMasterServerPort: 27016
[00:00:12]:   ClanID: false
[00:00:12]:   ClanOnly: false
[00:00:12]:   ClanAdmin: false
[00:00:12]:   LanOnly: false
[00:00:12]:   FriendsOnly: false
[00:00:12]:   EnablePunchthrough: false
[00:00:12]:   EnableAutosaver: false
[00:00:12]:   PVP: false
[00:00:12]:   MaxPlayers: 16
[00:00:12]:   GameMode: survival
[00:00:12]:   OverridenDNS:
[00:00:12]:   PauseWhenEmpty: false
[00:00:12]:   InternetBroadcasting: true
[00:00:12]:   Intent: cooperative
[00:00:12]: [Warning] Could not confirm port 10999 is open in the firewall.
[00:00:12]: [Shard] Shard server mode disabled by configuration file
[00:00:12]: [Error] Server failed to start!
[00:00:12]: Unhandled exception during server startup: RakNet UDP startup failed: SOCKET_PORT_ALREADY_IN_USE (5)
[00:00:12]: PushNetworkDisconnectEvent With Reason: "ID_DST_INITIALIZATION_FAILED", reset: false
[00:00:12]: Details: SOCKET_PORT_ALREADY_IN_USE
[00:01:00]: Collecting garbage...
[00:01:00]: lua_gc took 0.01 seconds
[00:01:00]: ~ShardLuaProxy()
[00:01:00]: ~ItemServerLuaProxy()
[00:01:00]: ~InventoryLuaProxy()
[00:01:00]: ~NetworkLuaProxy()
[00:01:00]: ~SimLuaProxy()
[00:01:00]: lua_close took 0.01 seconds
[00:01:00]: CurlRequestManager::ClientThread::Main() complete
[00:01:00]: HttpClient2 discarded 0 callbacks.
[00:01:00]: Shutting down

Here is my Master server.ini file:

Spoiler

 

[NETWORK]
server_port = 11073


[SHARD]
is_master = true


[STEAM]
master_server_port = 27018
authentication_port = 8768

 

And my Caves server.ini file:

Spoiler

 

[NETWORK]
server_port = 11049


[SHARD]
is_master = false
name = Caves


[STEAM]
master_server_port = 27019
authentication_port = 8769

 

The server_port was Master:11000 and Caves:11001 before I changed them to test if the problem was that; it wasn't.

Share this post


Link to post
Share on other sites
ToNiO55    298

@BeastNips

it's look like your server.ini in both server doesn't load correctly

because i see ServerPort: 10999 in both server.log txt

log of your Master:

Spoiler

[00:00:12]:   Dedicated: true
[00:00:12]:   Online: true
[00:00:12]:   Passworded: false
[00:00:12]:   ServerPort: 10999
[00:00:12]:   SteamAuthPort: 8766
[00:00:12]:   SteamMasterServerPort: 27016
[00:00:12]:   ClanID: false
[00:00:12]:   ClanOnly: false
[00:00:12]:   ClanAdmin: false
[00:00:12]:   LanOnly: false
[00:00:12]:   FriendsOnly: false
[00:00:12]:   EnablePunchthrough: false
[00:00:12]:   EnableAutosaver: false
[00:00:12]:   PVP: false
[00:00:12]:   MaxPlayers: 16
[00:00:12]:   GameMode: survival
[00:00:12]:   OverridenDNS:
[00:00:12]:   PauseWhenEmpty: false
[00:00:12]:   InternetBroadcasting: true
[00:00:12]:   Intent: cooperative

log of your Caves:

Spoiler

[00:00:12]:   Dedicated: true
[00:00:12]:   Online: true
[00:00:12]:   Passworded: false
[00:00:12]:   ServerPort: 10999
[00:00:12]:   SteamAuthPort: 8766
[00:00:12]:   SteamMasterServerPort: 27016
[00:00:12]:   ClanID: false
[00:00:12]:   ClanOnly: false
[00:00:12]:   ClanAdmin: false
[00:00:12]:   LanOnly: false
[00:00:12]:   FriendsOnly: false
[00:00:12]:   EnablePunchthrough: false
[00:00:12]:   EnableAutosaver: false
[00:00:12]:   PVP: false
[00:00:12]:   MaxPlayers: 16
[00:00:12]:   GameMode: survival
[00:00:12]:   OverridenDNS:
[00:00:12]:   PauseWhenEmpty: false
[00:00:12]:   InternetBroadcasting: true
[00:00:12]:   Intent: cooperative

your server.ini of your Master is correctly here?

Documents\Klei\DoNotStarveTogether\MyDediServer\Master\server.ini

your server.ini of your Caves is correctly here?

Documents\Klei\DoNotStarveTogether\MyDediServer\Caves\server.ini

 

  • Like 1

Share this post


Link to post
Share on other sites
BeastNips    105
44 minutes ago, ToNiO55 said:

@BeastNips

it's look like your server.ini in both server doesn't load correctly

because i see ServerPort: 10999 in both server.log txt

log of your Master:

  Reveal hidden contents

[00:00:12]:   Dedicated: true
[00:00:12]:   Online: true
[00:00:12]:   Passworded: false
[00:00:12]:   ServerPort: 10999
[00:00:12]:   SteamAuthPort: 8766
[00:00:12]:   SteamMasterServerPort: 27016
[00:00:12]:   ClanID: false
[00:00:12]:   ClanOnly: false
[00:00:12]:   ClanAdmin: false
[00:00:12]:   LanOnly: false
[00:00:12]:   FriendsOnly: false
[00:00:12]:   EnablePunchthrough: false
[00:00:12]:   EnableAutosaver: false
[00:00:12]:   PVP: false
[00:00:12]:   MaxPlayers: 16
[00:00:12]:   GameMode: survival
[00:00:12]:   OverridenDNS:
[00:00:12]:   PauseWhenEmpty: false
[00:00:12]:   InternetBroadcasting: true
[00:00:12]:   Intent: cooperative

log of your Caves:

  Reveal hidden contents

[00:00:12]:   Dedicated: true
[00:00:12]:   Online: true
[00:00:12]:   Passworded: false
[00:00:12]:   ServerPort: 10999
[00:00:12]:   SteamAuthPort: 8766
[00:00:12]:   SteamMasterServerPort: 27016
[00:00:12]:   ClanID: false
[00:00:12]:   ClanOnly: false
[00:00:12]:   ClanAdmin: false
[00:00:12]:   LanOnly: false
[00:00:12]:   FriendsOnly: false
[00:00:12]:   EnablePunchthrough: false
[00:00:12]:   EnableAutosaver: false
[00:00:12]:   PVP: false
[00:00:12]:   MaxPlayers: 16
[00:00:12]:   GameMode: survival
[00:00:12]:   OverridenDNS:
[00:00:12]:   PauseWhenEmpty: false
[00:00:12]:   InternetBroadcasting: true
[00:00:12]:   Intent: cooperative

your server.ini of your Master is correctly here?


Documents\Klei\DoNotStarveTogether\MyDediServer\Master\server.ini

your server.ini of your Caves is correctly here?


Documents\Klei\DoNotStarveTogether\MyDediServer\Caves\server.ini

 

Yep they're both there.

Share this post


Link to post
Share on other sites
BeastNips    105

Fixed it. It's such a weird problem I don't even know where to begin.

Basically I saved the files wrong (Windows 8.1 problem maybe?) so I had a file called server.ini but it wasn't actually the .ini file the server was using. I copied and pasted the info from that file into the real server.ini and it's working.

Now to tackle mods!

Share this post


Link to post
Share on other sites
ToNiO55    298

@BeastNips

can you also show your cluster.ini please?

what the type of your server.ini? Text Document? or Configuration Settings?

it's important that it be type of Configuration Settings

example:

Spoiler

Master:

160215122338574939.jpg

Caves:

160215122338733582.jpg

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now