V2C

Dedicated Server Quick Setup Guide - Windows

Recommended Posts

Zillvr    1,634

@Remps then you are saving it incorrectly. Open your StartDSTServers.bat.txt file and Click File > Save As > Set Save as Type: To All Types > In file name set as StartDSTServers.bat > Save

Now it should be a batch file, also seen as Windows Batch File under file type if you set your Folder Option Views to Details. If you get that File Type, then you have it saved correctly as a batch file.

  • Like 1

Share this post


Link to post
Share on other sites
Remps    169
9 hours ago, Zillvr said:

@Remps then you are saving it incorrectly. Open your StartDSTServers.bat.txt file and Click File > Save As > Set Save as Type: To All Types > In file name set as StartDSTServers.bat > Save

Now it should be a batch file, also seen as Windows Batch File under file type if you set your Folder Option Views to Details. If you get that File Type, then you have it saved correctly as a batch file.

i did but now invalid token error i used all tokens but same 

Share this post


Link to post
Share on other sites
Zillvr    1,634

@Remps Invalid token could mean any of the following, check them one by one:

  • Incorrect filename, make sure the filename is just cluster_token and saved as a .txt file. And not a text file with a file name of "cluster_token.txt", which would actually be a cluster_token.txt.txt
  • Token has expired so you have to generate another token. Either through Console Commands or in your Klei Account Page directly through browser.
  • Incorrect file directory, make sure the cluster token you are using is in the specified server files you made. It should be beside the cluster.ini file.

BTW about the cluster_token.txt file name, just do the same method we did for the .bat file (setting Save as type to All Types) but instead write "cluster_token.txt".

Cause saving cluster_token.txt on default settings with a notepad becomes a cluster_token.txt.txt file. I hope it's not too confusing.

Edited by Zillvr
  • Thanks 1

Share this post


Link to post
Share on other sites
Zillvr    1,634

@Remps make sure your dedicated server is running the same version as the dst client. The game client has been updated recently so it's likely your server is running the old version which is why your DST can't see it.

Make sure you have the "+validate" in your StartDSTServers.bat. Refer to Step 11 of this guide.

Oh and just realized you have to also change the first line in the batch file (StartDSTServers.bat). But it seems you corrected it already. If not, do so. Your batch file should reflect your custom SteamCMD installation location. Sorry about that. Wherever it is you installed your SteamCMD, if it's in C:, you don't have to change anything.

Share this post


Link to post
Share on other sites
Remps    169

@Zillvr idk whats that mean but i didnt write 16 player or something like that also didnt understand where to should i write "+validate "

Adsız.png

adsız2.png

Share this post


Link to post
Share on other sites
Zillvr    1,634

@Remps the "validate" command is in the first line of the batch file (StartDSTServers.bat). Make sure you have the "validate" word there.

5c4db6c19ee14_Screenshot(245).thumb.png.a7d2789fe8baf7fe634c9fe3e4303b6d.png

Looking at the screenshots you attached, it's a whole different issue. You need to make sure that the caves server.ini file has a different server_port number from the master's server.ini.

  • Go to Documents\Klei\DoNotStarveTogether\MyDediServer\Master\
  • Open server.ini file
  • Make sure it has this line:
server_port = 11000
  • Go to Documents\Klei\DoNotStarveTogether\MyDediServer\Caves\
  • Open server.ini file
server_port = 11001

You could also use 10999 for one and 10998 for the other. Just make sure they are different from each other. If they are the same, you will get the error:

"....SOCKET_PORT_ALREADY_IN_USE."

Edited by Zillvr

Share this post


Link to post
Share on other sites
TechiMAn    0
On 2016-02-11 at 10:30 PM, V2C said:

11. Copy and save the following text to:

  • \\Documents\Klei\StartDSTServers.bat
  Hide contents

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 validate +quit
cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin"
start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Master
start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Caves

Hey for anyone that does get it up and running I might suggest a slight modification on starting the servers, I found that I wanted to identify each window with its own name so I made 3 bat (cmd) files 

StartDSTServers.cmd

     c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 validate +quit
     start startmaster.cmd
     start startcaves.cmd
 

Startmaster.cmd

     @Echo Off
     Title "DST Dedicated server Master"
     cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin"
     dontstarve_dedicated_server_nullrenderer -console -cluster DoNotStarveTogetherDedicated -shard Master 

Startcaves.cmd

     @echo off
     title "DST Dedicated Server Caves"
     cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin"
     dontstarve_dedicated_server_nullrenderer -console -cluster DoNotStarveTogetherDedicated -shard Caves

 

 This Does the same thing but now your Windows will be labeled, also if you want you can add a /HIGH (LOW,NORMAL,HIGH,REALTIME,ABOVENORMAL,BELOWNORMAL) as a windows priority for each server if your truly using a dedicated vm or pc to run it.

eg. start startmaster.cmd /high

note: you can put whatever name you want in the title "whatever you want it to be called"

Share this post


Link to post
Share on other sites
Zillvr    1,634
9 hours ago, Chaosky said:

I keep getting this problem does anyone know how to fix this? 

errorklei.jpg

Means you didn't install SteamCMD in the correct installation location. If you're going to follow this guide to the letter, then you should have installed SteamCMD into c:\steamcmd.

  • Create a folder in drive c and name it steamcmd,
  • Download steamCMD for Windows (link in guide's step 1)
  • Extract files to that folder

Share this post


Link to post
Share on other sites

Dear moderators,

I have this error in my server master & the caves just reload again and again.

Please help me to fix this error:(
image.thumb.png.86a6ef74b60b11a0ef2f8d8bc605cdaa.png

Share this post


Link to post
Share on other sites
Gordsey    0

Can someone DM me and walk me through making a dedicated server please? This is really complicated to me, and its annoying the living hell out of me.

 

Thank you in advance

Gordsey

Share this post


Link to post
Share on other sites
On 27/1/2019 at 8:53 PM, Zillvr said:

@Remps the "validate" command is in the first line of the batch file (StartDSTServers.bat). Make sure you have the "validate" word there.

5c4db6c19ee14_Screenshot(245).thumb.png.a7d2789fe8baf7fe634c9fe3e4303b6d.png

Looking at the screenshots you attached, it's a whole different issue. You need to make sure that the caves server.ini file has a different server_port number from the master's server.ini.

  • Go to Documents\Klei\DoNotStarveTogether\MyDediServer\Master\
  • Open server.ini file
  • Make sure it has this line:

server_port = 11000
  • Go to Documents\Klei\DoNotStarveTogether\MyDediServer\Caves\
  • Open server.ini file

server_port = 11001

You could also use 10999 for one and 10998 for the other. Just make sure they are different from each other. If they are the same, you will get the error:

"....SOCKET_PORT_ALREADY_IN_USE."

I have the same error, my server port is the same as yours but its not working

 

 

image.png

Share this post


Link to post
Share on other sites
Zillvr    1,634
4 hours ago, KeiNguyen208 said:

I have the same error, my server port is the same as yours but its not working

image.png

server.ini content-wise, everything seems to be in order. Afaik the # just comments out that specific line and inconsequential to the syntax of the whole thing so that probably isn't an issue.

Can you confirm that they are in fact .ini files and not server.ini.txt files?

Set your Folder Options View to Details and under filetype, these should be "Configuration settings" and not "Text Document". If they are seen as Text Document then you just have to resave them with the correct file type with the correct method.

While in \\Documents\Klei\DoNotStarveTogether\MyDediServer\Master\

  • Open server.ini.txt file
  • Click File
  • Click Save As
  • Browse to your Master folder (\\Documents\Klei\DoNotStarveTogether\MyDediServer\Caves\)
  • Type server.ini in File Name:
  • Set Save as Type to "All Files (*.*)"
  • Save
  • Do the same for the server.ini in the Caves folder

Also, can you confirm you have the correct file location?

If you are following this guide, refer to step 8 & 9.

Share this post


Link to post
Share on other sites
13 minutes ago, Zillvr said:

server.ini content-wise, everything seems to be in order. Afaik the # just comments out that specific line and inconsequential to the syntax of the whole thing so that probably isn't an issue.

Can you confirm that they are in fact .ini files and not server.ini.txt files?

Set your Folder Options View to Details and under filetype, these should be "Configuration settings" and not "Text Document". If they are seen as Text Document then you just have to resave them with the correct file type with the correct method.

While in \\Documents\Klei\DoNotStarveTogether\MyDediServer\Master\

  • Open server.ini.txt file
  • Click File
  • Click Save As
  • Browse to your Master folder (\\Documents\Klei\DoNotStarveTogether\MyDediServer\Caves\)
  • Type server.ini in File Name:
  • Set Save as Type to "All Files (*.*)"
  • Save
  • Do the same for the server.ini in the Caves folder

Also, can you confirm you have the correct file location?

If you are following this guide, refer to step 8 & 9.

The file location & file type .ini are all exactly.

We're trying much times and I thought that the save file have problem so the world can't load :(
Anw, thanks for your respond

Share this post


Link to post
Share on other sites
Zillvr    1,634
Just now, KeiNguyen208 said:

The file location & file type .ini are all exactly.

We're trying much times and I thought that the save file have problem so the world can't load :(
Anw, thanks for your respond

Try changing the numbers for the server_port. Also are you using this guide specifically? Cause if you use a differently written batch file to launch your dedicated server, there is a possibility that you are launching duplicates which make the socket port conflict with each other.

Share this post


Link to post
Share on other sites
Kooky    4

It's been a good long while since I've made a dedicated server for DST, and I'm noticing the authentication token file isn't working AT ALL! I didn't even get a settings.ini file. All I wanna do is attempt to see if DST will load properly for my boyfriend and I to play on the same network (we live together FYI) but ever since the latest updates, we haven't been able to play. I've been plugging away trying with the dedicated server but it's not working.

Share this post


Link to post
Share on other sites
Kooky    4

token generation doesnt seem to work, I have the file with the cluster and it's still not working.

Share this post


Link to post
Share on other sites

how can i change world settings ? i checked internet but all i found are old and can anyone post world settings (and cave too ) ??

Share this post


Link to post
Share on other sites

Hi: simple question: (but I have no idea if the solution is simple)

 

Two command windows pop up presenting the master server and the caves. Is there a way to make the server run in the background without these windows being visible?

Share this post


Link to post
Share on other sites
ZHA    0
On 2016/2/12 at AM11点30分, V2C said:

two questions here:

1.How to fix the problem that ping looks like"???"image.png.1d33cd68db8419dd13a76165dac2ba98.png

2.the cluster.ini doesn't work properly.In the pictrue you can see the “cluster_name” and the "cluster_description" actually worked, but the "max_players" and the "pause_when_empty" really doesn't work. And you know that the "pause_when_empty" is so important that without it I can't open the dst server when I am not online.

image.png.3017e0a326c437ccd6a0a7794bb04208.pngimage.thumb.png.dc05e366c8205d65f62899301ab218b8.png

I really need some helps, just waiting here.

在2016/2/12上午11:30,V2C说:

Looks like the NETWORK part always works, and the GAMEPLAY part didn't.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now