V2C

Dedicated Server Quick Setup Guide - Windows

Recommended Posts

Wexxa    1

I honestly have no idea what I'm doing, other games' dedicated servers were more user-intuitive.

 

Server_Error1.png

 

What does this mean? I already have the shard_enabled as true in both Cluster_1 and MyDediServer.

Share this post


Link to post
Share on other sites
Wexxa    1
1 hour ago, Remps said:

I did it no problem but how can i add mods ??

Did you do it using ONLY this guide and not changing anything else?

 

Just wondering.

 

Edit: Okay, I got the server to launch, but now it doesn't appear when I search for it in the server list?

Edited by Wexxa

Share this post


Link to post
Share on other sites
Wexxa    1

Alright, it doesn't appear on the server browser in-game or online, even though the SteamCMD says it is launched. Here's a picture:

Server_Picture2.png

 

Any help?

 

Sorry for double-posting.

  • Like 1

Share this post


Link to post
Share on other sites
Vark0pZ    0

Let's say I want only my master server running a specific mod without the slave server doing it too. Can someone help me out with this?

Thanks.

Share this post


Link to post
Share on other sites
Rily    552

I have a problem with the dont_starve_server_dedicated_nullrender file, I have all the files and this error box says that windows can find it, where is that file?, why I don't have it, and how can I setup mods with this new way?

 

Edit: scratch that, looks like was little mistake with the steamcmd instalation, for everyone who have this same problem try to reinstall steamcmd, now I just want to know about mods

Edited by Rily

Share this post


Link to post
Share on other sites
mcloutier87    0

You need to download the program to run it. that will allow you too launch the server. Also some of you say your server doesnt show up on the list when you search for it. Mine is the same way but others can search for it. Ill be putting mine online called(The New Realm) If you can find it please let me know.

Share this post


Link to post
Share on other sites
mcloutier87    0

Okay guys, I have figured it out as now my server is active and working live. :) If anyone have question please message me and I will try to walk you through it. 

Share this post


Link to post
Share on other sites
popwind    2
2 hours ago, mcloutier87 said:

Okay guys, I have figured it out as now my server is active and working live. :) If anyone have question please message me and I will try to walk you through it. 

can you help me ?

Edited by popwind
wrong @

Share this post


Link to post
Share on other sites
Taiku789    0

[00:00:41]: 1 uploads added to server. From server_temp
[00:00:41]: About to start a shard with these settings:
[00:00:41]:   ShardName: [SHDMASTER]
[00:00:41]:   ShardID: 1
[00:00:41]:   ShardRole: MASTER
[00:00:41]:   MasterHost: (null)
[00:00:41]:   MasterBind: 127.0.0.1
[00:00:41]:   MasterPort: 10888
[00:00:41]: [Shard] Starting master server
[00:00:41]: [Warning] Could not confirm port 10888 is open in the firewall.
[00:00:41]: [Shard] Shard server started on port: 10888
[00:00:41]: Telling Client our new session identifier: 211F1F9F97907C23
[00:00:41]: ModIndex: Load sequence finished successfully.
[00:00:41]: Reset() returning
[00:00:42]: [Steam] SteamGameServer_Init(8769, 10999, 27019)
Setting breakpad minidump AppID = 322330
[00:00:42]: [Steam] SteamGameServer_Init success
[00:00:43]: Validating portal[3] <-> <nil>[3] (inactive)
[00:00:43]: Validating portal[5] <-> <nil>[5] (inactive)
[00:00:43]: Validating portal[7] <-> <nil>[7] (inactive)
[00:00:43]: Validating portal[4] <-> <nil>[4] (inactive)
[00:00:43]: Validating portal[8] <-> <nil>[8] (inactive)
[00:00:43]: Validating portal[1] <-> <nil>[1] (inactive)
[00:00:43]: Validating portal[10] <-> <nil>[10] (inactive)
[00:00:43]: Validating portal[9] <-> <nil>[9] (inactive)
[00:00:43]: Validating portal[6] <-> <nil>[6] (inactive)
[00:00:44]: Validating portal[2] <-> <nil>[2] (inactive)
[00:00:44]: Sim pause

 

so I managed to figure it out but I get this thing called sim pause and when I launch the caves on my dedicated server it says "There was some kind of trouble starting up the server. How odd."

 

 

Share this post


Link to post
Share on other sites
mcloutier87    0

sim is a good.thing. Now one thing that isnt posted is that you need to leave the beta verion. Go under properties and go back to the regular one. Now if you still have problems then under where you have your folders you have the ones for the game and then for the dedicated server part. Make sure you have the server under both locations. 

If anyone still have problems i will make a zip file that you guys can upload to your folders. I promise this will solve the problem.

 

Now as for mods not working... Well im still trying to fix it on my server too. I got the world working so I can change all settings for it. Works great. ;)

Share this post


Link to post
Share on other sites
Teodik    0

are you sure this is easy and quick one ?
your best noob i ever see 
use easy DST dedicated server tool in steam :)

Share this post


Link to post
Share on other sites
brachior    0

It's a really nice tutorial, thanks a lot :)

Just a thing, in the file "StartDSTServers.{bat/sh}", the first line destroys the file "dedicated_server_mods_setup.lua" so it's impossible to add mods in the server (without this line, everything it's ok ;))

Share this post


Link to post
Share on other sites

Hi there, I have 2 hard drives and my steam is installed into my D/ Drive. When I try running the start command the window just dissapears. Any help? :[

Edited by SurvivingArch

Share this post


Link to post
Share on other sites
SMorholt    0

The only problem I have so far is that it keeps wanting to set the world to be 16 players and survival, and that means it's not using my settings.

Share this post


Link to post
Share on other sites
Rily    552

I can't find my server since the 170... update, you know, the Meep! Meep! Meep! Update, everything looks find I just can't see my server in any list, how can I find the problem?, I deleted my world already

Share this post


Link to post
Share on other sites
gigazelle    11

Got my dedicated server up and running within 30 minutes using the OP's general concept, but used a lot of my own steps. I wanted to transfer my world that I've been hosting to a dedicated one. Here's what I did:

  1. Launch DST and Host a new server - get all the settings the way you want them
  2. Generate the new world and enter the game
  3. Disconnect and go to account info, generate the cluster token
  4. Go into documents/klei/donotstarvetogether and locate the server slot you created. Since I have several worlds, the one that I wanted was Cluster_3.
  5. Copy cluster_token.txt inside the world file and rename the copy to cluster_token_old.txt
  6. In the original cluster_token.txt, paste the cluster token you got from account info
  7. Create this .bat file in an easy to access place:
    cd "C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together Dedicated Server\bin"
    start dontstarve_dedicated_server_nullrenderer -console -cluster Cluster_3 -shard Master
    start dontstarve_dedicated_server_nullrenderer -console -cluster Cluster_3 -shard Caves
  8. The two servers started without a hitch for me. Note that anyone using this should change Cluster_3 to whatever the folder name is containing your world.

Share this post


Link to post
Share on other sites
Rily    552
On 20/3/2016 at 11:53 PM, gigazelle said:

Got my dedicated server up and running within 30 minutes using the OP's general concept, but used a lot of my own steps. I wanted to transfer my world that I've been hosting to a dedicated one. Here's what I did:

  1. Launch DST and Host a new server - get all the settings the way you want them
  2. Generate the new world and enter the game
  3. Disconnect and go to account info, generate the cluster token
  4. Go into documents/klei/donotstarvetogether and locate the server slot you created. Since I have several worlds, the one that I wanted was Cluster_3.
  5. Copy cluster_token.txt inside the world file and rename the copy to cluster_token_old.txt
  6. In the original cluster_token.txt, paste the cluster token you got from account info
  7. Create this .bat file in an easy to access place:
    cd "C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together Dedicated Server\bin"
    start dontstarve_dedicated_server_nullrenderer -console -cluster Cluster_3 -shard Master
    start dontstarve_dedicated_server_nullrenderer -console -cluster Cluster_3 -shard Caves
  8. The two servers started without a hitch for me. Note that anyone using this should change Cluster_3 to whatever the folder name is containing your world.

Did you know Why my second world isn't a cave?, I have two regular worlds linked with sinkholes, and since the last update my server stop every 30 minutes, just the master server, is quite annoying

Share this post


Link to post
Share on other sites
Rily    552
9 hours ago, ToNiO55 said:

Hi @Rily

are you sure your worldgenoverride.lua for server cave is good?

maybe try this:

http://pastebin.com/raw/fqWAC5K2

Thanks I don't know what was the problem with my old worldgenoverride file but it was the source of the problem, the server still stopping but at least I have caves now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now