Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

oceanbiscuit

Resolution glitch and crashes on Mac OS [RESOLVED]

Recommended Posts

I bought MotN on steam yesterday, and played it happily for a few hours. Today I launched it, and the game appears in a small rectangle, maybe two inches high, at the bottom left corner of a completely black screen. It doesn't respond to my cursor, but using the arrow keys I can still control the menus and such (what I can see, since it's so tiny). I went to "settings" to try to change the resolution, but each time I select "settings" the game immediately closes. I've tried deleting the game and reinstalling it, and I even went into the Library and removed the Saved Application State, but when I reinstall, it does the exact same thing.

Share this post


Link to post
Share on other sites
JanH    5,213

From what you have described, it sounds like Steam Cloud is not saving/loading your settings properly. You will be able to reset your screen resolution to their default settings by deleting your “graphics.ini” file. You’ll find the file here: Steam\steamapps\common\mark_of_the_ninja\users\graphics.ini.

Before your start the game though, try disabling Steam Cloud Synchronization for Mark of the Ninja - this will ensure that any changes to your settings are saved locally on your hard drive and not on Steam's Cloud servers.

  1. Right-Click on Mark of the Ninja in your Steam Games Library and choose “Properties”;
  2. In the “Properties” window, click on the “Updates” tab; at the bottom you’ll find an option for Steam Cloud.
  3. Uncheck “Enable Steam Cloud synchronization for Mark of the Ninja” and click on the “Close” button.

If that does not work for you, the screen issue may be caused by your Mac switching between discrete and integrated graphics after you launch Mark of the Ninja. Try turning off automatic graphics switching in your Energy Save preference pane – choose “Discreet Only” and turning “Switching” off should fix your issue.

Share this post


Link to post
Share on other sites
3 hours ago, JanH said:

From what you have described, it sounds like Steam Cloud is not saving/loading your settings properly. You will be able to reset your screen resolution to their default settings by deleting your “graphics.ini” file. You’ll find the file here: Steam\steamapps\common\mark_of_the_ninja\users\graphics.ini.

Before your start the game though, try disabling Steam Cloud Synchronization for Mark of the Ninja - this will ensure that any changes to your settings are saved locally on your hard drive and not on Steam's Cloud servers.

  1. Right-Click on Mark of the Ninja in your Steam Games Library and choose “Properties”;
  2. In the “Properties” window, click on the “Updates” tab; at the bottom you’ll find an option for Steam Cloud.
  3. Uncheck “Enable Steam Cloud synchronization for Mark of the Ninja” and click on the “Close” button.

If that does not work for you, the screen issue may be caused by your Mac switching between discrete and integrated graphics after you launch Mark of the Ninja. Try turning off automatic graphics switching in your Energy Save preference pane – choose “Discreet Only” and turning “Switching” off should fix your issue.

Turns out it was the graphics switching. Thanks so much!

Share this post


Link to post
Share on other sites