Sign in to follow this  
Zeroedout

Shank 2 - hide mouse cursor (w/ GNU/Linux workaround)

Recommended Posts

Zeroedout    10

You think that's annoying? I'm using a ps3 controller and the hid_sony module makes X think my ps3 controller is a mouse. Whenever I move shank, the mouse starts moving too :< Thanks for the workaround though, I'll play with it until I can get the mouse to not be on screen through an entire play through. One day games will be FOSS and we can just fix the code :<

Share this post


Link to post
Share on other sites
pholklore    10

I'm not familiar with the ps3 controller support, but I'd think there must be a way to disable the mouse emulation. You certainly can't be the only one with that issue. Or if you are, then something is most likely wrong with your setup. Knowing that parts of the stack do hid vendor/device id checks I'd guess that if have a controller that emulates as ps3 controller rather than the real one, something may not be recognizing the controller as such properly. But really I'm just guessing.> One day games will be FOSS and we can just fix the code I long for the day. However in your case, per your description, your problem is somewhere between the kernel/module and X, so you should already be able to fix the code today.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this