Sign in to follow this  
SwiftXShadow

Game gets slow

Recommended Posts

SwiftXShadow    10

For some reason my game slows down to a quite unbeareble level when i get to a very foresty aeria. Normally like where the pigs are around there. It is honestly so bad that i avoid that place like the plague. How to fix that?Intel® Core i7-2630QM CPU @ 2.00GHz 2.0 GHz Performance Rated at: 5.00 GHzRAM 8.1 GBMicrosoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bitGeForce GT 540M

Share this post


Link to post
Share on other sites
SwiftXShadow    10

same problem here BUT you can chop down a lot of trees to minimize the slow down

that will take forever... i set the entire forest on fire hoping to fix it but that didnt do much, well it did get me through the night with out a campfire

Share this post


Link to post
Share on other sites
Excess    53

Intel® Core i7-2630QM CPU @ 2.00GHz

2.0 GHz Performance Rated at: 5.00 GHz

RAM 8.1 GB

Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit

GeForce GT 540M

That sounds like a machine that could beat Kasparov in a hand-to-hand chess game.

I think the problem here isn't about the machines, several of us have pretty decent rigs and yet experiences low FPS while in heavy forested areas. I think it's a limitation of Chrome. Fortunately, the game will most likely launch on Steam when ready. Unfortunately, it's not ready :D

Could you tell us your general FPS and your forest FPS? You can activate a FPS counter typing about:flags on the address bar and activating the option FPS counter. That may help the devs.

Share this post


Link to post
Share on other sites
Kevin    992

You can toggle the game's debug rendering by pressing backspace. When the debug rendering is enabled, there is a rough performance breakdown in the top right hand corner of the screen- it tells you how many milliseconds it took to render and how many it took to update the simulation. If these two numbers add up to more than 32, your game slows down.When you are experiencing the slowdown, what do the numbers say? They jump around a lot, so they can be a bit hard to read.

Share this post


Link to post
Share on other sites
LadyD    3,223

I had a slow down today. LAGGING in game.Never happened before and I wasn't even in a hard to render area. Grasslands with nothing but yellow ahead.It was weird. Never lagged in game before...EDIT- its not my computer... I BUILT this... My Frankenstein Monster shall NOT fail me!!!

Edited by LadyD

Share this post


Link to post
Share on other sites
Excess    53

If these two numbers add up to more than 32, your game slows down.

No wonder my forest is laggy, my "update" number in 47 flashing 50's. Also, the date is all wrong down there, I took this screenshot today, 4th of October O_O

Posted Image

Share this post


Link to post
Share on other sites

The game gets super slow for me too. I thought originally it had something to do with the fog around graves which are usually within heavily forested areas. Typically when I leave said fog the games speeds back up again.

Share this post


Link to post
Share on other sites
Kevin    992

The date is the build date for your executable, not the current date.Interestingly, from your screenshot it looks like the physics system is what is slow. I wonder what's causing that - I would have guessed it was either rendering or the game scripts.

Share this post


Link to post
Share on other sites
Excess    53

The date is the build date for your executable, not the current date.

Oh, that makes sense.

Interestingly, from your screenshot it looks like the physics system is what is slow. I wonder what's causing that - I would have guessed it was either rendering or the game scripts.

The pigs don't had anything to do with it, there weren't with me when the lag started. It's the forest.

I'm gonna take a wild guess here and say it's the shadows. I didn't experienced this kind of lag in previous builds, when the shadows where broken and appeared whenever they wanted. A lot of trees, a lot of shadows. Also, at night the lag ain't that bad.

Edited by Excess
I accidentally a word

Share this post


Link to post
Share on other sites
Kevin    992

From the numbers in your screenshot, it looks like you are rendering the shadows fast enough. I think you are encountering another, more sinister bug. I'll PM you to see if we can get some more info about this.

Share this post


Link to post
Share on other sites
Kevin    992

OK, I've looked into Excess' save file, and managed to bring the physics timing from ~4ms to <1ms on my machine. So, yay!Poking something as fundamental as the physics system necessitates a lot of testing, so I don't want to push a hotfix. You should see these changes with the next normal update, which is on the 16th.Thanks for the feedback, guys! We have a limited range of hardware to test things on at the office, and most of the computers that we have are beefy development machines. It's very helpful to know when people are having performance problems.

Share this post


Link to post
Share on other sites
Kevin    992

Note - this won't help you if your problem is graphics-related. You can tell which camp you are in by looking at which is the higher of your update and render times.

Share this post


Link to post
Share on other sites
leothorn    10

I think thread is related to the problem i posted somewhere else in the forum . My Update time is hovering around 35-40 while rendering i at 10-12 . So I guess my problem will be addressed when this problem is hot-fixed ?

Share this post


Link to post
Share on other sites
sinmist    10

I have a computer with well more than enough to play run 50 games of this quality at once. Although it does get a bit slow i noticed. It is probably because it is running in a browser atm , what does it run flash?

Share this post


Link to post
Share on other sites
Kevin    992

How does the latest build (67554) run? Are the forests any more playable?

Share this post


Link to post
Share on other sites
Kevin    992

Forests and pig villages work great for me now. Graveyards with fog are still laggy though.

Awesome! Can you take a look at the relative update and render timings in the fog areas? I think that's a different issue than the one that I fixed, but I want to confirm.

Share this post


Link to post
Share on other sites
cptCalavera    616

Screenshot good enough?Less laggy when I went in to the fog this time though.post-688-13764589258828_thumb.jpg

Edited by cptCalavera

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this