Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Cri

[General] - Install the DLC prevents Invisible Inc to start

Recommended Posts

Cri    1

Bug Submission:

Category: General

Platform: PC

Issue Title: Install the DLC prevents Invisible Inc to start

Issue Description: Hello!

I just download the Contingency Plan DLC from Humble Store. After installing it, Invisible Inc refuses to start. If I uninstall the DLC or remove the "dlc1" folder from "dlc" directory, it works again. My current build number is 146683.

Thanks for your help.

Steps to Reproduce: I just download the Contingency Plan DLC from Humble Store. After installing it, Invisible Inc refuses to start. If I uninstall the DLC or remove the "dlc1" folder from "dlc" directory, it works again. My current build number is 146683.

Share this post


Link to post
Share on other sites
LogicalDash    0

Same for me. Here's my traceback from when I run in a terminal:

 

----------------------------------------------------------------
game/client/strict.lua:26: variable 'statemgr' is not declared

stack traceback:
    [C] ?
    [C] in function 'assert'
    game/client/strict.lua:26 in function <game/client/strict.lua:24>
    game/modules/bugreport.lua:17 in function <game/modules/bugreport.lua:11>
    [C] ?
    [C] in function 'assert'
    game/client/strict.lua:26 in function <game/client/strict.lua:24>
    game/modules/bugreport.lua:17 in function <game/modules/bugreport.lua:11>
    [C] ?
    [C] in function 'assert'
    game/client/strict.lua:26 in function <game/client/strict.lua:24>
    game/modules/bugreport.lua:17 in function <game/modules/bugreport.lua:11>
    ...
    [C] in function 'assert'
    game/client/strict.lua:26 in function <game/client/strict.lua:24>
    game/modules/bugreport.lua:17 in function <game/modules/bugreport.lua:11>
    [C] ?
    [C] in function 'assert'
    game/client/strict.lua:26 in function <game/client/strict.lua:24>
    game/client/mod-manager.lua:169 in function 'mountContentMod'
    game/client/mod-manager.lua:39 in function 'init'
    game/client/class.lua:39 in function <game/client/class.lua:30>
    main.lua:129 in main chunk

STUBBED: WinLoop at WinLoop (../../../code_src/spy/sdl/main.cpp:854)

Share this post


Link to post
Share on other sites
ahchae    0

I confirm the same thing for Linux x86_64, noDRM version.

 

The error message:

 

[LUA] mod.init ERROR: dlc1/modinit.lua:63: attempt to call method 'addLog' (a nil value)
stack traceback:
        game/client/mod-manager.lua:161: in function 'addLog'
        dlc1/modinit.lua:63: in function 'init'
        game/client/mod-manager.lua:158: in function <game/client/mod-manager.lua:154>
        [C]: in function 'xpcall'
        game/client/mod-manager.lua:153: in function 'mountContentMod'
        game/client/mod-manager.lua:39: in function 'init'
        game/client/class.lua:39: in function <game/client/class.lua:30>
        main.lua:129: in main chunk
----------------------------------------------------------------
game/client/strict.lua:26: variable 'res' is not declared
 

The log is attached.

log.txt

Share this post


Link to post
Share on other sites
Wade    309

Can I get you all to confirm that you've also downloaded and installed the latest version of the Invisible Inc base game as well?

 

We provided a new standalone build to Humble and GOG which needs to be used to play the DLC. Unfortunately older versions of the game are not compatible.

 

Share this post


Link to post
Share on other sites
Cri    1

The latest update on Humble Store is dated 08/27/2015. So I supose it means that I must wait the update that you talk about in order to be abble to start the DLC.

Share this post


Link to post
Share on other sites
Wade    309

I will confirm with the Humble team about the updated version, as I sent them the files personally. They may have forgotten to put the files up though.

.

Hopefully if they have not put the new build up, it should be up shortly.


I will confirm with the Humble team about the updated version, as I sent them the files personally. They may have forgotten to put the files up though.

.

Hopefully if they have not put the new build up, it should be up shortly.

Share this post


Link to post
Share on other sites