Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

ebenweb

v2.0 Daemons: can you turn them off?

Recommended Posts

ebenweb    0

i think these must have been added in a recent update, because i've played through to the end of the campaign already without seeing them.  i'm referring to the daemons that launch automatically at the beginning of the level, before you have a chance to move.  i believe they start appearing on level 5 missions.

 

i'm not a fan.  i get that some people want an even greater challenge, but if it were up to me i'd have these come in AFTER the level the campaign would normally end at.

 

i'm guessing they're not in the difficulty settings.  anyone heard of a mod to turn these off?

Share this post


Link to post
Share on other sites
Cyberboy2000    660

Archdaemons have existed since the full game first was released. They're not new, but they don't appear in campain so that míght be why you haven't seen them yet. I think they are good part of endless, because if wasn't for them it would get dull quickly, but if you don't want them anyways there is sadly no option for that. However you can change that by following these steps

Extract scripts.zip from where the game is installed

Make a backup of scripts.zip

Open modules\serverdefs.lua

If you want archdaemons to spawn later, go to row 811 and change four to whatever you want.

If you want archdaemons to not spawn at all, go to row 877 and delete that line.

Save and close

Pack all the files into a zip named scripts and replace the original scripts.zip

Share this post


Link to post
Share on other sites
ebenweb    0

Archdaemons have existed since the full game first was released. They're not new, but they don't appear in campain so that míght be why you haven't seen them yet. I think they are good part of endless, because if wasn't for them it would get dull quickly, but if you don't want them anyways there is sadly no option for that. However you can change that by following these steps

Extract scripts.zip from where the game is installed

Make a backup of scripts.zip

Open modules\serverdefs.lua

If you want archdaemons to spawn later, go to row 811 and change four to whatever you want.

If you want archdaemons to not spawn at all, go to row 877 and delete that line.

Save and close

Pack all the files into a zip named scripts and replace the original scripts.zip

 

awesome, thanks mate.  i'll see how far i get with this endless game before i make a decision. i don't have a problem with them in general, i just think they should be brought in a little later.

do you know what "four" signifies in row 811? i don't think it's "day four", but i could be wrong.

Share this post


Link to post
Share on other sites
Cyberboy2000    660

Yes the four is the day they start spawning. However it is based of day 1 as 0, so it actually means they don't spawn until day 5. If you for example don't want them to spawn until day 7, you should change 4 to 6.

Share this post


Link to post
Share on other sites
ebenweb    0

Yes the four is the day they start spawning. However it is based of day 1 as 0, so it actually means they don't spawn until day 5. If you for example don't want them to spawn until day 7, you should change 4 to 6.

 

cheers!

Share this post


Link to post
Share on other sites
Loscil2    81

I feel like reviving this thread.

 

Now with the new code after the DLC/Base Game update, how can I turn them off/delay archdemons? Line 811 doesn't contain the chunk that allows you to configure the day when arch demons spawn.

Also, as an aditional note, when reading itemdefs, I came into one particular item which is chargeable and basically says "prevent arch demons to install". Have you found this particular item?

 

Thanks in advance.

Share this post


Link to post
Share on other sites