Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Darklokey

Broken Slave Server

Recommended Posts

Rtd    7

In log.txt:

[00:00:10]: [Warning] SteamGameServer_Init Failed

Also, you are launching both servers on the same machine.

I had this error too, and you have to assign to each server different steam ports!

 

Tell me if changing the steam ports in the settings.ini file of the Slave solves the problem. ;)

Share this post


Link to post
Share on other sites
Darklokey    16

In log.txt:

[00:00:10]: [Warning] SteamGameServer_Init Failed
Also, you are launching both servers on the same machine.

I had this error too, and you have to assign to each server different steam ports!

Tell me if changing the steam ports in the settings.ini file of the Slave solves the problem. ;)

The servers are both being launched on the same machine but the settings have different steam ports so I don't know why it's acting up like this.

Share this post


Link to post
Share on other sites
Zillvr    1795

I don't know whether this would help, but have you made sure that you opt'd into cavesbeta for your Don't Starve Together Dedicated Server in Tools? That may or may not solve the issue. Just something to double check. Good luck.

 

Assuming its for cavesbeta you are asking about since thats where the master/slave servers come in to play. Hopefully I'm not mistaken.

Share this post


Link to post
Share on other sites
jacklul    94

I don't know whether this would help, but have you made sure that you opt'd into cavesbeta for your Don't Starve Together Dedicated Server in Tools? That may or may not solve the issue. Just something to double check. Good luck.

 

Assuming its for cavesbeta you are asking about since thats where the master/slave servers come in to play. Hopefully I'm not mistaken.

When you look at the log you will see that he's using the beta.

 

About that SteamGameServer_Init error, I'm getting it all the time on both servers, still I'm able to play and they work without any issues.

Share this post


Link to post
Share on other sites
Darklokey    16

My main problem personally is that OTHER people cannot join the server and I think it's because of the steam init error. My friend and I have been racking our heads for a week trying to fix this to no avail.

I've even port forwarded both servers so I should not have any problems with connecting with anyone. People usually are disconnected from the server when they enter the caves. When I change the ports to the server. The server recognizes that they have been change but by no means whatsoever that it tries to use the ports to initialize with steam.

Share this post


Link to post
Share on other sites
Darklokey    16

I don't know whether this would help, but have you made sure that you opt'd into cavesbeta for your Don't Starve Together Dedicated Server in Tools? That may or may not solve the issue. Just something to double check. Good luck.

 

Assuming its for cavesbeta you are asking about since thats where the master/slave servers come in to play. Hopefully I'm not mistaken.

 And yes I did opt into both the server and regular game caves beta. I just can't make it so others can play it to it's full effectiveness because when they try to enter the caves, the game kicks them out of the server and locks them out as well!

Share this post


Link to post
Share on other sites
Rtd    7

Master_settings.ini :

[network]steam_authentication_port = 10998steam_master_server_port = 10998server_port = 10998

Each port here have to be different, AND different of the Slave's one. :p

Share this post


Link to post
Share on other sites
Darklokey    16

Master_settings.ini :

[network]steam_authentication_port = 10998steam_master_server_port = 10998server_port = 10998

Each port here have to be different, AND different of the Slave's one. :razz:

That was when I was trying something and I forgot to change it here's the actual file.

 

settings.ini

 

 and if you check the log file. The server isn't even reading that the steam ports are supposed to be even though it's what they are in the SLAVE_Settings

Share this post


Link to post
Share on other sites
Rtd    7

Ok, so try assigning some other ports for steam on the Slave (since I think that default steam ports used by DST are actually the one suggested in the logs).

 

Master_settings.ini :

server_port = 10998

Slave_settings.ini :

steam_authentication_port = 12347steam_master_server_port = 12348server_port = 10990

Share this post


Link to post
Share on other sites
Darklokey    16

 

Ok, so try assigning some other ports for steam on the Slave (since I think that default steam ports used by DST are actually the one suggested in the logs).

 

Master_settings.ini :

server_port = 10998

Slave_settings.ini :

steam_authentication_port = 12347steam_master_server_port = 12348server_port = 10990

 

Uh didn't work, here's the file to prove it

 

settings.ini

 

log.txt

 

It says to somehow edit the command line and set the ports as those but noone helps with that and they don't even try to explain

Share this post


Link to post
Share on other sites
Rtd    7

No steam error on the Master side?

 

An other thing to try:

In Slave_settings.ini, your server token is different from the Master's one. I'm not sure its supposed to work like this...

Copy your server token from Master to Slave and retry. ;)

 

Edit: And keep the ports changes we made! :-)

Share this post


Link to post
Share on other sites
Darklokey    16

No steam error on the Master side?

 

An other thing to try:

In Slave_settings.ini, your server token is different from the Master's one. I'm not sure its supposed to work like this...

Copy your server token from Master to Slave and retry. ;)

 

Edit: And leave the ports changes we made! :-)

Uh no or else I would get the message where the server wouldn't start, the token isn't the problem at all, it's the fact that the slave server isn't connecting to steam.

 

See I even changed it like you said

 

SLAVE_settings.ini

 

MASTER_settings.ini

 

SLAVE_log.txt

 

Share this post


Link to post
Share on other sites
Rtd    7

Ok, try this,

 

Master_settings.ini:

 

[network]
default_server_name = Julian The Lokey's World (Broke Caves)
default_server_description = WIP SERVER, CAVES DON'T WORK, PLEASE CONTACT ME IF YOU CAN HELP FIX.
server_port = 10998
steam_authentication_port = 12345
steam_master_server_port = 12346
max_players = 6
pvp = false
game_mode = endless
enable_autosaver = true
tick_rate = 15
connection_timeout = 8000


[shard]
shard_enable = true
is_master = true
master_port = 20050
cluster_key = Lokey'sdog

 

 

Slave_settings.ini:

 

[network]
default_server_name = Julian The Lokey's World (Broke Caves)
default_server_description = WIP SERVER, CAVES DON'T WORK, PLEASE CONTACT ME IF YOU CAN HELP FIX.
server_port = 10990
steam_authentication_port = 12347
steam_master_server_port = 12348
max_players = 6
pvp = false
game_mode = endless
enable_autosaver = true
tick_rate = 15
connection_timeout = 8000


[shard]
shard_enable = true
is_master = false
shard_name = caves
cluster_key = Lokey'sdog
master_ip = 127.0.0.1
master_port = 20050

 

Replace everything in each block.

Share this post


Link to post
Share on other sites
Darklokey    16

What's the point in editing the Master Server? The master server doesn't need the steam ports to function. It's the SLAVE SERVER that's broke. I'm not saying they have problems connecting directly to eachother. I'm saying that the Slave server KICKS ANYONE WHO ENTERS IT. I don't mean to be rude at all no, I'm trying to prove a point that the slave server is malfunctioning. This has nothing to do with the master server.

Share this post


Link to post
Share on other sites
Rtd    7

That's the exact same problem I had, and how I solved it. ;)

 

What we are doing here?

1/ We are making sure that Master uses default steam ports.

2/ Making sure that Server/Slave authentification don't fail on things like a mismatch server name by copying Master config on Slave's one... ;)

Share this post


Link to post
Share on other sites
Darklokey    16

That's the exact same problem I had, and how I solved it. ;)

 

What we are doing here?

1/ We are making sure that Master uses default steam ports.

2/ Making sure that Server/Slave authentification don't fail on things like a mismatch server name by copying Master config on Slave's one... ;)

 Well what you did didn't work for my own server

 

SLAVE_log.txt

 

SLAVE_settings.ini

 

MASTER_settings.ini

 

I hate to ruin your optimism but what didn't works simply didn't work this time.

Share this post


Link to post
Share on other sites
Rtd    7

Are you sure you have the steam ports allowed in your firewall?

 

Because, except that and a server token problem, I can't tell you why it does not work...

 

Edit: Just to make sure: You are launching both servers on the same machine, right?

Share this post


Link to post
Share on other sites
Darklokey    16

Are you sure you have the steam ports allowed in your firewall?

 

Because, except a server token problem, I can't tell you why it does not work...

 

Edit: Just to make sure: You are launching both servers on the same machine, right?

Steam ports are allowed, or else the master server couldn't connect to steam. If there's a way to allow batch files to use steam ports then that would be great. I couldn't be the server token or else the server would go like "I WILL NOT START UNTIL YOU GET ME A TOKEN" Thus how would the server even be able to start connecting to steam? I will thank you for trying though.

Share this post


Link to post
Share on other sites
Rtd    7

If there's a way to allow batch files to use steam ports then that would be great.

 

It's already the case, log.txt:

 

[00:00:11]: Steam ports can be configured through command line by adding:

[00:00:11]: -steam_authentication_port 12345 -steam_master_server_port 12346

 

Share this post


Link to post
Share on other sites
Rtd    7

 

dontstarve_dedicated_server_nullrenderer -steam_authentication_port 12345 -steam_master_server_port 12346 -conf_dir Caves_DST

doesn't work?

Share this post


Link to post
Share on other sites