Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Ipsquiggle

Playing Caves (beta)

Recommended Posts

Ipsquiggle    4,990

post-243632-0-40184900-1442514811_thumb.
 
Hey everyone, as you know we’ve been working hard on caves and are getting closer to launching it. With caves integration, there’s a lot of content that's being added into Don't Starve Together and we need your help in testing it to make sure that we didn’t break things on the live branch while adding caves to multiplayer.
 
While caves aren’t quite ready for prime-time just yet, if you would like to jump into our testing branch, we would really appreciate you letting us know if anything is broken or missing.
 

Caves Beta Requirements:

  • You must own Don't Starve Together
  • The game must not be running when opting into the beta branch
     

During the beta for caves, there will be 3 different ways for you to try out the caves and give feedback:

  • Sync to the beta branch, and join one of the dedicated caves servers which will be available. This will allow you to try out the full multi-level experience with both the overworld and caves.
  • Modify your existing dedicated server to support a caves world. (If you don't have a dedicated server and would like to start one, start here.)
  • Launch a pre-configured multi-level dedicated server from Steam.
     

1 - Join a beta server

  • In steam click on Library > Games.
  • Scroll down to Don't Starve Together Beta.
  • Right-click, select Properties.
  • Go to the Betas tab.
  • In the dropdown, select the cavesbeta branch.
  • In that same properties window, go to the Local Files tab and press Verify Integrity Of Game Cache.
  • It will update you to the beta version.
  • Run the game and go to Browse Games. You should see servers which are running the Caves beta. Have fun!

post-243632-0-86855000-1442520244_thumb.
post-243632-0-77753700-1442520243_thumb.
post-243632-0-47767200-1442520244_thumb.

 
2 - Make your dedicated server multi-level or caves-only


These instructions assume you're already running a dedicated server on a linux machine.
 
Make sure your server is synced to the Caves Beta steam branch. To do this, run steamcmd or modify your scripts to the following:
steamcmd +login anonymous +app_update 343050 -beta cavesbeta validate +quit
 
For a caves-only server:
 
1. Simply put a worldgenoverride.lua in your server settings folder, with the following contents:
 
return {override_enabled = true,preset="DST_CAVE",}

2. Then regenerate the world with c_regenerateworld()
 
For a multi-level server:
 
You'll need to run two instances of the server, one for the overworld and one for the caves. (Players migrate back and forth between these servers to use the caves.)
 
1. First, make a new settings directory next to your existing directory. For example, if your settings are at ~/.klei/DoNotStarveTogether, then make ~/.klei/DST_Cave.
 
2. You'll want to put the above worldgenoverride.lua into that folder so that it generates a caves world!
 
3. We will modify the original server settings to make it the Master shard. Modify DoNotStarveTogether/settings.ini to include a new shard section, like so:
 

[shard]shard_enable = trueis_master = truemaster_port = 11200cluster_key = secretkeysaresecret

The cluster_key is a shared secret between your shards so only your servers can connect to each other.
 
4. Copy the settings.ini from the DoNotStarveTogether folder into the DST_Cave folder you created, but change the shard section like so:

[shard]shard_enable = trueis_master = falsemaster_ip = 127.0.0.1master_port = 11200shard_name = cavescluster_key = secretkeysaresecret

5. You'll also have to provide alternate ports for the slave server which do not conflict with the master. In the [network] section of settings.ini, add or modify the following values:

[network]server_port = 11001steam_authentication_port = 12348steam_master_server_port = 12349

6. Finally: Duplicate your server launch script to run the slave server, pointing it at the slave settings directory:

./dontstarve_dedicated_server_nullrenderer -conf_dir DST_Cave

(Don't forget to add whatever other flags you might be using, such as -console)
 
7. Run both servers at the same time. After they initialize,  you should see them connect to each other in their respective logs.
 
8. You'll have to regenerate the master server with c_regenerateworld() to spawn cave entrances, or c_spawn('cave_entrance') if you really want to preserve your existing world.
 
9. Special instructions for working with mods:
 
Because both servers will be running out of the same directory at this point, it causes conflicts with mod downloading. You can pick one of two options for dealing with this, whichever suits your setup (thanks to @noice for the head's up).
 


Solution A: Install the server twice by running a second steamcmd with the +force_install_dir flag:
steamcmd +login anonymous +force_install_dir ~/steamapps/DSTCopy +app_update 343050 -beta cavesbeta validate +quit

Then run your caves server from that separate install.

 
Solution B: Manage mod downloading:

First force it to sync mods based on the current dedicated_server_mods_setup.lua

./dontstarve_dedicated_server_nullrenderer -only_update_server_mods

Then, run both servers and tell them to ignore mod synchornization

./dontstarve_dedicated_server_nullrenderer -skip_update_server_mods./dontstarve_dedicated_server_nullrenderer -skip_update_server_mods -conf_dir DST_Cave

 



 

 3 - Launch a pre-configured multi-level dedicated server

  • In steam click on Library > Tools.
  • Scroll down to Don't Starve Together Dedicated Server.
  • Right-click, select Properties.
  • Go to the Betas tab.
  • In the dropdown, select the cavesbeta branch.
  • In that same properties window, go to the Local Files tab and press Verify Integrity Of Tool Cache.
  • It will update you to the beta version.
  • Run the tool and select the Run pre-configured servers option.

post-284973-0-60705800-1447203362_thumb.

post-284973-0-13190100-1447203373_thumb.

post-284973-0-28020700-1447203380_thumb.

post-284973-0-69511700-1447203386_thumb.

 
 

Thank you for your help everyone! We're really excited to get caves into your hands and we are very much looking forward to your feedback. (Please don't forget to post your feedback in this thread.)
 
Success!! Now go spelunking. :spidercowers:

Share this post


Link to post
Share on other sites
Zackreaver    140

I keep getting connection to master failed.  Waiting to reconnect.

 

What should I check to see whats wrong?

 

Do I have to host 2 dedicated servers for this?  or can I host the overworld through client and the caves through dedicated?

Share this post


Link to post
Share on other sites
Zackreaver    140
You crash while opening the fight tab near any engine.

 

I can verify that this happens.  0 mods installed, just so we're clear.

 

 

[00:18:38]: Could not preload undefined prefab 0x68ba70ff (researchlab1)

[00:18:38]: Can't find prefab researchlab1
[00:18:38]: [string "scripts/consolecommands.lua"]:85: attempt to index local 'inst' (a nil value)
[00:18:45]: Serializing user session to session/0E100003A5F60241/KU_GCDyJytE_/0000000004
[00:18:45]: Serializing user session to session/0E100003A5F60241/KU_4NHEdity_/0000000004
[00:18:45]: Serializing user minimap to session/0E100003A5F60241/KU_CDaeCcaR_/minimap
[00:18:45]: Serializing user session to session/0E100003A5F60241/KU_CDaeCcaR_/0000000004
[00:18:46]: Serializing world session to session/0E100003A5F60241/0000000004
[00:18:56]: WARNING! Could not find region 'claw_glove.tex' from atlas 'images/inventoryimages.xml'. Is the region specified in the atlas?
[00:18:56]: Looking for default texture '(null)' from atlas 'images/inventoryimages.xml'.
[00:18:56]: images/inventoryimages.xml
LUA ERROR stack traceback:
        scripts/widgets/image.lua(32,1) in function 'SetTexture'
        scripts/widgets/recipetile.lua(25,1) in function 'SetRecipe'
        scripts/widgets/craftslot.lua(127,1) in function 'Refresh'
        scripts/widgets/craftslot.lua(198,1) in function 'SetRecipe'
        scripts/widgets/crafting.lua(196,1) in function 'UpdateRecipes'
        scripts/widgets/crafting.lua(111,1) in function 'SetFilter'
        scripts/widgets/crafttabs.lua(114,1) in function 'selectfn'
        scripts/widgets/tab.lua(192,1) in function 'Select'
        scripts/widgets/tab.lua(44,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/crafttabs.lua(272,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/screens/playerhud.lua(423,1) in function 'OnControl'
        scripts/frontend.lua(307,1) in function 'OnControl'
        scripts/input.lua(163,1) in function 'OnControl'
        scripts/input.lua(362,1)
[00:18:56]: images/inventoryimages.xml
LUA ERROR stack traceback:
        scripts/widgets/image.lua(32,1) in function 'SetTexture'
        scripts/widgets/recipetile.lua(25,1) in function 'SetRecipe'
        scripts/widgets/craftslot.lua(127,1) in function 'Refresh'
        scripts/widgets/craftslot.lua(198,1) in function 'SetRecipe'
        scripts/widgets/crafting.lua(196,1) in function 'UpdateRecipes'
        scripts/widgets/crafting.lua(111,1) in function 'SetFilter'
        scripts/widgets/crafttabs.lua(114,1) in function 'selectfn'
        scripts/widgets/tab.lua(192,1) in function 'Select'
        scripts/widgets/tab.lua(44,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/crafttabs.lua(272,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/screens/playerhud.lua(423,1) in function 'OnControl'
        scripts/frontend.lua(307,1) in function 'OnControl'
        scripts/input.lua(163,1) in function 'OnControl'
        scripts/input.lua(362,1)
[00:18:56]: images/inventoryimages.xml
LUA ERROR stack traceback:
        scripts/widgets/image.lua(32,1) in function 'SetTexture'
        scripts/widgets/recipetile.lua(25,1) in function 'SetRecipe'
        scripts/widgets/craftslot.lua(127,1) in function 'Refresh'
        scripts/widgets/craftslot.lua(198,1) in function 'SetRecipe'
        scripts/widgets/crafting.lua(196,1) in function 'UpdateRecipes'
        scripts/widgets/crafting.lua(111,1) in function 'SetFilter'
        scripts/widgets/crafttabs.lua(114,1) in function 'selectfn'
        scripts/widgets/tab.lua(192,1) in function 'Select'
        scripts/widgets/tab.lua(44,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/crafttabs.lua(272,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/screens/playerhud.lua(423,1) in function 'OnControl'
        scripts/frontend.lua(307,1) in function 'OnControl'
        scripts/input.lua(163,1) in function 'OnControl'
        scripts/input.lua(362,1)
[00:18:56]: SCRIPT ERROR! Showing error screen
[00:18:56]: WARNING! Could not find region 'stone_claw.tex' from atlas 'images/inventoryimages.xml'. Is the region specified in the atlas?
[00:18:56]: Looking for default texture '(null)' from atlas 'images/inventoryimages.xml'.
[00:18:56]: images/inventoryimages.xml
LUA ERROR stack traceback:
        scripts/widgets/image.lua(32,1) in function 'SetTexture'
        scripts/widgets/image.lua(13,1) in function '_ctor'
        scripts/class.lua(181,1) in function 'Image'
        scripts/widgets/ingredientui.lua(28,1) in function '_ctor'
        scripts/class.lua(181,1) in function 'IngredientUI'
        scripts/widgets/recipepopup.lua(277,1) in function 'Refresh'
        scripts/widgets/recipepopup.lua(303,1) in function 'SetRecipe'
        scripts/widgets/craftslot.lua(189,1) in function 'Refresh'
        scripts/widgets/craftslot.lua(198,1) in function 'SetRecipe'
        scripts/widgets/crafting.lua(196,1) in function 'UpdateRecipes'
...
        scripts/widgets/crafttabs.lua(272,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/widgets/widget.lua(116,1) in function 'OnControl'
        scripts/screens/playerhud.lua(423,1) in function 'OnControl'
        scripts/frontend.lua(307,1) in function 'OnControl'
        scripts/input.lua(163,1) in function 'OnControl'
        scripts/input.lua(362,1)
[00:18:59]: Force aborting...
 

 

Apparently there's a claw glove item thats missing it's icon?

 

I've never heard of a claw glove, is this a new caves item?  Either way it's causing the crash.

Share this post


Link to post
Share on other sites
Zackreaver    140

Yeah, I checked the crash log, there's apparently an item you can craft in there that's missing an icon.

 

Edit: An update just happened, I'm guessing klei found it

Share this post


Link to post
Share on other sites
Ipsquiggle    4,990

I keep getting connection to master failed.  Waiting to reconnect.

 

What should I check to see whats wrong?

 

Do I have to host 2 dedicated servers for this?  or can I host the overworld through client and the caves through dedicated?

 

Yes, it requires two servers; Because if you host the over world through the client, then when you join the caves, the overworld shuts down! (because you're in the caves now). So both the master and slave servers have to be dedicated.

Share this post


Link to post
Share on other sites
Zackreaver    140
overworld shuts down

 

Yeah my brain turned on and I figured that out.

 

I think I got it working now, but the recent update you guys released to fix that crash had me a little stumped for a moment.

 

But now that I realized the server needed an update, I should be good to go now.

 

Edit:

Is there an easy way to run 2 instances of the dedicated server?

 

Currently I just copied the entire folder and ran it separately, but is there an easier way than that?

Share this post


Link to post
Share on other sites
ToNiO55    298

Hi,

 

although I configure my 2 linux servers as it should (1 for classic game and 1 for cave)

 

unfortunatly i have problem for join cave

 

when I try to get into the cave, the server starts up with loading screen,but it remains on the same place without going in the cave, like same with all sinkhole

 

Here are a clear video of what happens exactly:

 

don't starve.txt

Share this post


Link to post
Share on other sites
ToNiO55    298

Hi @badceltics,

 

you need to make same setting for cave and your classic game:

 

settings.ini of folder DST_Cave

[shard]
shard_enable = true
is_master = false
master_ip = 127.0.0.1
master_port = 20050
shard_name = caves
cluster_key = badceltics

 

settings.ini of folder DoNotStarveTogether:

[shard]
shard_enable = true
is_master = true
master_port = 20050
cluster_key = badceltics

 

if you want you can change master port, same for cluster_key, it's just example with your name

Share this post


Link to post
Share on other sites
badceltics    7

@Tonio55, I did exactly what you said but it is still saying connection to master failed. Am I supposed to run two dedicated server at the same time? If so, how? Also I have two separate directories for my dedicated server. One called "MyServer" and the other "MyCaveServer". Right now am running DST and my dedicated server but still not working. 

Share this post


Link to post
Share on other sites
GuilhermeT    36

Hi there, I am trying setting my dedicated server with caves, but I got this error:

 

[00:00:00]: Starting Up
[00:00:00]: Version: 147566
[00:00:00]: Current time: Thu Sep 17 23:18:21 2015

[00:00:00]: Don't Starve Together: 147566 WIN32
NNN Build Date: 2015-08-21_14-57-45
[00:00:00]: Parsing command line
[00:00:00]: Command Line Arguments: -conf_dir DST_Cave
[00:00:00]: Initializing Minidump handler
[00:00:00]: ....Done
[00:00:00]: Fixing DPI
[00:00:00]: ...Done
[00:00:00]: THREAD - started 'GAClient' (7396)
[00:00:00]: HttpClient2::ClientThread::Main()
[00:00:00]: ProfileIndex:4.84
[00:00:00]: Network tick rate: U=15(2), D=0
[00:00:00]: Network tick rate: U=60(0), D=0
[00:00:00]: Authorized application C:\dontstarveserver\bin\dontstarve_dedicated_server_nullrenderer.exe is enabled in the firewall.
[00:00:00]: WindowsFirewall - Application already authorized
[00:00:00]: OnLoadPermissionList: APP:Klei/DST_Cave/save/blocklist.txt (Failure)
[00:00:00]: OnLoadPermissionList: APP:Klei/DST_Cave/save/adminlist.txt (Failure)
[00:00:00]: OnLoadUserIdList: APP:Klei/DST_Cave/save/whitelist.txt (Failure)
[00:00:00]: cGame::InitializeOnMainThread
[00:00:00]: Renderer initialize: Okay
[00:00:00]: AnimManager initialize: Okay
[00:00:00]: Buffers initialize: Okay
[00:00:00]: cDontStarveGame::DoGameSpecificInitialize()
[00:00:00]: FMOD Error: An invalid object handle was used.
[00:00:00]: GameSpecific initialize: Okay
[00:00:00]: cGame::StartPlaying
[00:00:00]: LOADING LUA
[00:00:00]: DoLuaFile scripts/main.lua
[00:00:00]: DoLuaFile loading buffer scripts/main.lua
[00:00:00]: scripts/main.lua(169,1) running main.lua

[00:00:00]: loaded modindex
[00:00:00]: ModIndex: Beginning normal load sequence for dedicated server.

[00:00:00]: DownloadMods(0)
[00:00:00]: FMOD Error: An invalid object handle was used.
[00:00:00]: LOADING LUA SUCCESS
[00:00:00]: PlayerDeaths could not load morgue
[00:00:00]: PlayerHistory could not load player_history
[00:00:00]: loaded profile
[00:00:00]: bloom_enabled false
[00:00:00]: loaded saveindex
[00:00:00]: OnFilesLoaded()
[00:00:00]: OnUpdatePurchaseStateComplete
[00:00:01]: Load FE
[00:00:01]: Load FE: done
[00:00:01]: ModIndex: Load sequence finished successfully.
[00:00:01]: Reset() returning
[00:00:03]: [200] Account Communication Success (6)
[00:00:03]: [ACCOUNT_ACTION_TOKEN_PURPOSE] Received UserId from TokenPurpose: KU_R9PohEGb
[00:00:03]: Starting Dedicated Server Game
[00:00:03]: Network tick rate: U=60(0), D=0
[00:00:03]: [Warning] Could not confirm port 10999 is open in the firewall.
[00:00:03]: Setting up socket descriptors
[00:00:03]: Online Server Started on port: 10999
[00:00:03]: Overriding server save slot to: 3
[00:00:03]: Collecting garbage...
[00:00:03]: lua_gc took 0.02 seconds
[00:00:03]: ~NetworkLuaProxy()
[00:00:03]: ~SimLuaProxy()
[00:00:04]: lua_close took 0.03 seconds
[00:00:04]: ReleaseAll
[00:00:04]: ReleaseAll Finished
[00:00:04]: cGame::StartPlaying
[00:00:04]: LOADING LUA
[00:00:04]: DoLuaFile scripts/main.lua
[00:00:04]: DoLuaFile loading buffer scripts/main.lua
[00:00:04]: scripts/main.lua(169,1) running main.lua

[00:00:04]: loaded modindex
[00:00:04]: ModIndex: Beginning normal load sequence for dedicated server.

[00:00:04]: LOADING LUA SUCCESS
[00:00:04]: PlayerDeaths could not load morgue
[00:00:04]: PlayerHistory could not load player_history
[00:00:04]: loaded profile
[00:00:04]: bloom_enabled false
[00:00:04]: loaded saveindex
[00:00:04]: OnFilesLoaded()
[00:00:04]: OnUpdatePurchaseStateComplete
[00:00:04]: Load Slot: ... generating new world
[00:00:04]: WorldSim::SimThread::SimThread()
[00:00:04]: WorldSim::SimThread::SimThread() complete
[00:00:04]: THREAD - started 'WorldSim' (3216)
[00:00:04]: WorldSim::SimThread::Main()
[00:00:04]: DoLuaFile scripts/worldgen_main.lua
[00:00:04]: DoLuaFile loading buffer scripts/worldgen_main.lua
[00:00:04]: DLC enabled : false
[00:00:04]: ModIndex: Load sequence finished successfully.
[00:00:04]: Reset() returning
[00:00:04]: scripts/worldgen_main.lua(79,1) running worldgen_main.lua

[00:00:04]: scripts/worldgen_main.lua(81,1) SEED = 1442542705
[00:00:04]: scripts/worldgen_main.lua(484,1) WORLDGEN PRESET: SURVIVAL_TOGETHER
[00:00:04]: scripts/worldgen_main.lua(492,1) WORLDGEN LEVEL ID: 1
[00:00:04]: scripts/worldgen_main.lua(499,1)
#######
#
# Generating Normal Mode Together Forever Level
#
#######

[00:00:04]: DoLuaFile Error: scripts/worldgen_main.lua:308: bad argument #1 to 'pairs' (table expected, got string)
LUA ERROR stack traceback:
=[C] in function 'pairs'
scripts/worldgen_main.lua(308,1) in function 'OverrideTweaks'
scripts/worldgen_main.lua(506,1)
=(tail call) ?
=(tail call) ?
[00:00:04]: scripts/worldgen_main.lua:308: bad argument #1 to 'pairs' (table expected, got string)
LUA ERROR stack traceback:
=[C] in function 'pairs'
scripts/worldgen_main.lua(308,1) in function 'OverrideTweaks'
scripts/worldgen_main.lua(506,1)
=(tail call) ?
=(tail call) ?
[00:00:04]: Error loading worldgen_main.lua
[00:00:04]: WorldSim::SimThread::Main() ERROR
[00:00:04]: scripts/worldgen_main.lua:308: bad argument #1 to 'pairs' (table expected, got string)
LUA ERROR stack traceback:
=[C] in function 'pairs'
scripts/worldgen_main.lua(308,1) in function 'OverrideTweaks'
scripts/worldgen_main.lua(506,1)
=(tail call) ?
=(tail call) ?
[00:00:04]: WorldSim::SimThread::Main() complete
[00:00:04]: scripts/worldgen_main.lua:308: bad argument #1 to 'pairs' (table expected, got string)
LUA ERROR stack traceback:
=[C] in function 'pairs'
scripts/worldgen_main.lua(308,1) in function 'OverrideTweaks'
scripts/worldgen_main.lua(506,1)
=(tail call) ?
=(tail call) ?
[00:00:04]: SCRIPT ERROR! Showing error screen

 

It's very not clear for me, I need to put the same ports in differents folders? I have the folder myserverc working like master, I still need put anything into DoNotStarveTogether? Thank you for any help. :D

Share this post


Link to post
Share on other sites
V2C    5,933

@ToNiO55, in the video, it looks like all the migration is working properly, but that the slave server has generated a 2nd forest world rather than a caves world.  Make sure you have the worldgenoverride.lua file (in the same folder as settings.ini), and delete your the "save" folder before you restart the slave server.

Share this post


Link to post
Share on other sites
blambin    6

i dont know why the cave world auto generate the server password in it's setting.ini file,so the main world can't connect with it .

 

it like :

server_password = ev9BPhoLSi0wlF
if i delete it ,it will regenerate after server reboot

Share this post


Link to post
Share on other sites
V2C    5,933

This is generated by the master server, and automatically applied for your client during migration.  You will never need to manually enter this password anywhere.

Share this post


Link to post
Share on other sites
blambin    6

When enter the cave,i will be kick out ,and the main server log here:

[00:47:40]: Validating 7: status: ACTIVE world: 1603015731 available: true    [00:49:37]: CURL ERROR: Operation too slow. Less than 5 bytes/sec transferred the last 60 seconds[00:49:37]: Failed to send server broadcast message[00:51:05]: New incoming connection 113.204.200.58|52304 GUID: 526921161855741524[00:51:05]: Client connected from IP: 113.204.200.58[00:51:05]: ValidateGameSessionToken token: RCExWysJ+++CiwFt85vLqt+YXAsW4Dnh for: 526921161855741524[00:51:07]: SendHandShakeServerListing[00:51:07]: [SHARD] Read save location file for 'KU_-aeI4Lmd'[00:51:07]: [SHARD] Save location file read! APP:Klei/SV2/save/session/077000C45E606996/KU_-aeI4Lmd_/savelocation for KU_-aeI4Lmd[00:51:07]: [SHARD] ForwardPlayerIfNeeded  worldId is [1([SHDMASTER])][00:51:24]: ReceiveResumeRequest[00:51:24]: Received request to resume from: session/077000C45E606996/KU_-aeI4Lmd_/0000000003[00:51:24]: OnResumeRequestLoadComplete - UserID KU_-aeI4Lmd[00:51:24]: [Load] SPAWNING PLAYER AT: (-196.47, 0.00, -186.60)    [00:51:29]: Activating portal 7 to 1603015731    [00:51:29]: Serializing user minimap to session/077000C45E606996/KU_-aeI4Lmd_/minimap[00:51:29]: Serializing user session to session/077000C45E606996/KU_-aeI4Lmd_/0000000003[00:51:29]: [SHARD] Requesting migration of player KU_-aeI4Lmd from [SHDMASTER] to 1603015731(caves)[00:51:29]: [SHARD] Beginning migration of player KU_-aeI4Lmd from 1([SHDMASTER]) to 1([SHDMASTER]) (2).[00:51:29]: [SHARD] Migrating player data from: session/077000C45E606996/KU_-aeI4Lmd_/0000000003[00:51:30]: [SHARD] CLOSE CONNECTION for 1113337429[00:51:30]: CloseConnectionWithReason: ID_DST_SHARD_SILENT_DISCONNECT[00:51:30]: [SHARD] Received disconnect notification for 'KU_-aeI4Lmd' on server '1([SHDMASTER])' ('1([SHDMASTER])')[00:51:49]: [SHARD] Migration for KU_-aeI4Lmd timed out.[00:51:49]: [SHARD] Cancelling pending migration of player 'KU_-aeI4Lmd' from '0()' to '0()' (2).

The cave logs here :

   [00:00:18]: Reconstructing topology    [00:00:18]:     ...Sorting points    [00:00:18]:     ...Sorting edges    [00:00:18]:     ...Connecting nodes    [00:00:18]:     ...Validating connections    [00:00:19]:     ...Housekeeping    [00:00:19]:     ...Done!    [00:00:19]: 1 uploads added to server. From server_temp[00:00:19]: [SHARD] Connecting to master...[00:00:19]: Telling Client our new session identifier: 069000C50797D240[00:00:19]: [Warning] SteamGameServer_Init Failed[00:00:19]: Your server will still start, but some Steam functionality may be missing.[00:00:19]: Steam ports can be configured through command line by adding:[00:00:19]: -steam_authentication_port 12345 -steam_master_server_port 12346[00:00:19]: or through settings.ini, under the [network] heading[00:00:19]: steam_authentication_port = 12345[00:00:19]: steam_master_server_port  = 12346[00:00:19]: [Warning] Disabling Steam services[00:00:19]: Auth port: 8766 Master server port: 27016[00:00:19]: [SHARD] Sending slave information to master...[00:00:19]: [SHARD] Registering in lobby as a slave server...[00:00:22]: [SHARD] Slave is now ready![00:00:22]: World '1' is now connected    [00:04:12]: [SHARD] Migrating player data to: session/069000C50797D240/KU_-aeI4Lmd_/0000000002[00:04:12]: [SHARD] Received player migration data packet for 'KU_-aeI4Lmd' (2)[00:04:12]: [SHARD] PASS IS 'oP8ppN5xplmzmW'[00:04:31]: [SHARD] Migration by user ('KU_-aeI4Lmd') failed (157).
 

Share this post


Link to post
Share on other sites
Zackreaver    140

So far my caves server is running pretty good, haven't found any problems with it at the moment.  At a capacity of 6 at the moment.  Not sure what would happen if I raise it.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.