Jump to content

[Resolved] Updater 23 not getting fully downloaded


Recommended Posts

I downloaded the standalone installer for osx. After installing, it opens and proceeds to update the updater from 22 to 23. It appears as if 23 is not getting downloaded fully, because the folder is only 11,877,964 bytes, while 22 is 41,277,646 bytes. After 22 pretends to download 23, and you hit restart, nothing happens. If you go into the 23 directory and attempt to launch it directly, nothing happens. Only 22 works. I have repaired, file system permissions numerous times. I have even ran it from the desktop, and it still exhibits the same behavior. Is there a way to download the version 23 updater directly? 

Link to comment
Share on other sites

Thanks for reporting this to us; we've rolled back the Mac OS X updater and you will now be able to update your game to the latest version and launch the game.

Okay I have a similar problem...not sure if this is the right place or if it's even the same bug or what but what do you mean by saying you "rolled back the Mac OS X updater and you will now be able to update your game to the latest version and launch the game."? Because if what you did was resolve the bug, I'd like to point out that I am experiencing technical difficulties updating. It will not finish updating, as shown below. It simply allows a restart of an unresolved update or to skip the update all together and continue to play the previous version. I am running OS X 10.9.5 on a macbook pro - no mods whatsoever on game - am I supposed to re-download the game or something?

 

 

33k6p80.png

Link to comment
Share on other sites

Okay I have a similar problem...not sure if this is the right place or if it's even the same bug or what but what do you mean by saying you "rolled back the Mac OS X updater and you will now be able to update your game to the latest version and launch the game."? Because if what you did was resolve the bug, I'd like to point out that I am experiencing technical difficulties updating. It will not finish updating, as shown below. It simply allows a restart of an unresolved update or to skip the update all together and continue to play the previous version. I am running OS X 10.9.5 on a macbook pro - no mods whatsoever on game - am I supposed to re-download the game or something?

 

 

33k6p80.png

 

It sounds like your Updater may be stuck at version 22 for some odd reason. Try these next few steps:

  • Right-click "dontstarve.app", select "Show Contents"
  • Navigate to dontstarve.app > Contents > MacOS
  • Open the file "dontstarve.sh" in any text editor.

The contents of dontstarve.sh should be: 

 

#!/bin/bash
cd "$(dirname "$0")"
open ../updater/23/updater.app
 
If you find that the final line says .../updater/22/updater.app, change that line to ../updater/23/updater.app and save the file. 
Link to comment
Share on other sites

Same problem, Updater log:

 

Exception in thread Thread-2:

Traceback (most recent call last):
  File "/Volumes/Workspace/Jenkins-MrBuildDS/workspace/DontStarve_Release_OSX_StandAlone_MakeDMGPackage/source/tools/Updater/build/updater.osx/out00-PYZ.pyz/threading", line 810, in __bootstrap_inner
  File "<string>", line 296, in run
  File "/Volumes/Workspace/Jenkins-MrBuildDS/workspace/DontStarve_Release_OSX_StandAlone_MakeDMGPackage/source/tools/Updater/build/updater.osx/out00-PYZ.pyz/wx._core", line 8410, in PostEvent
TypeError: in method 'PostEvent', expected argument 1 of type 'wxEvtHandler *'
 
Link to comment
Share on other sites

Sorry for the inconvenience everyone, we are aware of the issue and are working to resolve it as soon as possible. 

 

In the meantime, you will be able to bypass the updater and play the game by following these steps:

  • Open Finder on your Mac and look for Don't Starve.pp
  • Right-click on Don't Starve.app, select "Show Package Contents"
  • Navigate to Contents/MacOS
  • Double click on dontstarve
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...