Jump to content

[GAMEPLAY] Can't interact with anything


Recommended Posts

Please choose a category




Standalone on Mac

Do you use mods?


Version Number


Issue title

I can't interact with any object
Steps to reproduce

Resumed a game in survival mode.
Describe your issue

I'm playing a game in survival mode, currently on day 172. 2 days ago everything was working perfectly, however, today the game autoupdated on startup. After completing the update and resuming the game I realized I cannot interact with anything in world. I can still use the left menus to build, but neither does clicking clicking on my backpack wich currently lies on the floor, nor pressing the space bar produce any results.


I'm afraid to continue playing since it's currently winter and nighttime so I'll either freeze to death or be killed by the darkness once my torch dies out (I've also tried dragging items into my fire pit to produce a fire, but the game won't let me do that either).


The mouseclick event seems to be recognized, since I can still move Wilson by clicking around on the floor, but I don't get any text prompts when hovering it above any object in the game.


I've spent so much time on this game and would hate to seet it go to waste because of this bug. Please help!




Link to comment
Share on other sites

I'm having the same issue and I'm on a Mac on version 132878. The problem seemed to start after I opened the game to continue play and it auto-updated... the game I was in then behaved strangely and I ended up dying, and now every new game I start (with or without custom settings and no mods) is empty, despite the map showing trees and such. 

Link to comment
Share on other sites

Thank you for starting this post-- I the same problem which started with this auto-update. Also on Standalone on Mac Yosemite OSX, version 132878. I don't use any mods or custom settings. All of my old games and new games are glitching-- all with blank/empty worlds or half empty worlds despite the map showing trees, etc. Is this the best way to get Klei to notice the problem, or should I post somewhere else too?

Link to comment
Share on other sites

We're aware of the issue and our programmers are looking into it. In the meantime, please provide us with your log.txt file, the log is found in your documents folder at Documents\Klei\DoNotStarve\log.txt


One fix you can try is to validate your game files. To do that, fully close Don't Starve and re-launch it; on the Don't Starve updater, click on the "Check Consistency" option under the "File" Menu. This will check game files and download/repair any ones that are missing or corrupted.




Link to comment
Share on other sites

  • Developer

@elmogwai, thanks for reporting the issue! We've rolled back the standalone build for Mac OSX, so next time the updater runs, it will remove the most recent patch and revert it to the previous version. (DS 104670, RoG 102572)

Unfortunately we haven't yet been able to reproduce the issue here in the office; could you please send us details on your machine specs, your log.txt file (elmogwai you can skip this part as you included your log already), as well as your save files and settings.ini file so we can take a look. These files will be located at ~/Documents/Klei/DoNotStarve/.
If you could wrap those up in a zip file and upload it here, or email it to us at livesupport@kleientertainment.com, that would be really helpful. If you run into any issues with the build after it reverts back to the previous version, please let us know.


Link to comment
Share on other sites

The rollback worked. Everything's normal again in my game!


These are my machine specs:


iMac (21.5-inch, Late 2012)

OSX Yosemite 10.10.2

Processor: 2.7 GHz Intel Core i5

Memory: 8 GB 1600 MHz DDR3

Graphics: NVIDIA GeForce GT 640M 512 MB


I'm also attaching the zip with the settings.ini file and the entire saves folder, hoping they're of any use.


Thanks so much.

Klei Files.zip

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...