Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Ipsquiggle

Reign of Giants public test: March 20th Update

Recommended Posts

MathBuster    0

Me and my sister spent all of yesterday playing. Everything ran smoothly, and we experienced no crashes whatsoever. There were some minor oddities and bugs, but nothing game-breaking across several plays.

 

A few of the bugs/oddities we encountered:

 

- Some world options show up in the world edit menu twice now. The pighead picture, for example - but there are multiple duplicates.

- Ominous Deerclops growling isn't heard by all players.

Share this post


Link to post
Share on other sites
KarateF22    18

The two big bugs I have seen are that Deerclops can spawn in Spring and that Lureplants are still spawning at an absolutely insane rate, at least one per 30 seconds if not more.

Share this post


Link to post
Share on other sites
AlternateMew    265

Dragonfly is working properly as far as falling asleep after eating enough ash. However, Bearger isn't falling asleep after eating 10 honey. Or 20 for that matter.

Share this post


Link to post
Share on other sites
Zinglon    131

Dragonfly is working properly as far as falling asleep after eating enough ash. However, Bearger isn't falling asleep after eating 10 honey. Or 20 for that matter.

 

Wait. Are the other giants appear on current DST test version?

 

- Checked. Oh I don't know Klei had updated them. lol...

Share this post


Link to post
Share on other sites
Sindex    141

Wait. Are the other giants appear on current DST test version?

 

As far as I know you can spawn them in. However anyone who joins the server other then the host crashes instantly. So no, I don't think they were officially added yet.

 

EDIT: On a side note I don't know if anyone else noticed the duplicate beefalo in the world preset selection beyond the duplicate touch stone one. Also I noticed that there is no world preset selection for tallbirds.

Share this post


Link to post
Share on other sites
Ipsquiggle    5,231

Whewf! I count 42 new bug reports from you guys over the weekend (an auspicious number!), so we'll be busy busy busy today fixing those!

Thanks so much for all your testing, you have no idea what a big help this is.

Share this post


Link to post
Share on other sites
Ipsquiggle    5,231

Also, everyone regarding Lure Plant Spawning. The amount of lureplants is saved into the world, so you can either

  • regenerate your world, or
  • enter the following console command to reconfigure an existing world:
You must be HOST or an ADMIN to use this command successfully.

1. Open the console with the ~ key.

2. If you are on a dedicated server: Tap "ctrl" key so that the word "remote:" appears next to the input box.

3. Type the following and then press enter:

TheWorld.components.lureplantspawner:SpawnModeMed()
There will be no feedback that the change was successful, but if there were no errors/crash then your world should be fixed and lureplants should spawn infrequently again!

Share this post


Link to post
Share on other sites
toastmasta    14

I have yet to see the majority of any of these bugs that people have reported with exception to the charcoal from trees, which is hardly anything.

 

I bet alot the "bug reporters" are running old worlds after the game has been updated and are running a crap load of mods.  Reporting errors for an unstable beta while you are running 20 unsupported mods is completely UNRELIABLE.  Your bugs/errors could very well likely be do to something you are running locally, yet we will never now.  Hence the unreliablity aspect.

Share this post


Link to post
Share on other sites
Dea7h    0

when spring hits and it starts to rain the server stops responding and we get booted from dedicated servers

Share this post


Link to post
Share on other sites
ailailou    729

One of those pigheads on a stick got burned, and after hammering it it dropped 2 pigskin and 2 sticks just like the normal structure. Shouldn't it give half the normal resources in this case?

Share this post


Link to post
Share on other sites
Sleestak    11

Found a group of guard pigs killing each other for no discernible reason.

Used c_spawn("Goose") to spawn Goose/Moose, created a static creature that could not be interacted with (probably because it isn't hooked up yet).

Some werepigs after full moon remained as werepigs when found later.

 

I had both of these issues, but the guard pigs also happened on regular DS:RoG

Share this post


Link to post
Share on other sites
Sleestak    11

I have yet to see the majority of any of these bugs that people have reported with exception to the charcoal from trees, which is hardly anything.

 

I bet alot the "bug reporters" are running old worlds after the game has been updated and are running a crap load of mods.  Reporting errors for an unstable beta while you are running 20 unsupported mods is completely UNRELIABLE.  Your bugs/errors could very well likely be do to something you are running locally, yet we will never now.  Hence the unreliablity aspect.

 

I play with no mods, on the most recent version with a new world, and I have gotten many of these bugs. It's not safe to assume that just because you don't get them, everyone else doesn't.

Share this post


Link to post
Share on other sites
Avanyali    1

A few days before winter ended, bees started coming out of their hives. There was still snow on the ground, and the environment color was winter. The bees were not aggressive.

Share this post


Link to post
Share on other sites
zdg1234    0

BUG in 131117:

1.I passed second autumn,and saved.When I resumed the world,I found that pig house,trees and drying rack are burning in no reason.

2.Crash when I used fire staff.

3.I can't use any item(including straw roll and tent) to sleep,after I turned off the hound in world generator.

Share this post


Link to post
Share on other sites
ToNiO55    298

Hi,

 

i have other crash on my server dedicated

 

unfortunately I only find little error in log.txt sorry

 

Ready....    0    
Set....    0    
Go!    0    
invalid key to 'next'
LUA ERROR stack traceback:
=[C]:-1 in (local) (for generator) © <-1--1>
scripts/update.lua:177 in () ? (Lua) <146-213>
   dt = 0.033333335071802
   tick = 843138

SCRIPT ERROR! Showing error screen    
QueryServerComplete no callback

 

I hope this will help you

Share this post


Link to post
Share on other sites
enragedcamel    195

Deerclops can not be heard growling client side on both hosted and dedicated servers.

 

I have never had this issue. Have you tried disabling your mods?

Share this post


Link to post
Share on other sites
Etna    145

Bug: Crash when Ice Flingomatic attempts to put out continuous fire in mid-summer

 

Reproduce: Plant a grass field farm with the edge a bit outside Flingomatic range. A while after trying to put out fire, game crash.

 

Here is the error report:

 

11078742_1727261744167166_541067877_o.jp

This image link seems to be broken. Any change you could try again?

Share this post


Link to post
Share on other sites
rezecib    3,144

@Etna, Strange, it loaded for me in the post and the quoted post. But it's the same stack trace as what ToNiO55 reported.

 

Edit: Specifically:

Ready....    0    

Set....    0    
Go!    0    
invalid key to 'next'
LUA ERROR stack traceback:
=[C]:-1 in (local) (for generator) © <-1--1>
scripts/update.lua:177 in () ? (Lua) <146-213>
   dt = 0.033333335071802
   tick = 843138

SCRIPT ERROR! Showing error screen    
QueryServerComplete no callback

 

Share this post


Link to post
Share on other sites
Doddler    52

We did a DST session yesterday and haven't run into any major bugs that haven't been reported so far. One oddity was before winter hit and it got cold enough we would take cold damage without any prior freezing warning. Once winter started we started getting the screen freezing effect as normal.

 

Also, I'm not entirely sure how the deerclops is supposed to behave. We ran into one not too far away from base and just ran a few screens away and left him there. As far as I can tell he just idled there all winter without coming after us or really moving around. Is that normal? I don't have much experience with the giants, but I expected they might be more... pesky?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.