Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Yeshishi

Season Randomization Problem

Recommended Posts

Yeshishi    0

Straight to the point:

 

I recently started randomizing season parameters for my world before starting a game, AKA - I choose "random" for season length and starting season. Two Weird things seem to happen every time I do this, the first being more annoying than the second:

 

1. Every time I load my saves, everything connected to seasons randomizes again, as though I started a new world. For example - when I saved, I was in the middle of spring, but when I loaded the game, it was first day of winter with no spring present at all in the game.

 

2. I start the game with three chests full of goodies circling me, and what seems like plenty of spider dens all around.

 

Any suggestions? This kind of pists me off. I would appreciate a quick answer.

Thanks guys.

Share this post


Link to post
Share on other sites
cptCalavera    616

I did the same in one of my runs and found the same thing in no 1. It is really annoying unless you play really long sessions. But that is how it works, it resets the random values every time you load the game. The thing I found most annoying was the fact that it is possible to completely skip a season.

 

As far as I know, no fix for this.

 

As for number two, this happen when you chose the preset "default plus" Did you do that?

Share this post


Link to post
Share on other sites
Yeshishi    0

Well, if this is how it works, a fix is crucial. No logic in keeping it the way it is. Can anybody think about a minor script edit to fix this?

I used a custom preset,without changing anything other than the season randomization I stated above.

Help, anyone?

Share this post


Link to post
Share on other sites
Yeshishi    0

OK, I tried something. Still not a solution, but helps understanding what's going on:

 

I tried generating a world with only all 4 season length parameters randomized (without "season start" randomization). Issue 2 was not present, but issue 1 was still a problem.

 

I tried vice versa, randomizing only the season start without touching season length. All was well.

 

So the problem is something to do with season legth randomization. Nevertheless, no idea what the problem is.  :frown-new:

Share this post


Link to post
Share on other sites