DarkXero

Solutions (host+client in same PC)

Recommended Posts

SnowyPanda    5

Can someone give me step by step instructions on how to update my dedicated server through SteamCMD?

 

The steps in the wiki is not very clear

 

 

Share this post


Link to post
Share on other sites
ToNiO55    296

well i'm on linux and i have not make server on windows 7 or on windows server

 

but maybe you can make batch "update.bat" like this:

 

steamcmd +login anonymous +force_install_dir D:\Servers\DST\ +app_update 343050 validate +quit

 

maybe that it is possible to automate this script with the task scheduler under Windows, for example restart the server and update daily, but i don't know how restart server on windows :razz:

Edited by ToNiO55

Share this post


Link to post
Share on other sites
Lucinastar    3

Ok I've been trying to get into my server for hours with no luck.

I have a RT N66U router and I'm not sure on what setting I have to change in order to get in. I'm not really sure if some of these solutions can help me because my router settings are worded different.

I have 2 connections btw one is a 2.4 and the other is 5. Is it possibly to make it so that one of the connections can be seen as a different connection so I can log into my server?

Share this post


Link to post
Share on other sites
Lucinastar    3

@DarkXero I have not but won't making it LAN make the server offline? I'm trying to join the server while its online. Will doing this help?

Share this post


Link to post
Share on other sites
DarkXero    2,881

@Lucinastar, when creating the server, pick ONLINE.

When selecting the filters for your server search, pick LAN.

 

Check the OP's post, I edited it with an image to show what to switch.

Edited by DarkXero

Share this post


Link to post
Share on other sites
Lucinastar    3

@Lucinastar, when creating the server, pick ONLINE.

 

Check the OP's post, I edited it with an image to show what to switch.

 

Sorry for the late reply. I tried to switch it LAN in the the game but my server doesn't show. It will if I switch back to NO it's still there though. I know it has to be because of my router but I'm not sure where I should go to on my router settings to configure it correctly.

Share this post


Link to post
Share on other sites
DarkXero    2,881

@Lucinastar, try forcing your connection.

 

After pressing Play!, open the console (the tilde "~"), and use the command:

c_connect(ip, port, password)

Where IP is the IP you used on your router to portforward to. i.e 192.168.1.123

Port is the port you portforwarded, default is 10999.

Password if your server has a password.

c_connect("192.168.1.123", 10999)
  • Like 1

Share this post


Link to post
Share on other sites
Lucinastar    3

 

@Lucinastar, try forcing your connection.

 

After pressing Play!, open the console (the tilde "~"), and use the command:

c_connect(ip, port, password)

Where IP is the IP you used on your router to portforward to. i.e 192.168.1.123

Port is the port you portforwarded, default is 10999.

Password if your server has a password.

c_connect("192.168.1.123", 10999)

 

Just tried this. Still says server isn't responding. It's not really a problem with my server as everything checks out fine and I can see people joining and talking to each other.

My router settings just must be blocking something on my end, I looked at the soultions on here and they seem helpful but my router settings layout is a bit confusing for me.

I see multicast in my router settings but I have no idea how to disable it or if I can. Also I'm not sure if I disabled all the NAT filters I have.

 

Share this post


Link to post
Share on other sites
Lucinastar    3

@Lucinastar, can you show me what's in the Wireless, WAN and Firewall tabs?

Here ya go. If you need me to take some more screenshots of my settings feel free to ask. Thanks for trying to help btw. :joyous:

3lu0vPB.png5ADz5dK.png

rzoNCa9.png

Share this post


Link to post
Share on other sites
Lucinastar    3

Hi Lcinastar,

 

when you make c_connect("192.168.1.123", 10999)

 

do you have black screen?

 

Yeah it fades into black a few seconds then fades back in saying the server not responding.

  • Like 1

Share this post


Link to post
Share on other sites
Lucinastar    3

Maybe my server needs to be update for me to join?

I checked my version on the list and it says 130891. Is this the latest update number?

Share this post


Link to post
Share on other sites
ToNiO55    296

Maybe my server needs to be update for me to join?

I checked my version on the list and it says 130891. Is this the latest update number?

 

it's normal server DST? or server DST ROG?

Edited by ToNiO55

Share this post


Link to post
Share on other sites
Lucinastar    3

@Lucinastar, I'm gonna ask for you to put "Enable NAT:" to "No."

Then try again hosting and looking with your client. Remember to look for "Show LAN: No" and "Show LAN:Yes".

 

130891 - http://forums.kleientertainment.com/topic/52208-game-update-130891-3202015/ is DST without RoG.

Your client doesn't have the RoG beta testing branch enabled, right?

 

I tried what you said with the NAT being off and it just disabled my internet connection off my computer (my router and modem are not connected to my gaming desktop pc that I'm using now, they're connected to a MAC downstairs). Is it supposed to do that or did something wrong?

No my client is a normal DST server. I didn't know they had DST RoG servers now.

Share this post


Link to post
Share on other sites
ToNiO55    296

 

It's normal DST. I didn't even know they had DST ROG server.

 

if you want you can update your server DST for server ROG

 

http://forums.kleientertainment.com/topic/52116-reign-of-giants-public-test-help-us-out/

 

just use this command for update your server:

 

app_update 343050 -beta rog_together_beta -betapassword rogtogetherbeta validate

Edited by ToNiO55

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now