Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Thekey147

Windows Server 2012 - server_token.txt?

Recommended Posts

Thekey147    0

I'm going to start off by saying that I love DST, have been playing a bit too much too fast with a friend of mine, and that I've been wanting a way to set up a dedicated server for a while.

 

But that I'm no stranger to hosting servers.

I LOVE SteamCMD, and it really makes everything else look like a pain. An outdated minecraft server? Time to go search for the updated .exe and hope you can use the old world...

Star Wars Battlefront 2 was the worst headache, but anyway..

 

I briefly read the Wiki and set up this script so it'd just close out when it was done.

"C:\Dedicated Servers\SteamCMD\steamcmd.exe" +login anonymous +force_install_dir "C:\Dedicated Servers\SteamCMD\dst" +app_update 343050 +quit

 

This was set up to a SteamCMD shortcut, and afterwards I change it to "+app_update 343050 validate" that way if it's out of date, it updates the server and only requires me to hit a button.

 

Pretty awesome, I spent a lot of time making sure all of my servers (11 with just SteamCMD) worked almost automatically.

 

But then, this stumped me.

server_token.txt isn't in /My Documents/Klei/DoNotStarveTogether/

In fact, I don't have a single server_token.txt in my entire computer.

 

Also, something that bothers me..

Why save things in the Documents folder?

Especially a dedicated server, it's awful to have things not in the directory installed...

 

Anyway, I ran the server once, it gave me an error of the server_token.

Automatically created a Klei folder, but it doesn't have a server_token.txt file...

 

I'm lost x_x

Share this post


Link to post
Share on other sites
TonyV    9
Also, something that bothers me.. Why save things in the Documents folder? Especially a dedicated server, it's awful to have things not in the directory installed...

 

Because it modifies those files frequently, especially the save files.  Windows doesn't like files that are frequently modified stored in your Program Files folder(s).  Also, you can run multiple servers on the same machine, which means that you might have several configuration and save file directories.  Files and directories of this kind of transient nature definitely belong in Documents, not Program Files.  ;)

Share this post


Link to post
Share on other sites
MarkL    537

I'm looking into the ability to generate the server_token.txt directly on the server by providing steam credentials.  (In a similar vein to SteamCmd Login).  

 

Please note, server_token.txt can be reused on all the machines you want to host, and only has to be generated once.

 

As @rezecib mentioned, it currently has to be generated in the Game Client.

 

Share this post


Link to post
Share on other sites
Azerath    0

Hi,

 

I went to the point of generating the server_token but I just don't understand where I should place it.

I made the dedicated server use the default configuration directory, then I tried with a different directory ([-config_dir...]) and each time the windows console end up telling me that the server will not start because there is no token.

Each time I placed the server_token file in the directory and in the settings.ini in the [Acount] section there is a token = 7 ... : ... t but it doesn't change anything.

I don't know what to do anymore.

I plan to do a video tutorial on it but I am still not able to do it myself, it is kinda sad xD

Share this post


Link to post
Share on other sites
Screamer21    8

Hi,

 

I went to the point of generating the server_token but I just don't understand where I should place it.

I made the dedicated server use the default configuration directory, then I tried with a different directory ([-config_dir...]) and each time the windows console end up telling me that the server will not start because there is no token.

Each time I placed the server_token file in the directory and in the settings.ini in the [Acount] section there is a token = 7 ... : ... t but it doesn't change anything.

I don't know what to do anymore.

I plan to do a video tutorial on it but I am still not able to do it myself, it is kinda sad xD

 

I found a solution that worked for me:

Put your token in your settings.in under the account section.

It should look like so:

[account]

server_token = insert Token here

dedicated_lan_server = false and remove the server_token.txt file.Hope i could help you :)

Share this post


Link to post
Share on other sites