Sign in to follow this  
Corey

"Error: Module load error:" - MASTER THREAD

Recommended Posts

vadjok88    14

vadjo88 - what kind of graphics card do you have, and what version of the driver. You appear to be on the Chrome GPU blacklist.

You may be able to update your graphics card driver to get off the list, although it's going to depend upon what hardware you have.

I have ATI Radeon HD 2400 XT card.

Driver is ATI v 8.561.0.0

As I remember it's not the last driver update, but that's because I had problems with higher ones.

I've got TravelMate5720 - I'm not the only one with this driver issue having this laptop...

Share this post


Link to post
Share on other sites
Silent    10

Beta 66910 switched from my normal error to one telling me my video drivers were out of date. Updated my drivers and hey presto, the game works! I've also managed to start more than once and will probably be making my purchase in the near future. Great work, folks! Here's to the final build and strong sales!

Share this post


Link to post
Share on other sites
vadjok88    14

I guess there won't be any more updates on this topic. I tried to upgrade my drivers - unfortunately the version I have is the highest that works for my PC. Is there any chance I will play this game or that's about it?

Share this post


Link to post
Share on other sites
Kevin    871

I guess there won't be any more updates on this topic. I tried to upgrade my drivers - unfortunately the version I have is the highest that works for my PC. Is there any chance I will play this game or that's about it?

It looks like chrome does not like that particular card. You can try doing what they recommend here : http://productforums.google.com/forum/#!topic/chrome/hTKgYlXFHRY, but it may result in graphical glitches in the game. YMMV.You may have better luck with the steam version, eventually.

Share this post


Link to post
Share on other sites
Kevin    871

in the shortcut, you should have: ...chrome.exe" --ignore-gpu-blacklist

Share this post


Link to post
Share on other sites
vadjok88    14

in the shortcut, you should have: ...chrome.exe" --ignore-gpu-blacklist

Wooohooo - can play a game!! ^^Thanks Kevin!

Share this post


Link to post
Share on other sites
vadjok88    14

Now - the only thing - I get a BLUE SCREEN when pressing BUY NOW! xDIs there any option I can get a key remotely and then just enter it without going through the BUY NOW button... ?

Share this post


Link to post
Share on other sites
Kevin    871

Now - the only thing - I get a BLUE SCREEN when pressing BUY NOW! xDIs there any option I can get a key remotely and then just enter it without going through the BUY NOW button... ?

Do you mean a Blue screen of death that crashes your OS, or the screen is rendering all blue?In either case, it's probably being caused by whatever underlying issue that made Google put your configuration on the blacklist in the first place. Unfortunately, there isn't much we can do to help, other than have you try using the steam client when it comes out.We are still looking into alternate payment arrangements. These things move at the speed of business, sadly. :)

Share this post


Link to post
Share on other sites
vadjok88    14

Yeah - it's a proper OS crash screen! :D Makes sense - doesn't it... Well - at least I can play with a demo for few days - become a PRO at the basic level... hahaWill be looking forward for the STEAM version.Any ideas when it's gonna be released or it's hard to tell yet?Would be nice to play it before the END OF THE WORLD COMES on the 21.12.20012.. :p

Share this post


Link to post
Share on other sites

The 'ignore blacklist' work around works for me, and I have no crashes after playing for a solid 30 minutes. Awesome game, I can't wait to get even more immersed in this!- Zero

Edited by Zero_Starlight

Share this post


Link to post
Share on other sites

Well, I am too getting an "Error: Module Crashed: NaCl module crashed" however, it seems like it is happening to most people when trying to load a game and while on windows XP... For me, it is consistently crashing when I kill a tree monster guy via fire and the items it drops burn away.I'm using Windows 7, and an NVIDIA GeForce GTX 460, and have updated my drivers within the last month.

Share this post


Link to post
Share on other sites
NameBasics    10

This is the crash report I'm recieving:Module load error: NaCl module load failed: Validation failure. File violates Native Client safety rules.Any help? I can post my system info if you need, but I didn't even see this report in your updated post. Not sure if this is a different problem all-together or something you have seen yet.

Share this post


Link to post
Share on other sites
Kevin    871

This is the crash report I'm recieving:Module load error: NaCl module load failed: Validation failure. File violates Native Client safety rules.Any help? I can post my system info if you need, but I didn't even see this report in your updated post. Not sure if this is a different problem all-together or something you have seen yet.

This one is due to a chrome bug which (I think) will be fixed in an upcoming update. Sometimes, files get written to the cache in a bad way, and when you try to load them again they are corrupt.The workaround (until the Chrome fix goes live) is to clear out your cache, and let the game download its files again.

Share this post


Link to post
Share on other sites
NameBasics    10

I have tried this and deleting all temp files, but to no avail. Not sure if that'll effect its running on the new update, so I will let you know. Extremely eager to play this game, so I hope the game sees its Steam release Soon.

Share this post


Link to post
Share on other sites
nblackburn    10

Hey,I am getting this error, directly upon loading the game...

Error: Module load error: NaCl module load failed: ServiceRuntime: command channel creation failed

Share this post


Link to post
Share on other sites
Kevin    871

Hey,I am getting this error, directly upon loading the game...

OK, that one is a different error. It means that NaCl is failing to initialize properly (before our game even starts). I've seen it happen in low-memory situations before... is your computer bogged down with other stuff?Also, try disabling all other chrome extensions and see if that helps. Some other extensions don't play nice with NaCl.

Share this post


Link to post
Share on other sites

Hi :)I have the Problem, that if I want to play the game, the loading screen stucks at the "common.zip" :(I tried to solve it by doing delete the cache. Doesn't work. So i deleted all cookies but that doesn't work too.What can i do?

Share this post


Link to post
Share on other sites
Sign in to follow this