Jump to content

The ol' GUI lag


Cyde042

Recommended Posts

 I saw someone else making a thread about this a year ago and didn't find a solution after all, but I did track the problem to be DLC related, you see, when I make a world without the dlc, everything runs smooth, no gui lag when buttons are pressed, no lag when I unequip or equip backpacks.

 

I also tried switching on which HDD the game ran, no difference. Has anyone come up with a solution or it's still a mystery?

 

On a side note, the specs are enough for the game to run at best options.

Link to comment
Share on other sites

 I saw someone else making a thread about this a year ago and didn't find a solution after all, but I did track the problem to be DLC related, you see, when I make a world without the dlc, everything runs smooth, no gui lag when buttons are pressed, no lag when I unequip or equip backpacks.

 

I also tried switching on which HDD the game ran, no difference. Has anyone come up with a solution or it's still a mystery?

 

On a side note, the specs are enough for the game to run at best options.

Not trying to divert the issue or anything, but does disabling the mods and playing make any difference, or does it eventually slow down?

 

Sometimes a conflicted modification program causes a memory leak which is not immediately noticeable. 

Link to comment
Share on other sites

Not trying to divert the issue or anything, but does disabling the mods and playing make any difference, or does it eventually slow down?

 

Sometimes a conflicted modification program causes a memory leak which is not immediately noticeable. 

 

 Forgot to update this thread. The issue turned out to be the Mods. But the lag is really noticeable in DLC worlds only. It's weird that I get lag based not on the type of mod, but how many I have enabled. Sucks I can't use many now, otherwise it's unbearable.

Link to comment
Share on other sites

 Forgot to update this thread. The issue turned out to be the Mods. But the lag is really noticeable in DLC worlds only. It's weird that I get lag based not on the type of mod, but how many I have enabled. Sucks I can't use many now, otherwise it's unbearable.

I wasn't here when the big RoG update happened on a hiatus, but there was a discussion on why they had to disable the mods and mods had to be updated or this (or outright crashing) happened.

 

Check that all of your mods are updated to work on RoG. Old mods are notoriously bad with conflicts currently. 

Link to comment
Share on other sites

I wasn't here when the big RoG update happened on a hiatus, but there was a discussion on why they had to disable the mods and mods had to be updated or this (or outright crashing) happened.

 

Check that all of your mods are updated to work on RoG. Old mods are notoriously bad with conflicts currently. 

 

All my current mods work. Even if there wasn't a need for them to be updated. But I'm sure if I enable like 10 compatible, new mods for RoG, it would still lag.

Link to comment
Share on other sites

it's not that it does not work...

 

Read this. Notice the slowdown:

http://en.wikipedia.org/wiki/Memory_leak

 

Ok. I missed what you asked of the memory leak in your post. The game doesn't slow down over time, not one bit. The GUI lag is constant, it occurs only when:

  • I switch backpacks
  • Craft something
  • Press craft menu buttons

And pretty much, only that, whenever I start a new game I sometimes get lag stutters for some seconds, unless I just go to the settings menu and back into the game, it switches to normal, not sure what's this about.

 

Do you use mods? If so, does your game lag when you do the above mentioned tasks. And by lag I mean, lag stutters, it simply doesn't render frames for like 0.2 sec.

Link to comment
Share on other sites

When you have a crafting tab opened, the game "refreshes" it about 20 times in a second... This is for displaying changes of amounts of items in player's inventory...

When I was using an "overclocked" orange amulet in my mod testing (does pickup about 100 items from the ground in a second), and it was picking up a lot of items, AND I opened a crafting tab in the meantime, the FPS changed to about 3-4 FPS, because 'the game / processor' was calculating a new amount of items to display each time I picked up one item...

What processor you have? If it's just above a minimum requirements, it may be lagging like that...

Link to comment
Share on other sites

When you have a crafting tab opened, the game "refreshes" it about 20 times in a second... This is for displaying changes of amounts of items in player's inventory...

When I was using an "overclocked" orange amulet in my mod testing (does pickup about 100 items from the ground in a second), and it was picking up a lot of items, AND I opened a crafting tab in the meantime, the FPS changed to about 3-4 FPS, because 'the game / processor' was calculating a new amount of items to display each time I picked up one item...

What processor you have? If it's just above a minimum requirements, it may be lagging like that...

 

 I have AMD athlon dual core 64 2.3 GHz. Refreshes 20 times?! in 1 second?!

 

Did you see the code for that? If so, where? I wanna try and play around with it. Now, I didn't really try gathering items with the crafting tab opened, but I only get stutters when I interact with it like I said in my other post. But this might explain why I get lag when I craft something.

 

In case you didn't understand, I do not get this lag when I don't any mods activated or if I play with mods activated in a non-dlc world.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...