Sign in to follow this  
FarSideX

Fix for Fullscreen Crash

Recommended Posts

FarSideX    10

I did not find a fix for this through search so if it has been previously posted please ignore.

If Don't Starve exits/crashes on WinXP after choosing 'Fullscreen' and 'Apply'; this is how to fix it.

Edit the settings.ini file in the folder where in game is installed. Under the [graphics] part it should look like this. Add the missing lines and change fullscreen to true. Do not change the windowed_xxxxx = and window_x/y lines. (Unless you want to)

[graphics]
windowed_width = 1024
windowed_height = 576
window_x = 0
window_y = 50
fullscreen = true
display_id = 0
refresh_rate = 59
fullscreen_width = 1680
fullscreen_height = 1050

Set the fullscreen_width and height to your liking and the refresh_rate to your desired refresh - 1 (in the example 59 gives you a refresh of 60)

The games seems to be exiting when it fails to write to this file.

Share this post


Link to post
Share on other sites
-pk-    16

Windows 7 users don't seem to crash, but the refresh rate is messed up and/or not supported by the monitor. I had to use refresh_rate = 60 to get 60 Hz while running on Windows 7.

Share this post


Link to post
Share on other sites
FarSideX    10

Yes under Windows 7 I did not have the problem and I took the info from my Windows 7 box to get it to work on my WinXP box. I did notice a change in the refresh rate setting with the Dec 11 update. It was auto set to 59 Hz in the settings menu but even after changing it, it is still saves 59 in my settings.ini file. It did not do this in the previous update.

I can only suggest trying either on WinXP because that is where the issue is not Win7 but this definitely is what is wrong under WinXP.

Share this post


Link to post
Share on other sites
Critter79    10

I am running Windows 7, mine did not crash but everything froze on me the first time I loaded the game after the update and then paused it. However, it hasn't happened since so not sure of the true cause.

Share this post


Link to post
Share on other sites
-pk-    16
Yes under Windows 7 I did not have the problem and I took the info from my Windows 7 box to get it to work on my WinXP box. I did notice a change in the refresh rate setting with the Dec 11 update. It was auto set to 59 Hz in the settings menu but even after changing it, it is still saves 59 in my settings.ini file. It did not do this in the previous update.

I can only suggest trying either on WinXP because that is where the issue is not Win7 but this definitely is what is wrong under WinXP.

It's still an issue in Win7 that it will force a different refresh rate. The refresh rate the game forces on my system isn't supported at my monitor's native resolution. I had to edit the settings.ini instead of using the options menu because the options menu is really broken.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this