Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

SethR

Patch Notes - Rev 103865 June 12, 2014

Recommended Posts

kraken121    396



It really cant be that hard to rebuild a proper standalone ds patch, since steam is working fine now?







are we gonna wait post-weekend?



Share this post


Link to post
Share on other sites
Madman666    80

 

It really cant be that hard to rebuild a proper standalone ds patch, since steam is working fine now?
are we gonna wait post-weekend?

 

 

I'd say it is not working quite fine for steam users. It starts and plays, but muffled sound FX and constant dinging sounds every time you pick something up or move in inventory does not make DS really fun to play right now. For me at least.

Share this post


Link to post
Share on other sites
kraken121    396

I'd say it is not working quite fine for steam users. It starts and plays, but muffled sound FX and constant dinging sounds every time you pick something up or move in inventory does not make DS really fun to play right now. For me at least.

that has nothing to do with what we are talking about, it will not even update correctly for non steam users...

Share this post


Link to post
Share on other sites
Madman666    80

that has nothing to do with what we are talking about, it will not even update correctly for non steam users...

 

Do you really want an update, that currently has serious bugs, like those that I mentioned? That is what I had in mind. Steam or not - we all are waiting for cleaned up update.

Share this post


Link to post
Share on other sites
SethR    1,229

I'm working on all the issues reported here, please be patient. I should have a hotfix out in the next few hours. I've already got the mod configuration data, erroneous dinging, and erroneous highlighting of locked recipes sorted out. Looking into DSP right now.

Share this post


Link to post
Share on other sites
Madman666    80

I'm working on all the issues reported here, please be patient. I should have a hotfix out in the next few hours. I've already got the mod configuration data, erroneous dinging, and erroneous highlighting of locked recipes sorted out. Looking into DSP right now.

 

Thanks for your hard work, as always. Do not misunderstand me - I wasn't really complaining or trying to sound impatient. Well, maybe I was complaining a little bit, but certainly not about your work - everyone makes some mistakes from time to time) Don't pay my rumblings any attention, you're awesome.

Share this post


Link to post
Share on other sites
SethR    1,229

I strongly agree with Coney on this one. Do you have any more specific reason for this removal, excluding: "it was causing a problem with controller targeting" ?

 

Yes and no: we're preparing to submit Reign of Giants to Sony for release on the PS4. On PS4, you can only use a controller, so this is actually a really bad bug. We try to maintain parity between the various platforms whenever possible, so I removed it.

Share this post


Link to post
Share on other sites
SethR    1,229

Thanks for your hard work, as always. Do not misunderstand me - I wasn't really complaining or trying to sound impatient. Well, maybe I was complaining a little bit, but certainly not about your work - everyone makes some mistakes from time to time) Don't pay my rumblings any attention, you're awesome.

 

That wasn't directed at you, though I do appreciate the kind words and clarification :)

 

I can certainly get a bit snippy myself--it can be pretty difficult juggling being attentive on the forums while also researching and fixing bugs as well as preparing new builds (and submitting to Sony)! I'm sorry if that came off as a bit short. Just trying to communicate that I'm working on the reported issues.

Share this post


Link to post
Share on other sites
SethR    1,229
 

 

It really cant be that hard to rebuild a proper standalone ds patch, since steam is working fine now?
are we gonna wait post-weekend?

 

 

Sorry for the multiple posts, just trying to get caught up. I've built the patch, but it appears to be failing when uploading to our distributors. There's not much I can do about that except keep trying (which I've been doing continually).

Share this post


Link to post
Share on other sites
Madman666    80

That wasn't directed at you, though I do appreciate the kind words and clarification :-)

 

I can certainly get a bit snippy myself--it can be pretty difficult juggling being attentive on the forums while also researching and fixing bugs as well as preparing new builds (and submitting to Sony)! I'm sorry if that came off as a bit short. Just trying to communicate that I'm working on the reported issues.

 

Everything's fine)) I already said it once, but I really do respect you for finding time for nearly everything, even answering most of our questions (even if some of them was answered before).

 

And you're damn effective for managing everything at the same time. If I was like that, I'd probably finished my project already and played DS freely.

Share this post


Link to post
Share on other sites
SethR    1,229

Why is the "Continue" button to the left of "Cancel" in the "WARNING - Mods Disabled" screen? In my opinion, they should switch positions, to minimise the chance of a player clicking through the screen without paying attention.

 

Because it's consistent with all of our other modal popup windows.

Share this post


Link to post
Share on other sites
SethR    1,229

Is there, or will there be a way to delete a saved custom world setting?

 

Once you've saved 5 presets, trying to save an additional preset will prompt you to choose an existing preset to overwrite. There's no utility to delete them, but you can save over them (which effectively deletes the old one).

Share this post


Link to post
Share on other sites
SethR    1,229

For the people experiencing the sound issues (@ProfFarnsworth, @LoayzaPaul, @Madman666, @skazito, and anyone else), a few questions:

- Do you only see the bug on old saves, or does it also occur on newly-generated worlds?

- Are you only seeing DSP issues in the seasons where DSP is used (winter, summer), or during all seasons?

- In games where the DSP issue is present, does it persist after you get to a new season?

- Could you possibly upload an affected save game and/or a video of the issue in action?

Share this post


Link to post
Share on other sites
Madman666    80

For the people experiencing the sound issues (@ProfFarnsworth, @LoayzaPaul, @Madman666, @skazito, and anyone else), a few questions:

- Do you only see the bug on old saves, or does it also occur on newly-generated worlds?

- Are you only seeing DSP issues in the seasons where DSP is used (winter, summer), or during all seasons?

- In games where the DSP issue is present, does it persist after you get to a new season?

- Could you possibly upload an affected save game and/or a video of the issue in action?

 

1. Yep its my 32 days save made before latest update.

2. I got it after winter started. Didn't have a chance to check fall or spring.

3. Likewise didn't got a chance to wait it out - I set all seasons on Long

4. Sure thing. Here it is.

Saves.zip

Share this post


Link to post
Share on other sites
LoayzaPaul    297

For the people experiencing the sound issues (@ProfFarnsworth, @LoayzaPaul, @Madman666, @skazito, and anyone else), a few questions:

- Do you only see the bug on old saves, or does it also occur on newly-generated worlds?

- Are you only seeing DSP issues in the seasons where DSP is used (winter, summer), or during all seasons?

- In games where the DSP issue is present, does it persist after you get to a new season?

- Could you possibly upload an affected save game and/or a video of the issue in action?

it occur on newly-generated worlds

I went to the caves and the same error with sound

Sometimes the sound is lost in the Winter like in Summer (this happened twice)

Share this post


Link to post
Share on other sites
DeathDisciple    292

 

 
 

 

Sorry for the multiple posts, just trying to get caught up. I've built the patch, but it appears to be failing when uploading to our distributors. There's not much I can do about that except keep trying (which I've been doing continually).

 

 

It seems to have gone through -  just got 103987 DS base version, blueprint crash thingy is gone too so I assume the patch applied properly, at least on first glance. The versions are now off in other direction, but only you know if they should be like that or not.

Checking Don't Starve...Latest version: 103987Patching files...Validating files...Consistency check completed.Everything looks good.Checking Reign of Giants...Latest version: 103865Patching files...Validating files...Consistency check completed.Everything looks good.

Share this post


Link to post
Share on other sites
SethR    1,229

 

It seems to have gone through -  just got 103987 DS base version, blueprint crash thingy is gone too so I assume the patch applied properly, at least on first glance. The versions are now off in other direction, but only you know if they should be like that or not.

 

 

There are a couple fixes coming for the RoG build (i.e. I need to make a new build for that 'half' of the game still). But this should at least get everyone able to play again: as far as I know, the game should be relatively stable with the mismatch you described. Thanks for letting us know it went through!

Share this post


Link to post
Share on other sites
UnderwearApp    134

For the people experiencing the sound issues (@ProfFarnsworth, @LoayzaPaul, @Madman666, @skazito, and anyone else), a few questions:

- Do you only see the bug on old saves, or does it also occur on newly-generated worlds?

- Are you only seeing DSP issues in the seasons where DSP is used (winter, summer), or during all seasons?

- In games where the DSP issue is present, does it persist after you get to a new season?

- Could you possibly upload an affected save game and/or a video of the issue in action?

1. Haven't tried a new save.

2.Only season tried was summer, when loading a save in spring, sound was fine.

3. Haven't switched seasons.

4. Will edit with upload.

Share this post


Link to post
Share on other sites
saturn333    20

Once you've saved 5 presets, trying to save an additional preset will prompt you to choose an existing preset to overwrite. There's no utility to delete them, but you can save over them (which effectively deletes the old one).

 

It would be nice to be able to name our presets but not necessary.

 

Here is a problem I found.  If I alter one of my custom existing presets and then save it, none of the changes I made are saved.

 

-But-

 

Altering one of the game's original presets and overwriting an existing custom preset works just as you've described.

 

 

-- Thank You and all the dev team at Klei for my favorite game --

Share this post


Link to post
Share on other sites
SethR    1,229

Here is a problem I found.  If I alter one of my custom existing presets and then save it, none of the changes I made are saved.

 

-But-

 

Altering one of the game's original presets and overwriting an existing custom preset works just as you've described.

 

Hmm, that is indeed strange. I tried to reproduce it myself, but didn't see what you're describing. Could you by any chance provide detailed steps explaining what you did that results in the behavior you described? Thanks!

Share this post


Link to post
Share on other sites
SethR    1,229

Thanks for the info on the DSP issue everybody! It was super helpful and I managed to sort it out. It should fix bugged games on load, but it will definitely do so on season change. At this point, it's a bit late to push out the change to everyone, but we'll get it to you on Monday morning.

Share this post


Link to post
Share on other sites
saturn333    20

Hmm, that is indeed strange. I tried to reproduce it myself, but didn't see what you're describing. Could you by any chance provide detailed steps explaining what you did that results in the behavior you described? Thanks!

 

Here is what I am doing step by step, I hope it helps.

 

1- select a New Game

2- goto World

3- select preset 1

4- change any (Lots, More, Less or None) to Default

5- save as Preset over slot 1

6- the setting I've changed revert to what they were before.

 

-- The slot 1 preset I am altering is an already altered Default Plus

 

I just tested out trying to alter a Default Plus and this is what I found...

 

1- select a New Game

2- goto World

3- select Default Plus

4- change several settings from More and Less to Default

5- save as Preset over an existing slot 1

6- the settings I've changed are reverted to More and Less

 

Hope this is helpful.

Share this post


Link to post
Share on other sites