Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

SethR

Patch Notes - Rev 103865 June 12, 2014

Recommended Posts

I belive steam files are in this location:

...\Steam\userdata\11XXXXXX\219740\remote

11XXXXXXX - would be your steam ID number

 

Got nothing in there either, except for serverbrowser_hist.vdf and sharedconfig.vdf  :-/

Share this post


Link to post
Share on other sites
_Q_    634

Got nothing in there either, except for serverbrowser_hist.vdf and sharedconfig.vdf  :-/

Then you looked at wrong numbered folder, DS dosent have any serverbrowser thingy:P

Share this post


Link to post
Share on other sites
SethR    1,229

Have all of you folks that are seeing issues tried restarting the game, verifying the game files, restarting steam, restarting your computers--all those basic sort of steps? We checked the live Steam build in the office and we're not having any of these issues.

 

If you're having issues, please let us know what version you're on and what platform you're on. Thanks.

Share this post


Link to post
Share on other sites
syrioforel    0

I notice that "When there's a will there's a wilson" now has "(preview)" after it on the title screen,

and that saves are not necessarily deleted but the state is reverted to RoG beta, or an early access

state of a patch, or some such. There were outdated saves present for me from long ago there.

 

Perhaps the game is accessing the wrong store of saves, rather than having wiped them.

Share this post


Link to post
Share on other sites
NightsFire    12

For people wondering about saves, try looking in your C:\Users\[username]\My Documents\Klei\DoNotStarve\save folder (if you're on windows). Please let me know if you see files there (they should be called things like "survival_1"). If they are there, "starting" a game in the appropriate slot (slot 1 in the example) should just resume that game. It sounds like something caused the saveindex file to get wiped erroneously. It shouldn't actually be deleting your saves though.

 

My folder is completely empty except for the mod_config_data folder.  My steam save folder still seems to have everything though.  

 

On another note, the game seems to be recognizing a file that I created for beta testing one of the cave updates. Is the update supposed to be called "Where There's a Wilson... (preview)"?

Share this post


Link to post
Share on other sites
Madman666    80

Have all of you folks that are seeing issues tried restarting the game, verifying the game files, restarting steam, restarting your computers--all those basic sort of steps? We checked the live Steam build in the office and we're not having any of these issues.

 

If you're having issues, please let us know what version you're on and what platform you're on. Thanks.

 

I've tried everything you mentioned. And also I read this thread before updating DS and starting it, so I backed up my steam savefolder, then started DS - no save and in the right slot it just starts to generate new world. I then inserted my backed save - no change. Survival 1-1 appeared in the right slot and it just starts generating new world instead of resuming my saved one.

Share this post


Link to post
Share on other sites
SethR    1,229

Looks like the wrong build got set live somehow, which means the game is looking for a different file than your normal ones when it is finding save games. We're fixing it right now. We'll have a fix for the crash some of you are reporting shortly as well.

Share this post


Link to post
Share on other sites

Have all of you folks that are seeing issues tried restarting the game, verifying the game files, restarting steam, restarting your computers--all those basic sort of steps? We checked the live Steam build in the office and we're not having any of these issues.

 

If you're having issues, please let us know what version you're on and what platform you're on. Thanks.

 

Have restarted Steam several times. I'm reporting version 103814 WIN32_STEAM, which seems to be 1 lower than the revision # in the OP. I'm on Windows 7 x64 w/ SP!. I'm backing up my game right now, not sure how to verify files but I can delete the local content and start from there. Will post back when done.

Share this post


Link to post
Share on other sites
Mila    0

My folder is completely empty except for the mod_config_data folder.  My steam save folder still seems to have everything though.  

 

On another note, the game seems to be recognizing a file that I created for beta testing one of the cave updates. Is the update supposed to be called "Where There's a Wilson... (preview)"?

 

Same thing going on here :/ is there any fix for this?

Share this post


Link to post
Share on other sites
Invader    0

I checked that folder and there was a file called "saveindex". Is that what I'm supposed to be looking for?

Share this post


Link to post
Share on other sites
SethR    1,229

Same thing going on here :/ is there any fix for this?

 

The fix should be live right now.

Share this post


Link to post
Share on other sites
SethR    1,229

Humph... My updater is saying it is still 1.102572... Why? (Yes, I bought game (standalone RoG).

 

Standalone lags behind a bit. The update should be going live for standalone in the next hour or so.

Share this post


Link to post
Share on other sites
Wade    309

Yup, I dropped the ball and kicked it on the roof.

 

Sorry about this everyone!  Let us know if your save files and morgue still aren't appearing.

Share this post


Link to post
Share on other sites
MaskdTux    0

I also tried restarting everything after the update and still nothing is in that file. I'm hoping that I can backup the file using the Steam save cloud.

Share this post


Link to post
Share on other sites
Madman666    80

Well, now it just opens for a second, then crashes...

 

Log file says this:

Starting up

Don't Starve: 103815 WIN32_STEAM
Build Date: 2014-06-11_19-11-55
THREAD - started 'GAClient' (6560)
HttpClient::ClientThread::Main()
cGame::InitializeOnMainThread
WindowManager::Initialize
RestoreWindowPosition
   Saved Client Pos (0 x 22)
   Adjusted Window Pos (-8 x -8)
EnsureWindowOnScreen
   All good.
GLInfo
~~~~~~
GL_VENDOR: Google Inc.
GL_RENDERER: ANGLE (NVIDIA GeForce GTX 580)
GL_VERSION: OpenGL ES 2.0 (ANGLE 1.0.0.2249)
GL_SHADING_LANGUAGE_VERSION: OpenGL ES GLSL ES 1.00 (ANGLE 1.0.0.2249)
THREAD - started 'WindowsInputManager' (6352)
OpenGL extensions (19, 19):
GL_ANGLE_depth_texture
GL_ANGLE_framebuffer_blit
GL_ANGLE_framebuffer_multisample
GL_ANGLE_instanced_arrays
GL_ANGLE_pack_reverse_row_order
GL_ANGLE_texture_compression_dxt3
GL_ANGLE_texture_compression_dxt5
GL_ANGLE_texture_usage
GL_ANGLE_translated_shader_source
GL_EXT_read_format_bgra
GL_EXT_robustness
GL_EXT_texture_compression_dxt1
GL_EXT_texture_format_BGRA8888
GL_EXT_texture_storage
GL_OES_get_program_binary
GL_OES_packed_depth_stencil
GL_OES_rgb8_rgba8
GL_OES_standard_derivatives
GL_OES_texture_npot
GL_MAX_TEXTURE_SIZE = 16384
GL_MAX_TEXTURE_IMAGE_UNITS = 16
GL_MAX_RENDERBUFFER_SIZE = 16384
GL_MAX_VIEWPORT_DIMS = 16384, 16384
GL_MAX_VARYING_VECTORS = 10
GL_MAX_VERTEX_ATTRIBS = 16
GL_MAX_VERTEX_UNIFORM_VECTORS = 254
GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = 4
GL_MAX_FRAGMENT_UNIFORM_VECTORS = 221
4 compressed texture formats
texture format 0x83f0
texture format 0x83f1
texture format 0x83f2
texture format 0x83f3
cDontStarveGame::DoGameSpecificInitialize()
cGame::StartPlaying
LOADING LUA
DoLuaFile scripts/main.lua
DoLuaFile loading buffer scripts/main.lua
DoLuaFile Error: ...amapps/common/dont_starve/data/scripts/constants.lua:249: variable 'PYRO_ENABLED' is not declared
LUA ERROR stack traceback:
        =[C] in function 'error'
        D:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/strict.lua(23,1)
        D:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/constants.lua(249,1) in main chunk
        =[C] in function 'require'
        scripts/main.lua(105,1) in main chunk
...amapps/common/dont_starve/data/scripts/constants.lua:249: variable 'PYRO_ENABLED' is not declared
LUA ERROR stack traceback:
        =[C] in function 'error'
        D:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/strict.lua(23,1)
        D:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/constants.lua(249,1) in main chunk
        =[C] in function 'require'
        scripts/main.lua(105,1) in main chunk
Error loading main.lua
Failed mSimulation->Reset()
Error during game initialization!
Collecting garbage...
lua_gc took 0.00 seconds
~SimLuaProxy()
lua_close took 0.00 seconds
HttpClient::ClientThread::Main() complete
Shutting down
 

Share this post


Link to post
Share on other sites
Minik435    50

Oh, thanks. I though that because I downloaded it from bad torrents (just joking, not to piracy.) :p I hope you will do this fix fast. Thank you for your work on the best game I ever had :D

Share this post


Link to post
Share on other sites
Mila    0

Well, now it just opens for a second, then crashes...

 

Same... from the log:

 

Starting upDon't Starve: 103815 WIN32_STEAMBuild Date: 2014-06-11_19-11-55THREAD - started 'GAClient' (6484)HttpClient::ClientThread::Main()cGame::InitializeOnMainThreadWindowManager::InitializeRestoreWindowPosition   Saved Client Pos (0 x 23)   Adjusted Window Pos (-8 x -8)EnsureWindowOnScreen   All good.GLInfo~~~~~~GL_VENDOR: Google Inc.GL_RENDERER: ANGLE (NVIDIA GeForce 9600 GT)GL_VERSION: OpenGL ES 2.0 (ANGLE 1.0.0.2249)GL_SHADING_LANGUAGE_VERSION: OpenGL ES GLSL ES 1.00 (ANGLE 1.0.0.2249)OpenGL extensions (19, 19):GL_ANGLE_depth_textureGL_ANGLE_framebuffer_blitGL_ANGLE_framebuffer_multisampleGL_ANGLE_instanced_arraysGL_ANGLE_pack_reverse_row_orderGL_ANGLE_texture_compression_dxt3GL_ANGLE_texture_compression_dxt5GL_ANGLE_texture_usageGL_ANGLE_translated_shader_sourceGL_EXT_read_format_bgraGL_EXT_robustnessGL_EXT_texture_compression_dxt1GL_EXT_texture_format_BGRA8888GL_EXT_texture_storageGL_OES_get_program_binaryGL_OES_packed_depth_stencilGL_OES_rgb8_rgba8GL_OES_standard_derivativesGL_OES_texture_npotTHREAD - started 'WindowsInputManager' (6668)GL_MAX_TEXTURE_SIZE = 8192GL_MAX_TEXTURE_IMAGE_UNITS = 16GL_MAX_RENDERBUFFER_SIZE = 8192GL_MAX_VIEWPORT_DIMS = 8192, 8192GL_MAX_VARYING_VECTORS = 10GL_MAX_VERTEX_ATTRIBS = 16GL_MAX_VERTEX_UNIFORM_VECTORS = 254GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = 4GL_MAX_FRAGMENT_UNIFORM_VECTORS = 2214 compressed texture formatstexture format 0x83f0texture format 0x83f1texture format 0x83f2texture format 0x83f3cDontStarveGame::DoGameSpecificInitialize()cGame::StartPlayingLOADING LUADoLuaFile scripts/main.luaDoLuaFile loading buffer scripts/main.luaDoLuaFile Error: ...amapps/common/dont_starve/data/scripts/constants.lua:249: variable 'PYRO_ENABLED' is not declaredLUA ERROR stack traceback:        =[C] in function 'error'        F:/Steam/steamapps/common/dont_starve/data/scripts/strict.lua(23,1)        F:/Steam/steamapps/common/dont_starve/data/scripts/constants.lua(249,1) in main chunk        =[C] in function 'require'        scripts/main.lua(105,1) in main chunk...amapps/common/dont_starve/data/scripts/constants.lua:249: variable 'PYRO_ENABLED' is not declaredLUA ERROR stack traceback:        =[C] in function 'error'        F:/Steam/steamapps/common/dont_starve/data/scripts/strict.lua(23,1)        F:/Steam/steamapps/common/dont_starve/data/scripts/constants.lua(249,1) in main chunk        =[C] in function 'require'        scripts/main.lua(105,1) in main chunkError loading main.luaFailed mSimulation->Reset()Error during game initialization!Collecting garbage...lua_gc took 0.00 seconds~SimLuaProxy()lua_close took 0.00 secondsHttpClient::ClientThread::Main() completeShutting down

Share this post


Link to post
Share on other sites
Wade    309

Sigh...

 

Once again, sorry all. We think we know what the issue is, and are compiling a new build right now to address the start-up crash.

 

Should be up shortly. We appreciate your patience!

Share this post


Link to post
Share on other sites
SethR    1,229

Yep, we're aware of the crash. Fix is building now and will get rolled out ASAP. Bear with us for an hour or so while it comes together.

Share this post


Link to post
Share on other sites
G4lle    1
Guys, this isn't serious. You can't publish a build if it doesn't work. 

I lost my save game, and (more important) my son's savegame!

Please do something. Now you aware that the game crashes and we can't play.

 

BTW, this game is a gem. Fantastic work and great imagination and effort behind this development.

Share this post


Link to post
Share on other sites