Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Vimko

[Linux] Issue with libcurl-gnutls.so.4. Can't start the game.

Recommended Posts

Vimko    7

Platform Linux 32-bit Standalone
Do you use mods? NO
Version Number 102572

Hi, i just updated to the newest version. But i can't run the game, because, apparently, it needs libcurl-gnutls.so.4 library. It wasn't needed before by the game.
So, i need to recompile libcurl with gnutls support? Because, it looks like, my libcurl has no gnutls support:
 

$ ldd libcurl.so.4.3.0 	linux-gate.so.1 (0xffffe000)	libidn.so.11 => /usr/lib/libidn.so.11 (0xb7671000)	libssl.so.1 => /lib/libssl.so.1 (0xb760e000)	libcrypto.so.1 => /lib/libcrypto.so.1 (0xb7451000)	liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0xb7443000)	libldap-2.4.so.2 => /usr/lib/libldap-2.4.so.2 (0xb73f8000)	libz.so.1 => /lib/libz.so.1 (0xb73e2000)	libc.so.6 => /lib/libc.so.6 (0xb7256000)	libdl.so.2 => /lib/libdl.so.2 (0xb7251000)	libresolv.so.2 => /lib/libresolv.so.2 (0xb7237000)	libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb721c000)	/lib/ld-linux.so.2 (0xb7727000

Error i get, launching game:

./dontstarve: error while loading shared libraries: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory

Share this post


Link to post
Share on other sites
simplex    2,608

Which distro? And is your distro 32 bits, or just the Don't Starve executable?

Share this post


Link to post
Share on other sites
Vimko    7

Which distro? And is your distro 32 bits, or just the Don't Starve executable?

Slackware. 32-bit.

I'm using Standalone (DRM-Free) version of Don't Starve with ROG DLC.

So, yes, both distro and executable are 32-bit, of course.

Share this post


Link to post
Share on other sites
simplex    2,608

Slackware. 32-bit.

I'm using Standalone (DRM-Free) version of Don't Starve with ROG DLC.

So, yes, both distro and executable are 32-bit, of course.

Well, apparently libcurl-gnutls is not available as a Slackware package (unlike in Arch Linux, Ubuntu, Debian and Fedora, at least). So you could either compile it yourself or grab it from the Steam runtime, since it is there (this would involve installing this, of course, even if temporarily just for that).

Share this post


Link to post
Share on other sites
Vimko    7

I recompiled curl with --without-ssl and --with-gnutls options, got libcurl.so.4.3.0, moved it to /usr/lib/libcurl-gnutls.so.4

Problem solved.

Share this post


Link to post
Share on other sites
Pash    0

In my case (Gentoo Linux / Don't Starve v.104670 with RoG DLC, standalone 32-bit executable, no mods) to start the game it was enough to create a symlink for the absent library (even though I don't have gnutls-enabled libcurl.so), like so:

ln -s libcurl.so.4 /usr/lib/libcurl-gnutls.so.4

Share this post


Link to post
Share on other sites
Pillcrow    0

 

In my case (Gentoo Linux / Don't Starve v.104670 with RoG DLC, standalone 32-bit executable, no mods) to start the game it was enough to create a symlink for the absent library (even though I don't have gnutls-enabled libcurl.so), like so:

ln -s libcurl.so.4 /usr/lib/libcurl-gnutls.so.4

This solution worked for me too (Slackware 14.1 X86_64)

But first i had to install the multilib (http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:multilib)

Share this post


Link to post
Share on other sites
Vimko    7

I've the same problème.

 

But i'm a new user on Linux, so i need some help :-) :-)

 

How to install multilib ?

And after ?

 

Thx in advance

 

I'm not using Slackware64, but i think the link Pillcrow provided is pretty much straightforward.

If you still keep facing difficulties, feel free to join Linuxquestions forums. It is official Slackware forums.

Share this post


Link to post
Share on other sites