Jump to content

[Crash] Game crashes shortly after starting new game

Recommended Posts

Bug Submission

Please choose a category



  • Steam

Version Number


Issue title

Game crashes shortly after starting new game

Steps to reproduce

- Open Steam

- Push "Play" on Don't Starve

- Push "New Game" or "Create New World" upon starting the game

- Watch the game load up and get ready to play


Describe your issue

So I recently bought Don't Starve on Steam a couple of days ago after having been following the game's progress for some time now via the Don't Starve blog, and after downloading it and installing it onto Steam, I've found that every time I try to start actually playing the game, the game crashes after about 2-10 seconds of playing.

The weird thing about this crash is that the game doesn't crash until I actually start PLAYING it. As in - the main menu loads up just fine, the loading screens are just fine, etc. It only crashes once I start a new game or create a new world and play it just fine for about 5 seconds before it crashes (I haven't had the benefit of being able to load a game because I haven't been able to play long enough to save it before it crashes again).

I tried every single possible fix that I've come across on these forums, and still - I get the exact same result. Here's a brief summary of some of the things I have tried:

- Manually installing updates for graphics card drivers, as well as all other drivers for that matter.

- Going into the Don't starve folder and manually installing the DirectX executable as well as the C++ executable.

- Running Steam in Administrator mode

- Reinstalling Don't Starve and verifying the cache files

- Running Don't Starve in compatibility mode for Windows XP

I searched around the forums and it appears no one else but one other guy has the same issue as me, and his complaints haven't even been answered yet as far as I can tell. I really hope I can get this fixed
, because as it stands, I'm currently the only one of my friends who hasn't been able to play their copy of Let's Starve, and ironically enough, I'm the only one out of them who actually forked out the cash for the privilege. (My other two friends are playing the free Don't Starve copies that were sent to them from other Steam members)

Please, please, please, let me know what I can do to fix my copy of Don't Starve, because this really sucks not being able to play it right now.

Here are my system specs:

OS: Microsoft Windows Vista Home Basic Edition Service Pack 1 (build 6000), 32-bit

CPU : Intel® Core2 Duo CPU T5270 @ 1.40GHz

CPU speed: 1.4 GHz

RAM: 2.1 GB

Video Card: Mobile Intel® 965 Express Chipset Family

Sound Card: SigmaTel High Definition Audio CODEC

Free Disk Space: 114.6 GB

Link to comment
Share on other sites

Well I hope this problem can be fixed Soon, because currently the laptop I'm on is the only PC that I own, and thus, my only way of playing Don't Starve, seeing as how it doesn't run on Macs. I'd really like to be able to play the thing that I spent my money on, because otherwise it feels like this may have been just a waste of money on my part, seeing as how I am unable to experience the product. My system runs other games like Killing Floor and Grand Theft Auto: Vice City just fine, and seeing as how this is a simple 2D game set in a 3D backdrop, the last thing on my mind was "I better check to see if my computer will be able to run it."

I would really like it if my complaint didn't just disappear into the abyss of the forums' history before getting this issue solved or somehow figuring out a way to get my money back.

Link to comment
Share on other sites

Here's the log.txt that I got after another crash:

Starting up

Don't Starve: 70495

Build Date: 2012-12-11_23-09-06

THREAD - started 'GAClient' (2112)





WindowManager::SetFullscreen(0, 1280, 720, 60)

SystemEvent::Resize {1280, 720}

WindowManager::Resize [0] {1280, 720}




DoLuaFile data/scripts/main.lua

DoLuaFile loading buffer data/scripts/main.lua

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\main.lua(105,1) running main.lua


Reset() returning





/anon/new - POST/{"character":"wilson","name":"Test name","size":"small"}


I didn't see any files under "mdmp" so unfortunately I can't provide those at the moment. And also, I'm not sure where to find a "dxdiag" report. Hope the log file helps though.

Link to comment
Share on other sites


  • Create New...